Kaspersky
Question

Установка нового KSC 11 со старой базой


  • Community Citizen
  • 12 replies

Добрый день.

Делаем новую установку KSC 11 на другую машину. При установке

во-первых, не выходит окно о выборе пользователя под кем хотим произвести установку. В связи с этим не видна база данных(будет действующая использоваться далее)

во-вторых, есть такая возможность сначала развернуть новый сервер с использованием старой базы(одновременно два KSC сервера будут работать) и удалить старый как новый будет полностью настроен?

Или у нас только один выход - сначала удалить старый KSC и после исталлить на старую базу, которая лежит удаленно?
 


14 replies

Userlevel 7
Badge +9

@freq, ознакомьтесь с этими статьями:

https://support.kaspersky.com/KSC/11/ru-RU/13057.htm

https://support.kaspersky.com/KSC/11/ru-RU/3675.htm

@freq, ознакомьтесь с этими статьями:

https://support.kaspersky.com/KSC/11/ru-RU/3675.htm

Эта статья была изучена ранее. 

 

Ответы на вопросы я не заметил, получится ли одновременно 2 сервера обратить к одной базе без иерархии

Userlevel 7
Badge +9

во-вторых, есть такая возможность сначала развернуть новый сервер с использованием старой базы(одновременно два KSC сервера будут работать) и удалить старый как новый будет полностью настроен?

Именно этот сценарий и описан в статье, которую вы изучили по вашим словам.

Устанавливаете новый сервер, восстанавливаете конфигурацию из бэкапа, подключаете к нему рабочие станции и затем удаляете старый.

Выбор пользователя будет если вы выбираете выборочную установку. При стандартной установке используются настройки по-умолчанию.

во-вторых, есть такая возможность сначала развернуть новый сервер с использованием старой базы(одновременно два KSC сервера будут работать) и удалить старый как новый будет полностью настроен?

Именно этот сценарий и описан в статье, которую вы изучили по вашим словам.

Не заметил я упоминания, что необходимо создавать новую БД для продолжения установки :blush:

 

Произвели установку, создали новую БД. Доменное имя новой машины естетственно отличается от прошлой, которое будет удалять и соответственно IP адрес. Необходимо назначить новой машине с KSC предыдущий адрес и имя машины/сервера администрирования.

При смене IP адреса подключение к серверу администрирования(с самой машины подключаемся к localhost) не удается. Переименование сервера администрирования как я понимаю - невозможно?

Userlevel 4
Badge +3

 

Произвели установку, создали новую БД. 

Не совсем понятно, после новой установки из резервной копии старого сервера восстановление на новом не производили?  Даже сертификат не восстанавливали?

При смене IP адреса подключение к серверу администрирования(с самой машины подключаемся к localhost) не удается. Переименование сервера администрирования как я понимаю - невозможно?

При этом не только ip адрес сменили, но и переименовали?

Если в консоли KSC удалить и заново создать подключение серверу к localhost, подключения тоже не происходит?

 

Произвели установку, создали новую БД. 

Не совсем понятно, после новой установки из резервной копии старого сервера восстановление на новом не производили?  Даже сертификат не восстанавливали?

При установке KSC возможности выбрать старую базу - нет. Создаем по этому новую. Установил новый сервер, через KLBackup вытаскиваю старую базу на новый сервер. Формируется новый сертификат, подтягиваются инсталл пакеты, политики и прочее, однако связи с машинами нет(логично, т.к. dns другой и адрес)

 

При этом не только ip адрес сменили, но и переименовали?

Никак нет. Машины в одном домене и сделать одинаковые dns - не получится. С адресами ситуация такая, что при остановке действующего KSC(для того, чтобы забрать его адрес) новый KSC не может подключиться к localhost.

 

Если в консоли KSC удалить и заново создать подключение серверу к localhost, подключения тоже не происходит?

Пока это не делал.

Удалил новый сервер администрирования на новой машине. Выключил старую машину. На новой машине назначил адрес предыдщуей(к которой подключались все рабочие станции) и такое же доменное имя. Так же через klbackup подтянул базу данных, создал на новой машине новый сервер администрирования, подписал сертификат и вновь недоступны рабочие станции.

Какие необходимо сделать действия для синхроназации с новым сервером?

Userlevel 4
Badge +3

У вас опечатка в порядке действий? Очередность на самом деле такая была: 

создал на новой машине новый сервер администрирования, через klbackup подтянул базу данных

Вот под этим что понимаете “подписал сертификат”? Открыл mmc консоль, при первом подключении согласился с подключением к серверу с предложенным сертификатом?

 

С какой-нить рабочей станции запустите утилиту klnagchk, проанализируйте на что ругаться будет

Userlevel 7
Badge +7

Сравните по отпечаткам сертификаты на Сервере администрирования и на проблемном хосте:

 

c:\ProgramData\Kaspersky Lab\adminkit\1103\klserver.cer

С большой вероятностью они будут разные.

В бекапе должен быть тот же сертификат, что на хосте.

У вас опечатка в порядке действий? Очередность на самом деле такая была: 

создал на новой машине новый сервер администрирования, через klbackup подтянул базу данных

Вот под этим что понимаете “подписал сертификат”? Открыл mmc консоль, при первом подключении согласился с подключением к серверу с предложенным сертификатом?

 

С какой-нить рабочей станции запустите утилиту klnagchk, проанализируйте на что ругаться будет

Я сначала на новой машине поднял консоль администрирования на произвольном имени и адресе машины и залил бэкап БД.

 

ПОсле вашего сообщения я снес этот поднятый сервер администрирования, назначил ему имя и адрес машины, которые совпадают с прошлой машиной консоли администрирования(естественно переименовав заранее прошлую машину, поменяв ей адрес на произвольный и выключив ее) и вновь сделал восстановление из бэкапа.

Вот лог с одной из машин. Ничего критичного не увидел, кроме как это:

Попытка соединения с Сервером администрирования...Не удалось установить соединение с удаленным устройством (местонахождение: 'Тут адрес, который совпадает с новой машиной KSC'): отказ в соединении.

 

Сравните по отпечаткам сертификаты на Сервере администрирования и на проблемном хосте:

 

c:\ProgramData\Kaspersky Lab\adminkit\1103\klserver.cer

С большой вероятностью они будут разные.

В бекапе должен быть тот же сертификат, что на хосте.

Этот же серт. Единственное что, на прошлом KSC формат серийного номера aa bb cc  и тд, а на новой aabbcc. Единственная разница, которую я заметил в этих сертификатах.

Userlevel 4
Badge +3

Попытка соединения с Сервером администрирования...Не удалось установить соединение с удаленным устройством (местонахождение: 'Тут адрес, который совпадает с новой машиной KSC'): отказ в соединении.

Порты бы проверить 13000, 14000, открыты ли на сервере. Да и вообще остальные тоже не помешало https://support.kaspersky.com/KSC/13/ru-RU/158830.htm

Попытка соединения с Сервером администрирования...Не удалось установить соединение с удаленным устройством (местонахождение: 'Тут адрес, который совпадает с новой машиной KSC'): отказ в соединении.

Порты бы проверить 13000, 14000, открыты ли на сервере. Да и вообще остальные тоже не помешало https://support.kaspersky.com/KSC/13/ru-RU/158830.htm

Все верно, 13000 и 14000 были закрыты. 13000 удалось открыть посредством правила в брандмауэре, а вот 14000 не хотел открываться и помог выбор пункта “Открыть порт Сервера без аутентификации” и порт 14000.

Рабочие станции сделали повторный пакет пульс и они теперь видны сервером администрирования.

Теперь вопрос по SVM. У нас есть несколько таких машин. Связь есть, гипервизор их видит. В параметрах гипервизор готов, а в списках подключенных SVM нет. Не потребуется ли нам переустановка SVM?

Userlevel 4
Badge +3

Там свои еще могут быть порты https://support.kaspersky.ru/KSV/5.0/ru-RU/97889.htm

И уже не помню, в каком случае, но мне как-то приходилось на svm заходить и запускать klmover для коннекта с KSC

Там свои еще могут быть порты https://support.kaspersky.ru/KSV/5.0/ru-RU/97889.htm

И уже не помню, в каком случае, но мне как-то приходилось на svm заходить и запускать klmover для коннекта с KSC

Развернул новый SVM(удалил старый и на этот же хост накатил новый). Он также не появился в списках подключенных. По портам пришлось создать правило дополнительно для 22 tcp и 15000 udp. Порты не слушаются. На старой рабочей машине они также не слушаются.

 

 

Reply