Kaspersky
Solved

Проблема с контролем устройств

  • 28 September 2020
  • 12 replies
  • 222 views

  • Community Citizen
  • 6 replies

Здравствуйте.

В домене установлен Kaspersky Security Center 12.0.0.7734

На клиентах под операционными системами Win 7/10 установлен Kaspersky Endpoint Security для Windows 11.4.0.233

Настраиваю Контроль безопасности - Контроль устройств - всем запрещено использовать “съемные диски”. При подключении флэшки к клиентскому компьютеру вижу сообщения в журнале KSC о невозможности использовать устройство.

Вношу эту флэшку в список “Доверенные устройства” для всех пользователей - и тут странное поведение, зависит от разных флэшек/внешних винтов:

  1. Флэшка успешно вносится и видится на клиентах, но не на всех.
  2. Заполняю данные в окне “Доверенные устройства - Добавить (по идентификатору) - копирую в поле название/модель данные устройства из сообщения из ошибки доступа - Обновить” - и флэшка не найдена. При ручном добавлении через импорт xml она добовляется, но работает так же, как и в пункте 1.

Можете подсказать решение такой проблемы?

icon

Best answer by Demiad 29 September 2020, 07:51

В комьюнити разработчиков никогда не бывает, официальной поддержки считай тоже.

Если у Вас есть силы, то воспроизведите проблему на тестовой версии KES 11.5 

и, видимо, в этот раздел отпишите баг-репорт.

11.5, полагаю, появится достаточно скоро. 

//ModNote:  на KES 11.5 бета проблема отсутствует.

View original

12 replies

Userlevel 7
Badge +5

В комьюнити разработчиков никогда не бывает, официальной поддержки считай тоже.

Если у Вас есть силы, то воспроизведите проблему на тестовой версии KES 11.5 

и, видимо, в этот раздел отпишите баг-репорт.

11.5, полагаю, появится достаточно скоро. 

//ModNote:  на KES 11.5 бета проблема отсутствует.

Userlevel 4
Badge +2

Косвенное наблюдение, может в эту сторону надо покопать, но некоторые флешки определяются как портативное устройство MTP

Смотрю тип устройства в сообщении о блокировке.

К тому же, не указываю тип устройства при добавлении - там есть “все устройства” и потом выбрать нужное.

Например, в сообщении о запрете доступа к устройству:

Тип события:     Операция с устройством запрещена
Устройство\Категория устройства:     Устройство
Устройство\Тип устройства/Тип шины:     Съемные диски
Устройство\Идентификатор устройства:     USBSTOR\DISK&VEN_WD&PROD_ELEMENTS_SE_25FE&REV_1026\575837314141393939345056&0
Устройство\VID/PID устройства:     VEN_WD&PROD_ELEMENTS_SE_25FE
Пользователь:     <мой доменный пользователь> (Не определено)
Результат\Решение:     Запрещать
Результат\Операция:     Чтение

А при попытке это устройство найти для добавления:

 

Userlevel 4
Badge +2

Не знаю внутреннюю механику, но скорее поиск осуществляется в реестре оборудования, который наполняется агентом администрирования и контролем устройств KES.  Проверьте политику агента - Хранилища - Информация о реестре оборудования, должно быть закрыжино и залочено. 

Аналогично в политике KES залочено “Контроль устройств” и “Параметры контроля устройств”. Сорри, если это очевидно, других идей нет.

На этой машине стояла, как и везде, 11.4.0.233.

На KSC сделал инстал.пакет для удаленной установки, обновил клиента и все заработало.

Советуете бету убрать и ждать релиз? Комп клиента не критичен, упадет - никто и не заметит, использовал для теста...

Создайте запрос в CA, Вам выдадут приватный патч, может, он устранит проблему на 11.4

Конечно, настроен сбор информации об оборудовании и запрещен клиентам к изменению. Политики применяются успешно.

В общем, я пока полностью в тупике…

Вот запрос клиента о желании использовать флэшку:

Вот поиск устройства по идентификатору (использую маску *, потому что нет устройства):

Прописал запрашиваемое устройство руками через импорт xml - и клиент нормально работает с флэшкой.

Разработчики тут бывают? Могут прокомментировать/посоветовать что-нибудь?

Понятно, спасибо.

Сейчас, к сожалению,  нет возможности пробовать тест.

Userlevel 3
Badge +1

День добрый.

Есть ли устройство в списке оборудования KSC (привел пример поиска по ИД)?

 

Одно из руками добавленных устройств есть (не знаю, было ли раньше) - однако, в окне добавления доверенных устройств оно все равно не находится.

Второго устройства нет (и в окне добавления доверенных устройств), хотя руками в доверенные устройства оно уже добавлено.

В комьюнити разработчиков никогда не бывает, официальной поддержки считай тоже.

Если у Вас есть силы, то воспроизведите проблему на тестовой версии KES 11.5 

и, видимо, в этот раздел отпишите баг-репорт.

11.5, полагаю, появится достаточно скоро. 


Все же решил найти время, накатил бету на один комп - заработало все корректно.

И ищется автоматом и, после добавления в доверенные - разрешается доступ.

С нетерпением жду 11.5, не рискну на все машины ставить бету, хоть и рабочую.

Спасибо.

Userlevel 7
Badge +5

@epth , а этой же машине если 11.4 поставить, то проблема будет?  Тогда точно дело не в агенте администрирования KSC будет и правда лучше будет подождать 11.5.

Бету ставить нельзя совсем, ЛК не предусматривает использование беты в коммерческой эксплуатации, только в рамках участия в бета-тестировани.

На этой машине стояла, как и везде, 11.4.0.233.

На KSC сделал инстал.пакет для удаленной установки, обновил клиента и все заработало.

Советуете бету убрать и ждать релиз? Комп клиента не критичен, упадет - никто и не заметит, использовал для теста...

Reply