Kaspersky
Question

Using Soulseek

  • 10 September 2021
  • 8 replies
  • 89 views

How can I use Soulseek while Kaspersky VPN is active - Soulseek reports my listening port as closed. I’ve tried giving app permission in Kaspersky Internet Security etc. but still get the same report. Without VPN, my port reports open.

Any help would be gratefully received - thanks.


8 replies

Userlevel 7
Badge +9

@Kevan Welcome.

Welcome, did you try this :

→ Settings → Firewall Settings → Packet Rules → Add → Protocol : (e.g.) “TPC”   →  Local ports

Thanks for the response - I assume I put my listening port in the ‘local ports’ box? I’ve just tried this and Soulseek still reports the port as being closed. 

Userlevel 7
Badge +9

@Kevan Can you please specify which Port ?

 

 

 

“You can specify a range of remote or local ports (for example, 6660–7000), list multiple ports separated by commas, or combine both methods (for example, 80–83,443,1080).”

I am adding the protocol in Kaspersky Internet Security, right? There doesn’t seem to be a way to configure this in the VPN app. Port is 61862 but I can easily change it, if I need to.

Userlevel 7
Badge +9

@Kevan Correct , did you try Soulseek  without VPN :thinking:  
 VPN has no Port option.

Thanks for bearing with me! When not using VPN, Soulseek reports port open and people can upload from me but I can’t download. I have a strong suspicion that my ISP is blocking the certain applications or the download of certain file types, hence me trying to use VPN. As soon as I initiate the VPN, Soulseek reports port closed.

This has only started to happen in the last week or so - it’s very odd.

Userlevel 7
Badge +9

@Kevan You are welcome.

Did you try to switch to another DNS Server e.g. Goolgle DNS , Open DNS , Cloudflare …

Where would I alter that? I don’t understand why I can search and queue things but they won’t download - that’s what makes me think it’s my ISP blocking certain file types and apps.

 

UPDATE: Success - all sorted now!  I have updated my router settings and this has cured it. 

Thank you so much for all your help - it is greatly appreciated.

Reply