Secure connection browsers show current location instead of changed

  • 28 February 2020
  • 7 replies


I have kaspersky secure connection subscription, I am based in the UK and when I select Germany my ip does show Germany on www.whatismyip.com but Google search on Chrome, Firefox and Internet Explorer says United Kingdom.

I thought once a different country is selected via secure connection then the browsers to show a different country instead of current one...what am I missing here?

I bought this so I can search results of a different country’s search index (without the need of changing browsers settings and workarounds).

Please advice

Thank you.

7 replies

Userlevel 7
Badge +8

Hello @kashelp, welcome.

A website can retrieve the original IP via WebRTC. Many VPNs do not prevent this.

In Firefox you can disable WebRTC:

  • about:config
  • search 'media.peerconnection.enabled'
  • set the value to 'false’

Please try this and then give us some feedback.

@Schulte Hello,

Thank you for your quick response to my post.

I have tried this but unfortunately it did not help.

Thank you.

Userlevel 7
Badge +8

Too bad, it should have worked.

Browser cache cleared?
FF restarted?

Maybe you have IPv6 active as well?


Yes I have tried all these and unfortunately didn’t work.
If Kaspersky secure connection is failing to do any of these then I am failing to understand whether it is useful at all.

Would you be able to advice where I can request for a full refund as this is not working and did nowhere mentioned about upcoming issues and limitations?

Thank you.

Userlevel 7
Badge +11

Hello @kashelp,

  • Is clearing the browser cache & history done between each location test?

  •  Please let us know?

Thank you:pray_tone3:



Yes i have taken all these steps and did not help.

Thank you.

Userlevel 7
Badge +9


Also , please contact K-Lab Technical Support https://center.kaspersky.com 

To obtain a refund please go to https://support.kaspersky.com/common/buy/14828