Kaspersky
Solved

Running openVPN over Kaspersky Secure Connection -can i run it?

  • 6 January 2021
  • 7 replies
  • 162 views

Tried to run openVPN with KSC enabled - very strange behavior - can i use both in the same time?

icon

Best answer by Cathy 27 January 2021, 22:08

Trying to debug the problem,

I deleted an extra private (home) network and an unknown network (maybe Kasperkey’s?).  Then I reinstalled Kaspersky VPN and I was able to send the WAKE UP msg to my NAS.  So problem solved.

Thank you !

View original

7 replies

Userlevel 7
Badge +3

Hi,

Welcome.

Why 2 programs?? 

Use only one VPN KSC or openVPN or any other but only 1.

Hi,

Welcome.

Why 2 programs?? 

Use only one VPN KSC or openVPN or any other but only 1.


Wondering how to use KSC VPN on my windows machine and a client on a QNAP NAS that has a special Linux OS.  The QNAP uses OpenVPN.  I’m a beginner at NAS and VPNs.

Userlevel 7
Badge +4

Hi @Cathy , 

In theory, you can use two different VPNs as long as they run on different devices. E.g. in your case on the PC and the NAS. The Kaspersky VPN on the PC protects your connections from the PC to the outer world. The VPN on NAS protects the connections to the NAS. There should not be any interferance (well, in the perfect world :-) ). Can you shed more light on the strange behaviors that you are observing? 

 

What quit working is a capability to power up my NAS remotely by sending a wake up msg to the MAC address of my NAS (via a mouse click).  Maybe there is a handshake from the NAS back to the pc and Kasp VPN won’t let that get thru ???? 

I played with the settings for the KASP VPN on my pc and nothing seemed to help until I turned the VPN off (the initial setting for on/off).

From your response it sounds like other devices are not aware of a VPN unless data is coming into the PC?  (I have NOT yet installed a VPN on my NAS).  My NAS is connected on my local network, ie. local IP address (192.xxx.w.yy)  I thought I could set the VPN to ignore my NAS by adding it’s IP address as a website and telling the VPN to ignore it.  Kasp VPN displayed the NAS IP address as a 1.0.0.xx address.

Once the NAS powered up, I turned the KASP VPN back on and I think everything works ok.

 

Userlevel 7
Badge +4

Hi @Cathy , 

Unfortunately, I do not have a NAS at hands to check your scenario. Can you please submit a ticket to technical support via my.kaspersky.com, we will request some additional information for further analysis? 

Trying to debug the problem,

I deleted an extra private (home) network and an unknown network (maybe Kasperkey’s?).  Then I reinstalled Kaspersky VPN and I was able to send the WAKE UP msg to my NAS.  So problem solved.

Thank you !

Userlevel 7
Badge +9

Hello @Cathy

Thank you for the update, we’re delighted the issue is resolved:clap_tone3:

Just for information, in Windows Network and Internet\Network Connections,  the “unknown network” device is Kaspersky’s Security Data Escort Adapter

 

 

Thank you:pray_tone3:

Flood:whale: +:whale2:

Reply / Ответить