Kaspersky
Solved

Remove Annoying Kaspersky Secure Connections Advertisements [Solved][Closed]

  • 2 March 2020
  • 5 replies
  • 285 views

Userlevel 1
Badge

I’m not interested in advertisement popups that Kaspersky seems to be plagued with.  How do I remove all annoying Kaspersky advertisements?

 

I’ve attached a screen capture of the unwanted advertisement that popped up on my Windows 10 machine. 

 

 

icon

Best answer by Flood and Flood's wife 9 March 2020, 22:34

Hello @silver_mica

Thank you for posting back & the additional information:ok_hand_tone3:

To manage the Kaspersky Secure Connection popup, there’s 2 options:

  • Option 1

Open Windows Start menu, type in Services, select Kaspersky Secure Connection, select Properties, select General Tab, change Startup type to Disabled and select the Recovery Tab, change all 3 Failure fields to Take no action, select Apply.

After applying the change reboot the computer. 

 

 

  • Option 2 - uninstall Kaspersky Secure Connection. 

Imo it’s better to use Option 1.

Why?

All Kaspersky Home AV products come with Kaspersky Secure Connection in the version distribution, a new version update will re-install Kaspersky Secure Connection, the problem will return. 

Clearly it would be preferable if Kaspersky changed the AV product range, by providing an option to not use Kaspersky Secure Connection, as they have now done with Kaspersky Password Manager, however, atm, this solution does not exist.

Please post back if further assistance is required? 

Thank you:pray_tone3:

Flood:whale:

View original

This topic has been closed for comments / Тема закрыта для комментариев

5 replies

Userlevel 7
Badge +9

Hello @silver_mica,

Welcome back!

  • From all the previous information, have the Kaspersky Secure Connection “recommendations” started again or never stopped?
  • Has KSC-VPN ever been used? 

Please let me know?

Thank you:pray_tone3:

Flood:whale:

Userlevel 1
Badge

Yeah, their popups came back - looks a little different now- but the annoying popups are back with a vengeance.  I want NOTHING to do with Kaspersky anymore.  No - I never used any other product of theirs.    

 

So, how do I get rid of this annoying pop up advertisement?   At this point in time my only option is to remove Kaspersky and never use Kaspersky again. Unfortunately,  I bought a five year license - but, at this point it just isn’t worth the hassle I have to constantly deal with.   Better to cut my losses and move on.

 

Like a nasty virus - I need to purge my system of Kaspersky.

 

 

Userlevel 7
Badge +9

Hello @silver_mica

Thank you for posting back & the additional information:ok_hand_tone3:

To manage the Kaspersky Secure Connection popup, there’s 2 options:

  • Option 1

Open Windows Start menu, type in Services, select Kaspersky Secure Connection, select Properties, select General Tab, change Startup type to Disabled and select the Recovery Tab, change all 3 Failure fields to Take no action, select Apply.

After applying the change reboot the computer. 

 

 

  • Option 2 - uninstall Kaspersky Secure Connection. 

Imo it’s better to use Option 1.

Why?

All Kaspersky Home AV products come with Kaspersky Secure Connection in the version distribution, a new version update will re-install Kaspersky Secure Connection, the problem will return. 

Clearly it would be preferable if Kaspersky changed the AV product range, by providing an option to not use Kaspersky Secure Connection, as they have now done with Kaspersky Password Manager, however, atm, this solution does not exist.

Please post back if further assistance is required? 

Thank you:pray_tone3:

Flood:whale:

Userlevel 1
Badge

Thank you for the detailed help.  I have used Option 1.   So far the advertisement is not there anymore.   Thanks again.

 

 

Userlevel 7
Badge +9

Hello @silver_mica,

You’re most welcome:relaxed: !

Thank you so much for letting us know:ok_hand_tone3: 

We’re delighted to read Option 1 resolved the issue:cartwheel_tone3:

Flood:whale: