Kaspersky
Question

Kaspersky VPN + TP-Link modem router

  • 9 November 2021
  • 5 replies
  • 103 views

VPN not working on my router. All the ‘pass-through’ options are enabled. What other settings do I need.

Would love if there was a tech support line I could call or address to get in touch with support. 


5 replies

Userlevel 7
Badge +11

Would love if there was a tech support line I could call or address to get in touch with support. 

Hello @scart

Welcome!

  1. Read before you create a new topic!
  2. What do you mean “VPN not working on my router” ? 
  3. Does the install meet KVPN Hardware and software requirements?
  4. Has the software been installed as per Kaspersky’s documentation: 
    How to install the application?
  5. Support

Thank you:pray_tone3:

Flood:whale:+:whale2:

VPN application used to work with different router

purchased new router, now VPN doesnt work

PPTP/L2TP/IPSec pass-through options are all enabled on the router. Are there other settings I need to enable on the router to get the VPN connection working?

Application side, it’s failing to connect on both win10 and android, so seems like a problem with my router (router is TP-Link Archer VR2100)

KVPN seems to have a lot fewer options on the client side than other VPN services I’ve used - there really doesn’t seem to be anything I can configure on the client

Userlevel 7
Badge +11
  1. VPN application used to work with different router
  2. Purchased new router, now VPN doesn't work
  3. PPTP/L2TP/IPSec pass-through options are all enabled on the router. Are there other settings I need to enable on the router to get the VPN connection working
  4. Application side, it’s failing to connect on both win10 and android, so seems like a problem with my router (router is TP-Link Archer VR2100)
  5. KVPN seems to have a lot fewer options on the client side than other VPN services I’ve used - there really doesn’t seem to be anything I can configure on the client

Hello @scart

Thank you for responding!

  1. Was the VPN that *did* work with the original router, Kaspersky VPN? 
  2. Are there errors - refer Read before you create a new topic! 
  3. You’d need to seek advice from TP-Link Technical support or their community.
  4. Ditto.
  5. Without knowing which other VPN you’re referring to, we assume that’s an observation, not a question. 
  6. If you wish to, you may contact support on the link we provided in our first reply: select either Chat or Email, fill in Application malfunctionOther template; support *will* request logs, traces & other data.
  • :exclamation:If you select Chat, we recommend you opt to receive a copy of the chat transcript, make sure you fill in your email address AFTER the chat is activated by the Chat agent & complete the Verify your email address email that arrives AFTER the chat completes:exclamation: ​

When it’s available, please share the outcome with the Kaspersky Community? 

Thank you:pray_tone3:

Flood:whale:+:whale2:

Yes, I’ve been using KVPN for a couple years. Apart from the occasional drop out, no connection problems. KVPN worked fine with old router (netgear)

The ONLY thing that has changed is the new router.

Tried searching for Kaspersky documentation on what options I should enable in the router. They just mention the pass-through settings (which were already enabled)

There doesnt appear to be any errors (though Im not sure where they would show up if there were).

KVPN does appear to make a connection (it says ‘Your connection is secure’), but I just can’t get any internet with it turned on

Out of curiosity I just tried another VPN … works perfectly.

So it appears the ‘fix’ is stop using KVPN and use something else.

Honestly, the limited configuration options were a bit annoying anyway - like how you can setup the app to connect to a VPN when visiting a specific site, but you can’t disable it for specific sites (like netflix), which means I end up disabling the whole thing

Reply