Kaspersky
Solved

Star Wars: The Old Republic (SWTOR) launcher blocked by Kaspersky

  • 26 April 2019
  • 3 replies
  • 100 views

Hello,

When I try to run SWTOR with Kaspersky running, I get a message saying "The launch service is currently unavailable." This happens no matter what I disable within Kaspersky. I've tried suspending protection using the sys tray icon, manually going in and disabling every protection option available, and whitelisting the launcher executable on every whitelist option there is, but the only thing that stops this error from occurring is to just exit out of Kaspersky completely. I've been running Kaspersky prior to ever getting this error and they never clashed before. I could just shut it off to play the game but I shouldn't have to do that.

Has anyone else ever run into this specific issue before? I can give whatever details might help... sorry for it being kind of generalized.
icon

Best answer by FLOOD 27 April 2019, 03:06

That's the one Frammelpie,
Very happy to hear it helped and for letting us know.
[Always scan] does have it's purposes, you've analysed it correctly & applied [Scan encrypted connections upon request] so that no security issues will result👍.
Thanks for documenting it, excellent doco (as yours is) always helps others. I was running short of time & reading your original post, I "surmised" you were pretty proficient with performing "bowel" surgery on the innards of Kaspersky app.
Happy gaming!
View original

3 replies

Userlevel 6
Badge +3
Hello Frammelpie,

  • Can you let us know which Kaspersky version you have?
  • Patch(e) has recently been released.
  • Has the problem been ongoing for a while or is it new?
  • Post in "old" Kaspersky Forum matches your information BUT not followed thru: (at least you know your not alone)
https://forum.kaspersky.com/index.php?/topic/352320-star-wars-the-old-republic-launcher-blocked/

mentions adding exceptions for launcher.exe and swtor.exe in [scan][secure/encrypted connections], try, if you've not already done so..

Also, contact Kaspersky Technical Support: https://my.kaspersky.com/, provide logs, full description, actions taken.
Hopefully there's SWTOR Gamers in this Community who'll be able to solve this for you...?
Thanks.
mentions adding exceptions for launcher.exe and swtor.exe in [scan][secure/encrypted connections], try, if you've not already done so..

Thanks for the reply. This seems to have been the issue, sort of. I couldn't find anything in the scan section regarding secure/encrypted connections until I stumbled through the settings in there and found this page:



This can be found in Settings / Additional / Network settings. It was set to always scan. Moving it to Scan encrypted connections upon request let the launcher fire right up, no exclusions necessary (or really even possible unless you know the URL that the launcher tries to communicate through). As for my version, I have KTS 19.0.0.1088(e).

Thanks for pointing me in the right direction!
Userlevel 6
Badge +3
That's the one Frammelpie,
Very happy to hear it helped and for letting us know.
[Always scan] does have it's purposes, you've analysed it correctly & applied [Scan encrypted connections upon request] so that no security issues will result👍.
Thanks for documenting it, excellent doco (as yours is) always helps others. I was running short of time & reading your original post, I "surmised" you were pretty proficient with performing "bowel" surgery on the innards of Kaspersky app.
Happy gaming!

Reply / Ответить