Problem encrypting USB drive, won't complete.

  • 15 December 2019
  • 17 replies

I am trying to encrypt a new 512GB USB flash drive using Total Security. To get started I am saving a small file, with the intention of adding more later.  I have set the size of the data vault to 499000 MB. The app progresses to try to create the vault but remains stuck in a state where it says Please wait… Saving to data vault, This may take some time.

I have left it in this state for over 8 hours and it doesn’t complete.  Windows Resource Monitor shows that avp.exe is writing file Kaspersky Vault 1,kde to the drive at a rate of about 8 MB/sec.  If I try to view the properties of the USB drive through Windows Explorer, Explorer hangs, and I can’t close it.  I can only restore it by closing the Total Security Data Encryption window then removing the USB drive.  I can then plug the drive in again and if I look at it via Explorer.  I can see that the vault has been created, but I assume it is incomplete.  I can delete the vault and retry (even on another computer) but the result is the same.


Am I being impatient or does it take an exceptionally long time to create the vault?  Or is there a problem?


17 replies

Userlevel 7
Badge +11

Hello  @RouseA,


How many computers? 

On all computers:

  1. Is Windows uptodate, with all updates showing a “successful “ status? 
  2. Is KTS uptodate? 
  3. In the setup, have you chosen default values?
  4. What “location” have you chosen for the vault?
  5. Is KTS license still valid?
  6. Is the User account Standard or Admin? 

Please let me know?

Thank you:pray_tone3:



  1. I have tried two different computers, each running Windows 10 Home (Version 10.0.18362) and both are completely up-to-date
  2. KTS is also up-to-date
  3. I reset KTS to the default settings but it made no difference
  4. I have set the location to drive F:, which is the USB drive.
  5. The KTS licence is still valid
  6. I assume you mean my Windows User Account, which is Administrator

I should also add that I have previously used KTS to encrypt a 500GB hard drive without any problems

Userlevel 7
Badge +11

Hello  @RouseA,

Thanks for replying.

Try using encryption “default ” values, save to the desktop, not F.

Let me know if that works please?

Thank you. 


The default size for the vault is 100MB, and I can successfully create a vault with that size on my desktop

Userlevel 7
Badge +11

Hello @RouseA,

Thank you. 

I thought that would happen, now we need to work out what’s changed, maybe in KTS, since the last time you successfully used KTS to encrypt a 500GB hard drive:thinking:

I have to reinstall KTS to test, allow me some time please?

:octagonal_sign: In the interim, check creating a larger vault, still to DT, please?:octagonal_sign:  

Thank you

I have tried further tests:

  1. I can successfully create a 100MB vault on the USB drive
  2. I then tried to create a 1000MB vault, and timed it.  It took about 4.5 minutes.
  3. I then created a 1000MB vault on another (16GB) USB drive, in case my original drive is exceptionally slow, or the time is related to the block size.  However, it took over 8 minutes to create the vault on this drive.
  4. At a speed of 4.5 minutes/GB it would take 37.5 hours to create a 500GB vault.  This suggests that there may not be a fault, and waiting 8 hours was not long enough.

Do these timings seem reasonable to you?

Userlevel 7
Badge +11

Hello  @RouseA,

Yes & no, that’s why I’m testing.

The reason I said “fault” is bc you advised “ I have previously used KTS to encrypt a 500GB hard drive “:thinking:

Back after I’ve reinstalled KTS & tested.



Userlevel 7
Badge +11

Hello  @RouseA,

Test 1: Created 50gb vault, with 16.5gb files, to DT, started 17:44, ended 18:49,  created successfully.

16.5gb files, opened using Windows Explorer, no hangs. 


It should not be the case, but, maybe it’s USB flash drv:thinking:

2nd test running now.. 

Will update with results. 

  • :question: @RouseA, did you format or reformat the new 512GB USB flash drive, before creating the vault:question:

I had already checked the drive.  It is formatted in exFAT. I am able to save files to it, so I don’t think there are any problems with it.  Yesterday I ran ScanDisk to confirm no errors.  I ran CrystalDiskMark to confirm the read/write speed.  I also ran ChkDisk to confirm that it funtioned correctly.  ChkDisk takes a long time to test 500GB so I stopped it before it had finished.  I have just run a quick format on the drive, and I’ll run ChkDisk again to fully test it.

I should also note that I experienced the same problem with another USB drive, which tends to suggest that it isn’t a hardware problem.

Userlevel 7
Badge +11

I wasn’t suggesting a hardware problem…

I’m running the 2nd test, created a 500gb vault, on a 2tb drive, 16.5gb files, started, 18:35, it’s now 20:41, hasn’t done squat. 

Maybe, even tho it’s not specified, the vault always has to be created on the core drive:thinking:

If you have licensed Kaspersky software, log a case with Kaspersky Technical Support, if they provide a solution, please let us know?

Thank you:pray_tone3:

Thanks for your help.  I have logged a query with Technical Support

Userlevel 7
Badge +11

Hello  @RouseA,

Your welcome!

23:41, I’ve just checked the 2nd test vault creation, it’s still:

5 hours, aint nuttin happening.

It doesn’t give you a solution, but does backup your experience.

Support may ask for a GSI & Windows Logs

Thank you



I left a PC encrypting a 512GB USB drive before I went away for a couple of days.  The computer locked up, so I could do nothing with it.  When I returned KTS was reporting that the encryption had failed.  I was unable to access the drive until I removed it the re-inserted it.   It has a file named Password Protected.kde (which is the name I configured).  When I clicked on it KTS asked for the password, which I entered.  This opened a window saying the drive needed to be formatted, which gave every indication that it was the standard Windows formatting, so I expected the whole drive to be re-formatted.  Formatting was very quick.  However,  Windows Explorer then showed a new drive Removable Disk (Z:), size 488GB.  I am able to read and write to that drive, and it appears to be encrypted.

It would appear, therefore, that KTS has successfully encrypted to drive, after some indeterminate time, even though it reported that it had failed.

Userlevel 7
Badge +11

Update:  I canned the 2nd test 10hrs after my last post, at that point the process had run for 15+ hours.

With the duration and the “reported that it had failed”, (imo) KTS Encryption doesn’t score well. 


Further update:

When I copied data to the encrypted drive it failed at about 300GB, although I had tried to create a 500GB folder.

I then tried running ChkDsk.exe/ChkFlsh.exe.  After a couple of hours it started reporting errors on consecutive blocks.  I assume therefore that KTS was right when it reported that it had failed during the creation.  I wonder why it failed.

PS  I reported the problem to Kaspersky Support 4 days ago and they haven’t responded

Userlevel 7
Badge +11


Support “generally” respond within 5 business days. 
If, after 7 business days, a Kaspersky Lab human has not contacted you, send a reply email using the INC# you received when you logged the case.

Also, as the issue has “evolved”, i.e. “encrypted drive failed”, log into your MyKasperky account & update the INC# with the  new information. 

Given the nature of the issue, (imo), when support do engage, they may wish for you to repeat everything with Traces running, they will guide you with the requirements. Although, having said that, if it takes +days+ to create / encrypt the vault (stage one), the traces would be so large as to be unmanageable. I guess they’ll sort that with you if & when that happens:thinking: 

Please keep us posted?

Thank you