No Internet When Kaspersky Firewall On

  • 15 September 2020
  • 11 replies

As title suggests, I can no longer access the Internet when the Kaspersky firewall is turned on (when off, I can access no problem). I’m running Windows 10 Pro Version 2004 OS Build 19041 and Kaspersky Total Security 20.0.14. 

I’ve gone through the process of marking all  “Monitored ports” inactive - so none are active - and deselecting “Monitor all network ports for applications...” with no impact on accessing the internet.

No other firewall active. MBAM is installed, though I turned it off and still no success getting online with the Kaspersky firewall active. I’ve tried to find the solution online and the most promising posts were allegedly solved without providing a solution.

Any help much appreciated. Again, from my perspective it’s simple: Kaspersky on = No Internet connection; Kaspersky off = Gain Internet access. No idea why I cannot access the Internet with my firewall on (yes, Chrome is added as an exempt





11 replies

Userlevel 6
Badge +4

Hi @JohnGalt , try to remove MBAM, install the latest version of KTS the 2021  , update and restart, if it doesn't work make a GSI and post it


Here is the GSI prior to updating to KTS and removing MBAM. The link you provided is an update to KTS version 21.1.15 (not 2021). Are you recommending I upgrade to this version and not 2021?

Also, why would MBAM impact my internet access when it is not running or active (MBAM install doesn’t include a firewall and it’s clear KTS firewall is the issue)? 



Userlevel 7
Badge +8

Hello @JohnGalt

Thank you!

  1. Kaspersky Total Security (version is the latest 2021 version. 
  2. The Hosts file is not standard, is that deliberate? 
  3. Remove TinyWall firewall.
  4. GSI & Windows Logs needs to be run after updating KTS, removing Mbam & Tiny Wall, then please run a new GSI & Windows logs & post back? 

Thank you:pray_tone3:


Userlevel 7
Badge +6

@JohnGalt, remove MBAM tails with this utility.
Remove TinyWall.

Possibly incompatible software or hardware is found:






Normalized driver file name is:


Driver file exist: False



Malwarebytes Service


"C:\Program Files\Malwarebytes\Anti-Malware\MBAMService.exe"



TinyWall Service


"C:\Program Files (x86)\TinyWall\TinyWall.exe" is the latest version of Total Security (2021)

My thanks in advance to those trying to help me out!  :tada: :thumbsup: :tada:

Okay @bobbycooper@andrew75 and @FLOOD I’m ready for the next step.

BTW, the “2021” following Total Security in recent post’s threw me off since, well, its only the year 2020. I thought 2021 was the build or version number :joy:

Regardless, I removed all Tinywall remnants and now see little green On or Off in Kaspersky Settings - instead of a toggle bar - after installing Total Security 2021 and the GSI now shows, “Incompatible software is not found.”

However, as I suspected, it did nothing to resolve the issue of Kaspersky firewall blocking my access to the Internet. 

There’s a potentially important fact I left out of my original post:

I HAVE TWO 2 :v: LAPTOPS, SIDE BY SIDE, THAT CANNOT ACCESS THE INTERNET WHEN KASPERSKY FIREWALL IS TURNED ON. When use Windows Network Diagnostics to troubleshoot the issue it comes back with:

Details about network security diagnosis: Settings that might be blocking the connection:Provider name: 		    Kaspersky LabProvider description: 	Kaspersky Lab WFP ProviderFilter name: 		    Kaspersky Lab WFP ALE auth connect V4 filterProvider context name: 	-

I’m wondering if this is “user error” :astonished:and I managed to screw up a setting in Kaspersky... Does the GSI report include system settings so someone could review these?

The GSI report attached directly to this post is the same computer as in my original post (removed Tinywall, upgraded to KTS 2021).

I’m going to include the GSI report from the SECOND COMPUTER in the next post (with identical an identical failure to access Internet when Kaspersky firewall turned on) so we can see if there’s a common denominator between  them as well as fix the second one too, hopefully!

Thanks again.

Here is the second laptop (though not upgraded to 2021 - I’m in the middle of a couple things and don’t want to restart my PC at the moment) that is unable to access the Internet with KTS firewall turned on.

Hopefully someone can see what the problem is a get two birds with one stone!

@FLOOD Yes, hosts file as intended.

Thank you!

Userlevel 7
Badge +8

 Hello @JohnGalt

Thank you for the information:ok_hand_tone3:

Don’t worry about 2020/2021, it’s a misunderstanding, many of us have made:upside_down:

Please do the following:

  1. Open command prompt, ping your own IP address - result ? 
  2. If you are able to ping your IP, type “nslookup www.google.com” - no quotes, result should be Google ip address ? 
  3. Create a System restore point. 
  4. KTS, export Settings.
  5. Run the following network commands, as Administrator, to manually reset the TCP/IP stack, release and renew the IP address, and flush and reset the DNS client resolver cache:
  • In the search box on the taskbar, type Command,  the Command Prompt button will appear, right click & select Run as administrator → Yes.
  • At the command prompt, run the following commands in the listed order = one at a time → allow each command to complete before entering the next command, then check if the connection problem is fixed
    • Type netsh winsock reset and select Enter.
    • Type netsh int ip reset and select Enter.
    • Type ipconfig /release and select Enter.
    • Type ipconfig /renew and select Enter.
    • Type ipconfig /flushdns and select Enter.


  • If the above does not resolve the issue it will be necessary to do further network recovery steps that do involve shutdown of devices, so atm, lets see if the above works? 

Please let us know? 

Thank you:pray_tone3:


  • Edit, additional, in device Alexander, there’s numerous

The device, \Device\Harddisk0\DR0, has a bad block\

errors; these will not be causing the network connectivity issue, however, it will do no harm to check & if necessary, seek support from Microsoft Technical team. 

@FLOOD Thank you so much for the detailed reply, very much appreciated!

I literally laughed out loud as I read your post and began to wonder what’s really in those GSI reports: The only network commands I know - ping …, net sh winsock reset, ipconfig /release, /renew, /dnsflush - were the ones you posted! (I didn’t know the nslookup command, though).

I guess great minds think alike?

Nevertheless, I followed your instructions exactly since you definitely have much more experience with this stuff than me. Here we go:

  1. First pinged
    [Pinging with 32 bytes of data:
    Reply from bytes=32 time=3ms TTL=64

    Reply from bytes=32 time=3ms TTL=64
    Reply from bytes=32 time=3ms TTL=64
    Reply from bytes=32 time=3ms TTL=64

    Ping statistics for
        Packets: Sent = 4, Received = 4, Lost = 0 (0% loss),
    Approximate round trip times in milli-seconds:
        Minimum = 3ms, Maximum = 3ms, Average = 3ms]

  2. Then entered: nslookup www.google.com
    [DNS request timed out.
        timeout was 2 seconds.
    Server:  UnKnown (yes, the “K” in unknown is capitalized in the response even though “U” already a capital letter)

    DNS request timed out.
        timeout was 2 seconds… [repeat 3 times]
    *** Request to UnKnown timed-out]

  3. Went to System Properties > System Protection > Create… and created a restore point (it saved successfully). Haven’t done anything with it but not a bad idea anyway

  4. Exported KTS settings (see attachment: NOTE Site wouldn’t allow upload of .cfg file so I added a .zip extension to it; Just deletie the last four characters to review the exported settings file 

  5. Went through the network commands, in order, and waited for each command to complete, checked if network open, and went to next one. Unfortunately, no luck! :/

    * Running a chkdsk C: /f /r /x command to fix harddrive issues. Thanks for the heads up!

Hey guys, (@bobbycooper@andrew75 and @FLOOD) please let me know if you have any ideas on next steps.

It’s very odd that both my laptops are having the same issue. I try to keep the same KTS settings for both of them in case something like this happens (fixing one fixes the other - unfortunately, if I break one I also break the other!)

Thanks again for any help you can offer!

Best regards,

Userlevel 7
Badge +6


Did you change anything in the packet rules settings?

Please show a screenshot of the packet rules configuration window? (Settings - Protection - Firewall - Configure Packet Rules)

Userlevel 7
Badge +8

Hello @JohnGalt

Thank you for updating us:ok_hand_tone3:

  • To respond to two points, the System Restore point is standard best practice, hopefully not required, but better to have it than not. 
  • The KTS config is similar prep, we (Kaspersky Community) don’t need the file, however, you may, if you reset KTS, which you may eventually do. 


Please share with us:

  1. When was it last possible to use the internet?
  2. & in the 24hrs preceding not being able to use the internet, what changes: any network, hardware, software, environmental changes, anything at all
  •  Please continue to follow whatever guidance @andrew75 provides.

Thank you:pray_tone3:


Userlevel 4
Badge +1

Lenovo Flex 5-1570 System:

Lenovo Update the BIOS:


Uninstall these software:

Nord VPN, Belarc Advisor, IDrive, RansomStopper, Stardock Multiplicity

  • Never use driver finder software.
  • Do HDTune “Error scan" and share the result.
  • Apply this:



Download and install:



Download the software and run it as an administrator. Mark all the ticks in the window and start them:




Apply DDU: https://www.wagnardsoft.com/content/ddu-guide-tutorial


Install these:




Lenovo 80HE Yoga 3 PRO System:

Lenovo Update the BIOS:



Uninstall these software:

Nord VPN, Lenovo all software, Belarc Advisor, Driver Booster 6, RansomStopper, TAP-Windows


  • Never use driver finder software.
  • Apply this:



*Update your Broadcom network driver. I cannot share the updated file with you because I cannot see the hardware ID.


Download the software and run it as an administrator. Mark all the ticks in the window and start them:





Reply / Ответить