Kaspersky Total Security block keyboard input in Firefox.

  • 17 September 2020
  • 12 replies

Hello, I’m using Kaspersky Total Security 20 on Windows 10 2004.


Since the last couple of weeks, Kaspersky is blocking my keyboard when I type on something on Firefox at some pages like Amazon, banking, etc, it annoys that I have to type on Notepad once then copy into the browser. It doesn’t matter if Safe Money is enabled or not because I disabled Safe Money but it didn’t help. Browser Add-on is disabled but the issue still happens.

I tried so far MS Edge and it worked as usual but I don’t like to use it. Firefox is the latest version 80.0.1.

When I stop whole Kaspersky, keyboard works as usual.


It might be the case that the problem happens on Windows 10/2004, but I’m really not sure if it started just after 2004 installation….

I could not find any settings related to this topic. Is there anything I can change ?

12 replies

Userlevel 7
Badge +11

Hello @lucy99


To help us understand the issue, please make videos of:

  • Kaspersky blocking the keyboard when, using a Firefox browser, data is entered on an Amazon page, irrespective of whether or not Safe Money is active?
  • A comparison video: the keyboard working when a Edge Chromium browser is used? 

Please post back?

Thank you:pray_tone3:


Userlevel 7
Badge +9

@lucy99 Welcome. Did you try to disable the Kaspersky Secure Keyboard :
Settings > Additional > Secure Data Input settings


@Berny , @FLOOD 


Thank for the quick reply.

I was not so patient to wait for the answer, so tried updating to version 21 and now it works…

I’m using v21.3.10.391(d) and this bug also happens to me.

It also happened with the previous version of Kaspersky (20).

Recently its been happening while my computer is asleep, so it prevents me from logging into the machine.

Userlevel 7
Badge +11

Hello @_________


Please log a case with Kaspersky Technical Support, select Application malfunction, Other template, provide as much detail as possible, if you have images & or video - that may help Support understand the issues, Kaspersky may request Traces & other data, they will guide you:



  • After submitting the case, you’ll receive an automated email with an INC+12digits reference number, then, normally, within 5 business days, a Kaspersky Technical Support human will be in touch, also by email, you may continue to engage with the Kaspersky Technical Team via email or by updating the INC in the MyKaspersky account.

:large_blue_diamond: Please share the outcome with the Community when it’s available? 

Thank you:pray_tone3:

Flood:whale: +:whale2:

Userlevel 1

The same issue happens to me and it’s very annoying.


I see lots of posts in the community.


Why the problem still persists and what is the source of it?

I disabled the Secure Keyboard Input. Since then I haven’t experienced this problem.

Userlevel 1

In my case the source of the problem was Heimdal Thor Foresight; I only had the proactive protection, but I didn’t know it used HIPS for preventing malware, so I uninstalled it and the problem with Kaspersky is gone.

I disabled the Secure Keyboard Input. Since then I haven’t experienced this problem.

Tech support had me disable keyboard input, but I still have the problem. The only way around it is to turn off Kaspersky and turn it back on.

Userlevel 7
Badge +8

Hello @ChulaT, Welcome.

Can you please try the following:

disable all FF add-ons
restart FF

If the input works, turn on the add-ons one by one again and restart FF each time.

it happens in more than just Firefox browser, but I will try

Userlevel 7
Badge +8

Hi @ChulaT,

I assumed that we have a FF problem here.
What other programs are affected in your case?