Kaspersky
Question

I have to exit out of Kaspersky completely or playback of our cameras won’t work.

  • 1 December 2020
  • 25 replies
  • 583 views

I use internet explorer to manage our security cameras, recent upgrade of Kaspersky Total Security means I have to exit out of Kaspersky completely or playback of our cameras won’t work.  I have tried adding the ip address into exclusions, but nothing works.  I have tried almost every setting I can find, have tried turning various options on or off but cannot get the program to playback unless kaspersky is shut down.  Security cameras work best with internet explorer.


25 replies

Userlevel 7
Badge +9

Hello @complete

Welcome!

  1. Which Kaspersky Total Security version & patch(x) x=letter, is installed → on Windows Taskbar, rightclick the Kaspersky icon, select About ?  
  2. Camera security software name & version? 
  3. As a test only: if Inject script into web traffic to interact with web pages is unchecked, does the camera playback issue persist? 
  4. As a test only: if Encrypted connections scan, Do not scan encrypted connections, is unchecked, does the Samsung page issue persist? 
  5. In KTS Reports, are there any events that indicate KTS is blocking or interfering with the camera - please save the Report & attach:paperclip: to your reply?   

Please let us know? 

Thank you:pray_tone3:

Flood:whale: +:whale2:

Kaspersky Total Security 21.1

HikVision software cameras

Number 3 test suggestion above, unchecked, issue persists

Number 4 test suggestion, same result

I have no reports or indications, other than when I shut kaspersky down the playback issue goes away = thus my thinking that kaspersky is the issue….

 

Userlevel 7
Badge +9

Hello @complete

You’re welcome! 
Thank you for the information:ok_hand_tone3:

:a: Does the issue happen in all supported browsers: Chrome, Firefox, Edge Chromium? 

:b: KTS is up to version 21.2.16.590a, please update & recheck? 

If the issue persists, contact Kaspersky Technical Support, fill in the Application malfunction, Other template, include:

  1.  A detailed history? 
  2. What caused the problem?
  3. Did you try to solve the problem? How?
  4. Text from an error message? Screenshot? Video?
  5. Community topic URL?

Support may request Traces & or other data, they will guide you:

 

  • After submitting the case, you’ll receive an automated email with an INC+12digits reference number, then, normally, within 5 business days, a Kaspersky Technical Support human will be in touch, also by email, you may continue to engage with the Kaspersky Technical Team via email or by updating the INC in your MyKaspersky account.

Please share the outcome with the Community when it’s available? 

Thank you:pray_tone3:

Flood:whale:+:whale2:

Thank you, will work through all this tomorrow, your help very much appreciated!:grinning:

Userlevel 1

Did you get this resolved?  I have a similar issue with playback from Hikvision cameras since KIS was updated to version 21.   I’ve traced it back to the fact that incoming steam under port 80 TCP is being blocked for some reason.  

Under Configuration and then local from the Hikvision NVR webpage, change Protocol from TCP to UDP. This will then allow playback streaming to work. While this fixes the issue something has changed in KIS. Do not know if this is a bug or new behavior. 

Userlevel 7
Badge +8

I have tried adding the ip address into exclusions,

Did you try with a Packet rule https://support.kaspersky.com/15163#block4

Userlevel 1

Yes, makes no difference. Even if you disable Web Anti-Virus, Firewall it still blocks playback

Userlevel 7
Badge +8

@juice_of_2_limes Please contact K-Lab Technical Support https://center.kaspersky.com 

Userlevel 7
Badge +5

Hi @juice_of_2_limes , 

Does it help to pause protection, then restart browser and check?

Try to reset the product configuration settings to detault values (Settings → Manage settings → Restore), restart browser and check?

Regards,

Igor

Userlevel 1

Hi Igor

Pausing protection, restarting browser makes no difference.

While you have mentioned resetting the configuration settings to default, I should point out that I have another PC that I recently performed a fresh Win 10 install along with KIS 21 and that PC also exhibits the same issue.

The Hikvision NVR is accessed via normal web browser using IP address. It is however an unsecured connection if that makes any difference to what KIS is doing.

You would think that pausing protection should be enough but KIS must still be protecting something which is only released on complete exit.

 

Martin

Userlevel 7
Badge +5

Hi Martin, 

Thanks for checking. Pausing protection is definitely not suggested as a workaround, we are looking to find out a possible cause of this issue. 

Please submit a ticket to technical support, we will request some additional information for further analysis and resolution. 

Regards,

Igor

Userlevel 1

Hi Igor

Thanks for your inputs thus far. Ticket INC000012270612 raised.

Martin

Userlevel 7
Badge +5

Hi Martin, 

Thank you for submitting a ticket, we will continue investigation in the incident. 

Regards,

Igor

Same issue here.. trying free version as the full version with free month blocked all playback. Tried all the suggestions above, it doesnt fix. Tried a fresh instal on new PC (about to change over), which had AVG and playback is fine. Uninstalled AVG installed new version 21.2.16.590b  and it immediately blocked all playback.. Has there been any update on the ticket raised? or do i raise a new one?

found another thread with a different version of Kaspersky, but basically it answered the issue. Had trouble finding the right location, but go to settings, Threats & Exclusions, scroll down to the bottom of that and click Specify Trusted applications, then make sure IE is in there, and follow the instructions on the other thread, 

 

basically, do not scan all traffic and add the IP address of the Hikvision camera.. good luck

Userlevel 1

Apologies for not replying sooner, never got notification you had replied gem1919.

Update on my ticket today actually which had a resolution similar to what you have said.

The problem is related to “LocalServiceControl” which is downloaded/installed when you access the NVR for playback.

Solution is to add exclusion for IP of NVR to the above application.

Settings, Application Control,, Manage Applications

Top right, search for "localservicecontrol", Right click and select "Details and Rules", then select "Exclusions".

Tick/select "Do not scan all traffic" and also tick "Only for specified IP address".

Add the IP address for your NVR. Save and your done.

Userlevel 7
Badge +5

Hi Martin, glad your issue has been mitigated via this workaround! 

Hi @complete , if you have not resolved the issue yet, can you check if this workaround works for you as well? 

Thanks for all the suggestion/workarounds, I am yet to get back to this after we took a break over Christmas, I am aiming to get to this soon and keen to resolve the issue, much appreciated!

I have the same problem and have tried everything below suggested by all of you. KIS20.* was working without this problem, but after updating to version 21.2.16.590b playback immediately stopped.

I hoped Martin’s solution will be the case, but “LocalServiceControl”  or any other application related to Hikvision does not exist in my system for this reason nothing can be exlcuded.

Agreeing with others I am completely sure the problem is in KIS new version.

Would you please find a solution because this is a very annoying problem. I can not believe you have not find the root cause or the solution since 3 months. 

Userlevel 7
Badge +5

Hi @alexabo , 

Developers have been working on this issue, I will post an update when there is news. 

Here is more details from Martin, regarding the workaround solution used: 

“When connecting to the NVR using IP address for the first time via Chrome / Edge, the NVR offers a small download which installs to help provide live view / playback of Hikvision security cameras. With the download installed, when your in the configuration pages of the NVR, there is also a small section that allows you to configure how the local agent behaves. For example, TCP or UDP streaming, encryption key for cameras, and other options.

The name of the file downloaded is named "LocalServiceComponents.exe"
It installs to Windows with the same name if you look at installed apps
Under task manager, you also see it executing as "LocalServiceControl.exe (32 bit)"

In Kaspersky, to stop it interacting and blocking TCP streaming, I have coded the IP address of the NVR to the exclude list. "Application Control Settings", "Manage Applications", search "LocalService", Then "Details and Rules" then "Exclusions" and add IP to exclude.

The Hikvision NVR I am using is model "DS-7608NI-I2 / 8P" There are others out there but I assume the most recent models will also install the same small download. Those using older "IE" to connect might have different results.”

Userlevel 1
Badge

Dear, All

 

I have been having the same issue, I need to pause protection Kaspersky to allow the playback my camera. I have tried everything with this workaround, unfortunately it doesn't work in my case cus in the Manage Applications "localservicecontrol" doesn’t exist in my system. 

 

Regards.

Hi Igor,

Thank you for your immediate reaction and the forwarded solution. As I mentioned I have tried every possible solution I found on the Internet including the one of Martin’s without success. There is no “LocalServiceControl” in my system and even switching the protocol from TCP to UDP did not help me.

Downgrade to previous KIS version is not possible unfortunately, but it would be a solution until you find the root cause. As you may learn from other user’s experiences this is not a separate problem, but general happening with KIS versions 21.*

 

BR, Sandor

Same problem here, using the free version for now but had the paid version of KAV for years.

can’t view only playback using my HikVision DVR, only closing Kaspersky completely resolves the issue.

can’t exclude it, it just doesn’t work.

Userlevel 7
Badge +5

Update: the fix is expected in the MR4, which is scheduled for release in Q3 2021. 

Hello,

 We keep more than one year with same problem in all ours kaspersky EndPoint Security version 11.4.0.233 ( KSC scope).  Whenever I receive a notice to view Hikvision cameras, I have turn off the protecction to playback. I did multiple changes over the protecction policy, but there is no way to solve it. 

Regards

Reply