Kaspersky
Question

Google Chrome and Googke Earth wont connect to the internet

  • 30 August 2021
  • 2 replies
  • 52 views

This problem arrived a few weeks ago: prior to that everything had been working fine for 2-3 years.

Now Chrome refuses to connect to the internet, and Google Earth won’t run because it can’t connect to the server.  Firefox runs fine, though, as does my email and other browsers.

Having tried a number of things (virus scans and checking firewall permissions etc.) I closed Kaspersky Total Security, going back to Windows Firewall.

And everything worked.

So the problem is caused by Kaspersky.   I can manage without it - I have alternative anti-virus I can use, for instance - but I have a good while paid on my subscription so I would prefer to use it.

if anyone has a helpful suggestion, I would be grateful.

Oh, and I have also tried uninstalling and reinstalling both apps, which didn’t help.  As I say, Kaspersky is the problem.

i run the latest version of Windows 10 Home.

 


2 replies

Userlevel 7
Badge +8

Hello @Clearcomms,

have you already tested how your KTS behaves after a reset to default settings?

 

 

Userlevel 7
Badge +5

Hi @Clearcomms , 

Did you try settings restore, as Schulte has advised?

If the problem still persists, does it help to: 

  • disable Kaspersky Firewall or Web Anti-Virus? (Restart browser after disabling and check)
  • if not, does it help to pause protection and then restart browser?
  • If pausing does not help, disable encrypted connections scan via Settings -> Network settings -> set it to 'Do not scan network connections', restart browser, how will it go? 

Reply