Kaspersky
Solved

Firewall Blocking network share [Solved][Closed]

  • 6 December 2019
  • 9 replies
  • 19557 views

Hello, 

I have on my PC the KTS and when I share some directory from my windows, I can’t access this share remotely because KTS firewall blocks connections.

When I go to firewall settings and network, I can edit my networks connections, but when try to edit my main network ethernet, it’s not allows me to change any configuration like network type. The only available option is Public network and I can’t change it.

So if I want to access my remote share, I have to temporarily disable KTS firewall setting.

What can I do to access share without having to disable the firewall setting?

Thank you.

icon

Best answer by Fernando Silva 7 December 2019, 21:37

View original

This topic has been closed for comments

9 replies

Userlevel 7
Badge +11

Hello  @Fernando Silva,

Welcome!

Please tell us:

  1. Windows operating system name & version?
  2. KTS version?
  3. When “KTS firewall blocks connections”, are there any errors in KTS Reports?
  4. If ethernet network “extended” detail is shown, is “edit” not available?
  5. Have you added the “share” in Windows Network?

    6.) Are you able to show us images of the issue please?

Please post back?

Thank you

Network properties window

Userlevel 7
Badge +9

@Fernando Silva Before providing an additional suggestion , are you talking about sharing files and folders in your Local Area Network (LAN) ?

Hello @FLOOD 

Sorry for not providing so much info at beggining. So here we go:

  1. I’m using Windows 10 x64 v1903.
  2. My KTS is 20.0.14.2085(f)
  3. Actually I can’t see any log error when firewall enabled and SMB didn’t work, I don’t know where on KTS I can start or check real time package monitor ( if there is any)
  4. On my ethernet adapter, I can’t see any “sharing” options.
  5. I’ve checked my network profile and it was on public network, I’ve changed to private and not works, it appear that somehow KTS firewall keep denying SMB connections. I didn’t saw any deny SMB firewall rule.
  6. The only “issue” is when I had the older version (KTS 19) I was able to change on firewall > Network properties > the network properties. Actually mine is set to public ( even when I changed my windows network profile ) and I can’t change at any cost like before. I believe this setting is blocking my sharing. My KTS is configured in my local language, and I couldn’t revert to english, I’ll post this print and if necessary I translate to you:

1-Network type option

2-My ethernet adapter configured as “Public network”

Available options are:

3- Public Network (currently applied)

4-Local Network (Can’t select it as KTS19)

5-Trusted Network (Can’t select it as KTS19)

@Fernando Silva Before providing an additional suggestion , are you talking about sharing files and folders in your Local Area Network (LAN) ?

Hello @Berny 

Yes, Actually I use my Windows as File server, and I only share one directory on my local network LAN. Not use to WAN side.

Userlevel 7
Badge +8

Hi @Fernando Silva,
according to your screenshot you are trying to change the internet connection setting. That’s not possible.
Klick on 'Realtek PCIe GBE Family Controller' and change the setting to local network (Rede local).

Userlevel 7
Badge +11

Hello  @Fernando Silva,

Thank you for replying, the image, the additional information, & the translation:ok_hand_tone3:

Since v20 has been updated & as well as the advice from  @Schulte, have you:

  1. Deleted and recreated the network share? 
  2. Disconnected your computer from the internet, reset network and all defined devices?
  3. Just so I understand, 1. “Can’t access this share remotely because KTS firewall blocks connections”, 2. “Can’t change FW NW properties”, are, in essence, they same issue:thinking:
  4. (Even tho it should not be necessary), when v20 was out earlier this year, some folks found adding an exclusion, fixed “unable to access network share” issues. 
  5. Are you able to access the following

     

  • How are (Windows) Advanced sharing settings configured? 

Please let me know?

Thank you. 

Just for information:

KTS Firewall Library

KTS Release notes: Patches A – F for version 20.0.14.1085

Vulnerability Report: List of Advisories current at 02/12/19

Userlevel 7
Badge +9

Hi. @Fernando Silva,
Please set the 'Trusted' status to network Realtek PCIe GBE Family Controller listed in Kaspersky Firewall, to do that: https://support.kaspersky.com/15158#block1

Userlevel 7
Badge +9

@Fernando Silva What I mostly suggest to allow file sharing in a LAN configuration are these settings :

Kaspersky > Settings > Protection > Firewall > Configure packet rules

=> Local services (TCP) > Rightclick > Edit > Action : "Allow" > Save

=> Local services (UDP) > Rightclick > Edit > Action : "Allow" > Save

=> Reboot

Hi @Fernando Silva,
according to your screenshot you are trying to change the internet connection setting. That’s not possible.
Klick on 'Realtek PCIe GBE Family Controller' and change the setting to local network (Rede local).

That worked!!! Finally, so I was trying to change wrong adapter. When configured the realtek adapter worked. Thank you!