Kaspersky
Question

Dramatic internet speed decrease after KTS 2019 install [UN-CROSS-POSTED]



Show first post
This topic has been closed for comments

44 replies

I have the same issue with KIS 20.0.14.1085 j with 1 gbit fiber.

It is obvious that KIS affects the speed. If  I exit KIS speed returns to 1 gbit. I measured with speedtest console app in Windows 7.

I tried whatever suggested in this post. No luck.

Any feedback from Kaspersky on this matter?

Have same problem, but issue with windows 10 x64 may update.

After update, KIS 20.0.14.1085(k) limit all download speed on my wifi is 2mp/s.

Exit KIS, my download return max speed is 6mb/s.

Did this ever get worked out?  

 

That is really strange, because I personally have 1Gbps fiber, and I am not having problems with it.

Have you rebooted your router?

What is your system specs?
Sunmit a ticket to tech support, because it shouldn't be happening to that extent.

Another though have you asked your ISP about the speed drop?

But as I said before it shouldn't be that bad of a drop.
Userlevel 1
Hi Friend,

Yes, I'm aware the speed will decrease a bit (as mentioned my experience with KTS 2018), but what happens here is a true disaster.

I'm typically using speedtest.net to measure my speed and also my ISP's dedicated tool - they have always given quite comparable results (the difference was +/- 5% only). I've just downloaded a 1GB test file from https://www.thinkbroadband.com/download and I can see that the speed was only approx 25-30 Mbps.

The mesurements I quoted were made this morning and tests before and after KTS installation were made one after the other, so it's not some peek time speed problem or anything else. I've specifically waited with this to Monday morning, to avoid some test blurs related to heavier weekend internet usage.

How can I fully disable KTS internet filter to see if the speed improves then?
Userlevel 1
Have the same issue and just posted on the Community as well. You can review a bunch of posts submitted to the legacy forum, and apply the enhancements advised there. They haven't helped in my case, but maybe they will help in yours.

I do still believe it's a KTS 2019 issue - I didn't have any issues with the previous versions.
Userlevel 1
OK, understood.

Getting back to your first response: are you saying that after KTS installation the internet speed is actually more or less the same, only the speed measurement results are somehow falsified?

If so, is there any reliable tool that is not affected by the KTS driver and can be used for this purpose?
Userlevel 1
Roger that!

So here are the speeds of downloading 1GB test file from https://www.thinkbroadband.com/download:

with KTS 2019 OFF:
  • top speed - 18 MB/s -> 144 Mbps
  • average speed - 12 MB/s -> 88 Mbps
with KTS 2019 ON:
  • top speed - 9 MB/s -> 72 Mbps
  • average speed - 7 MB/s -> 56 Mbps
Obviosuly the bottleneck in this case is with the server, not with the client, but still getting up to almost 150 Mbps is good enough for me. It definitely looks that KTS 2019 is seriously impacting the link speed, and I doubt that 50% speed reduction is something that anyone would accept.
Userlevel 1
@KarDip - how do you attach non-media files in the new community? All I can see is an option to add image / video / link - none of those accepts zip archives.

Roughly the same yes,, which is why I was curious if it got worked out,  Using latest Security Cloud myself,   but prior to installation was seeing downloads  in the low 430’s to as high as 570 Mbps on my main system,,  after installation   17-24 Mbps.  running off the same router , 2 other systems , less capable hardware wise are still seeing 400-500 Mbps and wireless  devices  no lower than low 40’s Mbps.  Even a crappy old dell running ubuntu gets 200Mbps  on a wired connection.  I stopped rolling out to the rest of my systems as a result.

Userlevel 1
Hmmm.... @harlan4096, shoot me but I can't see such option...

Userlevel 1
No worries, @KarDip!

Here's my report: https://www.getsysteminfo.com/report/d4c1e4f4a6448952e1663a4f318f4058
Userlevel 1
Thanks, @BeanSlappers, I've already got both those tweaked and still no luck...

I have the impression that KTS driver/filter is doing this lousy job. I tried disabling individual KTS modules to see if there was any speed difference, and there was none. The only "solution" is to completely exit application (then I can get 60% of my nominal link speed) or completely uninstall it (then 100% is back). However the uninstallation.... You know...
Userlevel 1
@BeanSlappers, oh sure - I've played with my whole network infrastructure for a long time, with no effect again.

I'm running Dell XPS 9360, with i7-7500U, 16GB RAM, 512GD SSD. The bottleneck could be the Realtek network card, but 1. I've also tweaked its parameters, and 2. the issue appeared somewhere with KTS 2019 (unfortunately I can't say which build), as in the past I had no throughput problems with this card.
Userlevel 1
I had a technician visiting me last week on this issue and he confirmed everything was fine.

Moreover, I have my business laptop (with another security suite) also cable-connected to my router and I can get the full speed on it.

Finally, as I said - I did several speed test before I installed KTS and after doing so. In the meantime there were no other installations, updates or other configuration changes. KTS seems then to be the only culprit. It's possible it can be an isolated situation, but I do believe it needs to be validated by Kaspersky Support.

I've placed my support request over 2 days ago and till now, no engineer has even been assigned to review it 😒
Userlevel 1
@Friend, thank for this!

My support case No is INC000010341584. I'm a bit disappointed so far, as I entered all the necessary info and the GSI report, and in return I was asked to provide the very same info and GSI report that was already there!

I'm aware of the E patch, but since I have a fresh KTS install, it looks it hasn't been yet enabled to me (as explained in the ticket). I do the manual database update everyday hoping it will get downloaded, but so far no luck. Is there any way to enforce this module update?
Userlevel 1
Some update: Support has advised me to upgrade to the 2020 RTM version to see if it helps. I've installed version 20.0.14.1085 and... it's much worse! 😮 All I can get now is 60-65 Mbps...
I saved the app settings, so 2020 is operating with the KTS config that assured the best possible networks performance I could get with 2019.
Userlevel 1
@Friend, later after posting I actually removed 2020 and cleared everything with Kavremover, then re-installed 2020 with no legacy settings. No improvement whatsoever...

Support told me that the code changes in 2020 were i.a. directed into improving the scanning driver, so they should positively impact the network performance.

I did some more test and the speed varies, but in general the results are worse than for 2019...