Kaspersky
Question

Browser extension duplicates audio on certain websites

  • 24 February 2021
  • 23 replies
  • 165 views

Userlevel 2

Has anyone else encountered issues with KTS browser extension? When I go, for example on 9gag.com it loads audio twice of every video that I play. This happens on other websites too, especially web radio stations. If the extension is disabled, everything works fine.

I’m using Kaspersky Total Security on Windows 10 64bit.


23 replies

@semperlabs  hello!

Try to add this URL to the list of SSL exclusions, then retest the issue. Does it help?

 

Userlevel 2

Where exactly is this setting located? Is this Network → Encrypted Connection Scanning ?

Userlevel 7
Badge +9

Hello @semperlabs,

Yes:

 

 

 

&

  1. Which KTS version & patch(x) is installed → on the Windows Taskbar or hidden icons, rightclick the Kaspersky icon, select About ?  
  2. Does the same “ loads audio twice for every video” issue happen in every Supported browser: Chrome, Edge Chromium & Firefox? 
  3. Is Private browsing → Allow data collection on 9gag.com Allowed → image 2 above?
  4. Is Anti-Banner → Banners on 9gag.com Allowed → image 2 above?  

Thank you:pray_tone3:

Flood:whale:+:whale2:

Userlevel 2
  1. 21.2.16.590 (b)
  2. Every browser that has Kaspersky Extension installed. I have tried on Chrome and Edge (Chromium)
  3. Can you try on this website http://www.rdv.ba/live/ it loads audio twice, and I did as described
  4. Did as described but issue persists

Thank you in advance

 

EDIT:

I added this website on exceptions list

Userlevel 7
Badge +9

Hello @semperlabs

You’re most welcome:relaxed: !

:flushed: rdv.ba, crikey! That’s LOUD:sweat_smile:

  1. Ok, the sound control does not respond, it’s just LOUD! 
  2. The sound OFF, does not respond. 
  3. It’s not duplicating audio.
  4. Site is not secure

     

  1. We’ll adjust the PB, AB &  Encrypted Connection Scanning exclusion & report back.

Question, just to confirm, the Encrypted Connection Scanning exclusion for 9gag didn’t work, is that correct? 

Please let us know? 

Thank you:pray_tone3:

Flood:whale:+:whale2:

Userlevel 2

Lol sorry for the loudness on their behalf :) Pause and unpause the audio on the controls you’ll see there is another parallel audio playing in the background. Controls work then the extension is disabled, I can confirm that, you should try as well.

 

 

Both added on exclusion but problem is still there. Restarted everything.

Just to mention, everything works in `incognito` mode where extension is not enabled.

Userlevel 7
Badge +9

Hello @semperlabs

Thank you for posting back:ok_hand_tone3:

We appreciate the apology, however, we can no longer hear, so it’s meaningless:joy:

Thanks for the incognito info:ok_hand_tone3:

Re “Pause and unpause the audio on the controls”, we can’t, they do not respond, as per our 1. & 2. advice in our last reply. 

We’re in the process of testing our solutions, as per our original reply… 

We’ll update shortly. 

Thank you:pray_tone3:

Flood:whale:+:whale2:

Userlevel 7
Badge +9

Hello @semperlabs

  1. Question, with or without any of the suggestions by @Anton Mefodys or ours, is everything visually resolving correctly on rdv.ba? 
  2. Post an image of “Pause and unpause the audio on the controls you’ll see there is another parallel audio playing in the background”, we’re not able to see what you mean please? 
  3. Edit additional:confounded:

     

     

     

Thank you:pray_tone3:

Flood:whale:+:whale2:

Userlevel 2

 

Playing

 

Paused

 

Controls work, but it appears that it just controls one of the audio streams. Are you able to replicate this issue on your side?

  1. Open website
  2. Click pause
  3. Wait for 5 seconds
  4. Click play

You’ll hear audio with 5s delay.

 

EDIT:

http://www.rdv.ba/live/ 

This is the link for the live radio, I wasn’t going on the homepage.

Userlevel 7
Badge +9

Hello @semperlabs

Thank you:ok_hand_tone3:

  1. Question, with or without any of the suggestions by @Anton Mefodys or ours, is everything visually resolving correctly on rdv.ba? 
  2. Recreate the  rdv.ba issue, at the same time, open the developer log, console tab, do you see errors (red) the same as ours, post a full screen image please? 
  3. Exit all browsers, uncheck Inject script into web traffic to interact with web pages, open browser, recheck rdv.ba, working correctly or not? 
  4. Have rdv.ba & 9gag ever worked properly? 

 

 

 

Thank you:pray_tone3:

Flood:whale:+:whale2:

 

Userlevel 2

It’s not resolved (1)

I see only this in the developers console (2)

http://www.rdv.ba/live/

I tried that (3) as well, same thing.

Everything worked properly until 5-6 days ago, but I didn’t know what is causing this, so I contacted this website to resolve it, and then I realized it’s on other sites as well.

 

But don’t focus on rdv.ba it happens on 9gag as well, for example this video

https://9gag.com/gag/aDdz34G

 

When it first loaded, it works fine because the player is muted. But if the player is not muted, and I refresh the page, I can hear it twice, and controls are not working.

 

I wonder if anyone else has the same issue

 

EDIT:

When there are more videos on one page everything works fine, but when it’s isolated on one page like in new tab it doesn’t

Userlevel 7
Badge +9

Hello @semperlabs

Thank you for posting back!

Re 9gag, you’re seriously determined to ruin our hearing:rofl:

OK, on 9gag, with the sound going off the graph, muting via the sound icon, makes no difference (for us). 

Log a case with Kaspersky Technical Support, select Application malfunction, Incompatibility with 3rd party software template; Support will request Traces, Logs & other data, they will guide you

 

  • After submitting the case, you’ll receive an automated email with an INC+12digits reference number, then, normally, within 5 business days, a Kaspersky Technical Support human will be in touch, also by email, you may continue to engage with the Kaspersky Technical Team via email or by updating the INC in the MyKaspersky account.

:large_blue_diamond: Please share the outcome with the Community when it’s available? 


Thank you:pray_tone3:

Flood:whale: +:whale2:

Userlevel 2

Will do, thank you, and I’m sorry for the trouble,… I SAID I’M SORRY FOR THE TROUBLE (joke because of the hearing loss :D).


Till next time

 

Userlevel 7
Badge +4

Will do, thank you, and I’m sorry for the trouble,… I SAID I’M SORRY FOR THE TROUBLE (joke because of the hearing loss :D).


Till next time

 


Hello,

This issue is a very intersted case. When KL addone is enabled, the browser will post two request to http://www.shoutcastunlimited.com:8892/stream/1/ to response media type network traffic. So this result two sound raise from the browsers. One sound can be control, another can not.

KL Proctection addone is enabled
The browser’s port enviroment

 

KL Proctection addone is closed

Regards.

Userlevel 2

So it’s not just me. I contacted the support directly so I’m waiting for their response.

I will share the outcome here.

 

Best regards, and thank you

Userlevel 7
Badge +9

Hello @semperlabs
Thank you for posting back & for logging the case:ok_hand_tone3:

Of course it’s not just you! We established that last night! 

Regarding the changes/tests we requested above, please reverse anything that did not work.  

Btw, you have shocking taste in music:rofl:

Thank you:pray_tone3:

Flood:whale: +:whale2:

Userlevel 2

I have reversed everything back, thanks!

  

Btw, you have shocking taste in music:rofl:

 

Hahaha shocking as in shockingly awesome?

 

 

Userlevel 7
Badge +4

Hello @semperlabs
Thank you for posting back & for logging the case:ok_hand_tone3:

Of course it’s not just you! We established that last night! 

Regarding the changes/tests we requested above, please reverse anything that did not work.  

Btw, you have shocking taste in music:rofl:

Thank you:pray_tone3:

Flood:whale: +:whale2:


Hello, @Flood and Flood's wife 

The most strange things is that this issue doesn’t occur in 2021 MR3 Beta build I have tested.:sweat_smile:

And Happy chinsese Lantern Festival.

BR.

Userlevel 7
Badge +9

Hello @Wesly.Zhang

Happy Chinese Lantern Festival and New Year🐂 to you & your family too! 

We hope your year will be filled with good health, good friends and good luck:grinning:  

Issue not replicable in MR3, we’re not sure that’s necessarily strange, but, it’s certainly good news. 

Roll on MR3:wink:  

@semperlabs,

For information, MR3 is the next release, due some time in March 2021, no exact date available; the patch will be released globally, in staggered distribution; the patch arrives silently, you will not know when it’s arrived; after it’s arrived, it waits for 7 days, if, in that 7 days, the computer has not been rebooted, at the end of the 7 days: in the KTS Notification centre, there’ll be a “device requires a reboot” recommendation; on the Windows Taskbar or hidden icons, the KTS icon will turn red; in your MyKaspersky account, the device icon will be yellow/orange & in the MyKaspersky Notification centre there’ll be a message stating the “device requires a reboot”.

Thank you:pray_tone3:

Flood:whale: +:whale2:

Userlevel 2

Deal.

Userlevel 2

Thank you for your help guys, just reaching out to say that “2021 MR3” update fixed the issue.

Best regards

Userlevel 7
Badge +9

Hello @semperlabs

Fabulous! Thanks for taking the time to let us know:thumbsup_tone3:

We’re delighted the issue is resolved:cartwheel_tone3:

Question, if we may, did you manually update MR3 or did it happen “automatically”? 

Please let us know?

Thank you:pray_tone3:

Flood:whale: +:whale2:

Userlevel 2

Question, if we may, did you manually update MR3 or did it happen “automatically”? 

 

Kaspersky lab technician sent me the update directly to email, and I installed it manually

Reply