Kaspersky
Question

Automatic update not working automatically. [manual update does work]


Userlevel 1
  • Bronze Theorist
  • 11 replies
I have KTS 19.0.0.1088f, Windows 10 Version 10.0.17134.765

The problem is that the automatic update does not work.
If I press "Update" the update process works OK, but if I do not manually update, every 2 days I get a notification to update:





And the update screen shows that last update was 2 days ago








The update is configured to Daily updates with "run skipped update tasks", so it should run an update even if the computer was off at the update time.








Before I changed the settings to "Daily" it was on "Automatically" and the same thing happened, the automatic update did not work and I got a notification every 2 days to manually update. So I tried to switch to "Daily" update task, and it did not solve the problem.





10 replies

Userlevel 7
Badge +5
Hello Me34,
Welcome!
Thank you for the detailed info and the images - helps enormously!
Has the issue just started or has it been going on for some time?
Have you tried uninstalling / reinstalling KTS?
If not please do so, during the uninstall process select ONLY - save licence information, ignore every other option - https://support.kaspersky.com/us/common/uninstall/12783#block2
  1. Clear Windows Temp folder - https://support.kaspersky.com/us/common/windows/1161
  2. Reboot
  3. Reinstall
  4. Reboot.
  5. Run a manual update.
  6. Setup the automatic update schedule
  7. Test for a period (x days) where you would have seen the issue .
Please let us know?
Thanks
Userlevel 4
Badge +3
If the automatic update task of Kaspersky products does not work properly, the official solution is to reinstall the product.
  1. Download the latest version of the application.
  2. Uninstall the current version of the application.
  3. Install the latest version of the application.
If the issue persists, submit a request to Kaspersky Lab technical support via the My Kaspersky portal. Please include a detailed description of the issue.

Kind regards,
Leon
Userlevel 1
Hello Me34,
Welcome!
Thank you for the detailed info and the images - helps enormously!
Has the issue just started or has it been going on for some time?
Have you tried uninstalling / reinstalling KTS?
If not please do so, during the uninstall process select ONLY - save licence information, ignore every other option - https://support.kaspersky.com/us/common/uninstall/12783#block2
  1. Clear Windows Temp folder - https://support.kaspersky.com/us/common/windows/1161
  2. Reboot
  3. Reinstall
  4. Reboot.
  5. Run a manual update.
  6. Setup the automatic update schedule
  7. Test for a period (x days) where you would have seen the issue .
Please let us know?
Thanks



Thanks, I will try it and get back in a few days
Userlevel 1
After uninstalling kaspersky (leaving only the licence information), reboot, and reinstalling it, the problem is not solved.

Every 2 days I get the same notification to update kaspersky.

If I select "Run Update" the update process runs with no problem, and then after 2 days again the same notification.





Userlevel 7
Badge +4
Hi @me34,

please check 'Settings->Performance'.
If 'Perform Idle Scan' is enabled, updates are also only loaded if the computer is 'idle'.
Userlevel 1
Hi @me34,

please check 'Settings->Performance'.
If 'Perform Idle Scan' is enabled, updates are also only loaded if the computer is 'idle'.



@Schulte
Here are the settings

This is the default settings.
should I uncheck the "Perform Idle Scan" ?

In a normal day the computer is left open and unused for a long time


Hello me34!

Thank you for your reply and the screenshots.

Please have in mind that disabling "Perform Idle Scan" won't solve this issue, as this is only for when the computer is locked or the screensaver is on (you can find more info about this here: https://support.kaspersky.com/14379?cid=KTS_19.0&utm_source=interceptor&utm_medium=product&utm_campaign=KTS_19.0)

A good idea would be to disable the first checkbox in "Performance" inside the settings (Disable schedule tasks...), in case the computer is a laptop. After this wait for a while or even restart the computer and see if the problem persists.

If so, we would need more info in order to study the problem. Could you please send us a GSI? You can do it following this guide: https://support.kaspersky.com/common/diagnostics/3632

With the GSI we will see if there is anything worth checking in your system that may be causing trouble to the update the database automatically.

Thank you!
Userlevel 7
Badge +4
Please have in mind that disabling "Perform Idle Scan" won't solve this issue, as this is only for when the computer is locked or the screensaver is on ...
Of course these setting can help. This shows the experience and the last sentence in your link: 'Idle scan and update tasks will be performed according to these settings.'

should I uncheck the "Perform Idle Scan" ?
@me34:
Yes. Just try it for a few days. It can only get better...
Userlevel 1
@Schulte
I tried to disable the "Perform Idle Scan" checkbox. i will see if this helps.

@Mad Will
This is a desktop, not a laptop, so "Disable schedule tasks..." will not have an effect.
I have run the GSI tool but it collects a lot of personal information. Can I send you specific files from the zip output which will help you analyse the problem?
Or, you can write me what to look for?
Userlevel 7
Badge +5
Hello Me34,
Re: [desktop, not laptop]
As long as Kaspersky software is installed on a compatible operating system, it works.
Please pm the link for GSI & Windows logs.
Thanks!

Reply / Ответить