Kaspersky
Solved

My Visual studio projects not running on self SSL

  • 29 October 2020
  • 7 replies
  • 174 views

Hi,

I am using Kaspersky Security Cloud 21.1.15.500(c)  and when I run my visual studio web application (which run on localhost:5001) on self signed SSL not working at all and here is what I configured:

1-  added https://localhost:5001/* to exclutions in URL Advisor

2- added https://localhost:5001/*  to Trusted URLs

3- added my project folder to exclutions in “Threat and exclutions settings”

4- added [visual studio, msbuild.exe, myAPI.exe ] to trusted applictions in “Threat and exclutions settings”

5- added [localhost,127.0.0.1] to exclutions in “Network settings -> Encrypted connection scanning”

6- enable “Do not decryot SSL connections that use EV cirtifictes”

7- disable “Scan secure traffic in Mozzila appliction” then using firefox as default browser

 

and no luck after all of this. the only way is closing kaspersky to make my applications working. I am struggling on this for 6 days, please can any one help me and explaining what is the problem here

 

icon

Best answer by Friend 31 October 2020, 18:31

Hi, @elawady,
The problem should be fixed in version 21.2.16.590, you can download and install it at this link

View original

7 replies

Userlevel 7
Badge +7

@elawady, try solution from this thread

Userlevel 7
Badge +8

@elawady  ? Also and in addition to andrew75 ?

> Settings > Firewall settings > Packet rules > Add :

  • Action : Allow
  • Name : Visual Studio
  • Directions : Inbound/Outbound
  • Protocol : All
  • Address : From the list > Local addresses : 127.0.0.1 > Save
  • Reboot
     

@elawady, try solution from this thread

 

@andrew75

I added chrome to exception and choosing all options which is more general and nothing

 

@elawady  ? Also and in addition to andrew75 ?

> Settings > Firewall settings > Packet rules > Add :

  • Action : Allow
  • Name : Visual Studio
  • Directions : Inbound/Outbound
  • Protocol : All
  • Address : From the list > Local addresses : 127.0.0.1 > Save
  • Reboot
     

 

@Berny  I disabled firewall at all and nothing

any solution??

I also tried to turn off all components of Kaspersky without exiting and still have the same problem, the only way is to exit from Kaspersky at all.

 can Kaspersky process conflict with my applications in someway? 

notes:

1-  I tried the “hello world” web application and also not working.

2- I am using .net 5 SDK, can the new SDK conflict with the Kaspersky process?

3- I tried the same applications with Kaspersky Free 20.14.1085(m) on different PC and working fine

 

Userlevel 7
Badge +8

@elawady At this point your best option is to submit a ticket to Kaspersky Lab Technical Support : https://center.kaspersky.com 

> Summary > Technical Support Center > Request Technical Support > Create Request

Userlevel 7
Badge +8

Hi, @elawady,
The problem should be fixed in version 21.2.16.590, you can download and install it at this link

Hi, @elawady,
The problem should be fixed in version 21.2.16.590, you can download and install it at this link

finally, it’s working

thankyou :)

Reply / Ответить