Kaspersky stops Explorer from opening when I insert a flash drive

  • 12 February 2021
  • 2 replies

Every time i insert a flash drive or any external drive Karspesky scans it to do its security check. This may be a good hing but unfortunately it stop the drive (as I have it set up to do in Win 10 Pro) from opening o Explorer. This bothers me a lot. How can I stop it in doing this? I want Explorer to open. Seeing that more often than not my drives haven’t left the house I would rather stop it from checking my drives then preventing my Explorer window form opening. I do like it checking my drives and would like to keep it as is, but if I have no choice then I would stop it from checking my inserted drives.

Thanks in advance

2 replies

Userlevel 7
Badge +9

Hello @pintree3


Sadly, Removable drives scan, is either ON or OFF, we’re hoping Kaspersky will refine this & offer more configurable options:thinking:

Open the Kaspersky app, select Scan, scroll down to Removable drives scan, select the Settings icon:gear:, toggle the switch OFF, select Save





Note, our images show Kaspersky Total Security (KTS), Kaspersky Security Cloud is identical. 

Thank you:pray_tone3:

Flood:whale: +:whale2:


Removable drive scan settings

How to run a removable drive scan

Scan settings

Thank you. It’s too bad nothing can be done about having both. I hope Kaspersky does come up with something soon enough.

Reply / Ответить