Kaspersky
Question

Kaspersky Security Cloud Free blocking network

  • 2 December 2021
  • 25 replies
  • 206 views

Windows version: 10 20H2 (19042.1288)
KSC: 21.3.10.391 (g)

Hi,

The issue is that KCS (Kaspersky Cloud Security Free) blocks any and all network access on any network except the one that was active when it was installed, and only if I pause its protection or exit it completely do I have access to the internet, otherwise I can’t access the internet or even the router’s/modem’s settings page. Even the wifi icon says no internet and all websites are inaccessible, only the router page says PR_Connection_Reset.

I checked the reports and didn’t find any thing recorded that was related to network security at all.

This issue happened to me when I used KTS free trial and I had to manually add the network to the trusted networks and I think it worked back then, but I can’t remember well now, but point is KCS is isn’t supposed to have Firewall Security AT ALL.

I hope there is a fix for this, I am facing this issue on two devices, one running Windows 10 20H2 and the other running Windows 10 2004.

Any help would be much appreciated, and please tell me if any details are required.


25 replies

Userlevel 7
Badge +9

@Titan Welcome.

Under normal conditions KSCloud doesn’t block internet or network access.
Do you run any other additional security suite on your system ?
Please reset KSCloud to default settings ?

 

@Berny  Thanks!

No other security suite is running, and I already tried resetting its settings.

Like I said, only when I disable it do I have access to the internet,

Userlevel 7
Badge +9

@Titan Please reinstall on top KSCloud as ADMIN ?

@Berny You want me to reinstall KSC and run the setup as admin? Ok will do.

@Berny That worked thankfully (although I forgot to select run as admin, my bad), but doesn’t this seem like an inefficient solution where I have to reinstall every time I connect to a different WiFi network?

Userlevel 7
Badge +9

@Titan

Thank you for your feedback.
Can you please describe what’s going on when you switch on another Wi-Fi.

 

@Berny Sure, it just doesn’t allow me to access the internet, and the WiFi icon says no internet, plain and simple. ACTUALLY, I tried again now and:

  • Device 1 (which had KCS re-installed):
    The home WiFi works correctly.
    When I made a hotspot from a third device, it worked as well.
  • Device 2 (haven’t reinstalled yet):
    Home WiFi isn’t working.
    Hotspot WiFi is working.

This whole ordeal started when I swapped my router, but how does it interfere with KCS where a simple reinstall solves it is baffling me.

Userlevel 7
Badge +9

@Titan

Can you on Device 2 access your Home Wi-Fi  192.168.x.xxx with your Browser  ?
Please check your network with “Wireless Network Watcher” → nirsoft.net

Update: I was wrong. The same issue happened again on the device I reinstalled on, the home WiFi isn’t working.

I have to mention that on a device that has Windows 11, the issue didn’t happen, but I don’t want to install it on those devices since Windows 11 has some annoying (not dangerous but annoying) bugs.

@Titan

Can you on Device 2 access your Home Wi-Fi  192.168.x.xxx with your Browser  ?
Please check your network with “Wireless Network Watcher” → nirsoft.net

That was what I meant in my original post when I said:
“otherwise I can’t access the internet or even the router’s/modem’s settings page.”
and
“ only the router page says PR_Connection_Reset. “
I can’t even access the router settings.

Userlevel 7
Badge +9

@Titan 

Tech Support is not available for free versions and we don’t request system Logs for privacy reasons,

maybe other other suggestions might  bring a solution for your problem.


 

@Berny Thank you for your effort though!

Userlevel 7
Badge +8

Hello @Titan,

I guess you are using Firefox.
Does the problem also occur with other browsers, e.g. Edge?

@Schulte Yes I was using Firefox, no I didn’t try the other browsers since Windows itself says “No internet”.

Userlevel 7
Badge +8

Hello @Titan,

unfortunately it took a while, I just installed KSC Free on another computer.

What stands out first:
under 'Settings->Network settings' 'Support DNS over HTTPS' is enabled.
Can you please disable this and then test again?

@Schulte I appreciate your effort, but unfortunately it will have to wait until tomorrow for urgent reasons, I apologise.

I will keep you updated with the results of the test as soon as I try it out!

@Schulte I tried again with that setting disabled, and then tried disabling all settings under Network Settings but still no luck, tried with Firefox and Edge.

Userlevel 7
Badge +9

@Titan Just a guess , do you use the original Windows Hosts file ?

@Berny Would it even matter per network? I mean I think one device has a modified one and the other has the original, but point is that the hosts file is a global one and doesn’t apply to only one wifi network.

Userlevel 7
Badge +8

Hello @Titan,

I have read through the whole thread again.
It is possible that there are still some remnants of your KTS installation. Did you keep settings during the uninstallation?

I think it is reasonable to use Kavremover in your case. However, this can also lead to errors, so it would be best if you create a backup of important data.
Please read the instructions carefully and then apply the remover.

https://support.kaspersky.com/common/uninstall/1464

I hope that after that the KSC Free will run without any problems (after reinstallation).

@SchulteThe two devices I mentioned never had KTS installed, the device which actually had KTS is a third one that surprisingly doesn’t have such problems thankfully, but I have to mention it is running on Windows 11, and I probably haven’t used KTS on it since I reinstalled Windows and wiped everything mostly (the wipe happened a few months back, before the current problem).

I apologise for any confusion.

Userlevel 7
Badge +8

OK, let's search further.
All the following tips are for troubleshooting. They should not be used as default!

Go to 'Settings->Network settings' and set 'Encrypted connection scanning' to 'Do not scan encrypted connections'.
You may have to restart the computer for this setting to take effect.

I already tried disabling ALL settings in network settings, but didn’t restart. I am going to try that tomorrow (it is late now) hopefully and get back to you.

Userlevel 7
Badge +8

I wish you a pleasant night's rest.

Task for tomorrow:

with KSC Free the Kaspersky VPN is also installed. If you don't want to use it, please uninstall it via Windows Control Panel.

Then you should look at one more setting:
'Settings->Network settings->Proxy server settings'. There 'Automatically detect proxy server settings' should be set.

@Schulte I apologise for the late reply, didn’t have a lot of free time lately.

Unfortunately your suggestions didn’t make a difference.

Reply