Kaspersky
Solved

Kaspersky SC prompts "New Ethernet Connection detected" every time I connect to PIA VPN using WireGuard

  • 11 February 2021
  • 2 replies
  • 33 views

I use Private Internet Access and recently switched from using the OpenVPN connection protocol to WireGuard, because my connection speed increased from ~36 Mbps to over 100. However, every time I connect to the VPN, Kaspersky Security Cloud gives me an alert that a new ethernet connection is detected. It prompts me to choose the level of network activity I want to allow and I have to type in my password every time.

 

I have tried adding an exception to the WireGuard network adapter (Settings→Additional→Network→Encrypted Connection Scanning→Manage Exclusions). This doesn’t work because every time I connect to the VPN, a new IPv4 address is assigned to the adapter (seen under Control Panel\Network and Internet\Network Connections Status→Details), rendering the previous exclusion useless.

 

Is there a way to exclude the WireGuard network adapter from this alert or disable this notification feature entirely?

icon

Best answer by Schulte 11 February 2021, 02:15

Hello @sergei791, Welcome.


Go to 'Settings->Protection->Firewall'.
Scroll down and click 'Available Networks'.
Double click your VPN (in my case Kapersky's VPN).

 


In the next window select 'Automatically move new networks to the group: [whatever you think is appropriate]'.

 


I prefer 'Public network for standard VPN connections.

Click ‘Save’

View original

2 replies

Userlevel 7
Badge +7

Hello @sergei791, Welcome.


Go to 'Settings->Protection->Firewall'.
Scroll down and click 'Available Networks'.
Double click your VPN (in my case Kapersky's VPN).

 


In the next window select 'Automatically move new networks to the group: [whatever you think is appropriate]'.

 


I prefer 'Public network for standard VPN connections.

Click ‘Save’

@Schulte Thank you for your reply - I saw this solution elsewhere, however, for KSC Free users, we don’t have access to the Firewall menu. This brings to mind why this feature is enabled then if there is no control over it? I’ve seen another post with the same issue - this seems like something Kaspersky would need to look at.

 

In my case, as cliche as it is, simply uninstalling PIA, rebooting, uninstalling KSC, rebooting, and then reinstalling in the reverse order seemed to fix the problem - maybe it was a KSC issue or a PIA issue, but either way I’m happy for now.

Reply / Ответить