Kaspersky
Solved

Kaspersky changing attached file names like .pdf to .pd_ apparently due to filtering attachments [Merged]

  • 28 December 2020
  • 12 replies
  • 1186 views

My email in outlook on one of my computers is having the last character in the attachment file extension changed to a dash such as .pdf changed to .pd_.

In googling the problem, it is apparently associated with the "Filtering email message attachments" settings.  The solution they suggest looks to be for a version of Kaspersky other then Security Cloud because it starts out by asking me to open the application setting window.  I can not find it.

icon

Best answer by Flood and Flood's wife 9 January 2021, 04:17

Hello @Craig

Welcome!

You’re not missing anything, you’re absolutely correct, Kaspersky has acknowledged a bug with KIS 21.2.16.590(b), please read:

Kaspersky changing attached file names like .pdf to .pd_ apparently due to filtering attachments, raised by @Bookstore Bill 

&

Microsoft Outlook 2019 and Attachments, all attachments come with a weird extension_, .xls_  raised by @azucena

Also, the same topic raised in Spanish, German, Russian, French, Italian forums. 

  • If there are any existing files extensions that have been changed to  JP_, or similar, they must be manually changed.
  • The fix from Kaspersky, @Anton Mefodys, was an update of the fix shared by @Katie_A “

quote: 

@Anton Mefodys 
If you face this issue, where Outlook email attachments are showing as blank icons and the file extension changes to underscores in the last character, for example:

".pdf" shows as ".pd_",
".docx” as ".doc_"”
".png" as ".pn_"

Email pictures included in HTML formats are also broken and the right-click properties all greyed out.

To fix this issue: 
1. Close Outlook. 
2. Open Kaspersky Internet Security (or Kaspersky Total Security)
3. Go to Protection (select on the left pane) -> Mail-Anti-Virus -> Advanced Settings -> make sure that only the dangerous extensions are selected: *.bat, *.сmd, *.com, *.exe, *.js, *.jse, *.msi, *.scr, *.vbe, *.vbs.
4. Open Outlook.

This solution fixes all new incoming email. Unfortunately past emails affected by this will not be changed - so to manually solve this: 

1. Right click on the file in the Outlook
2. Choose "Safe as"
3. In the "File name" field change the extension by replacing the "_" with the correct letter, e.g. ".pd_" -> ".pdf"
4. Press "Save" button. 
Now you can open the saved file in its saved location. 

The answer by @Katie_A  has been taken as the base for this answer, we added a few steps to it to make it complete.

unquote

Thank you:pray_tone3:

Flood:whale:+:whale2:

View original

This topic has been closed for comments / Тема закрыта для комментариев

12 replies

Userlevel 7
Badge +9

Hello @Bookstore Bill

Welcome!

Open Kaspersky Security Cloud application, select Settings:gear: → lower left hand corner & bottom of the app window:

 

 

Thank you:pray_tone3:

Flood:whale: +:whale2:

Hello @Bookstore Bill

Welcome!

Open Kaspersky Security Cloud application, select Settings:gear: → lower left hand corner & bottom of the app window:

 

 

Thank you:pray_tone3:

Flood:whale: +:whale2:


Thanks, that got me past the first hurdle. The next step I have in eliminating the problem of fie extension names having their left letter changed to an underscore is:

“2 In the left part of the window, in the Anti-Virus protection section, select the Mail Anti-Virus subsection.
In the right part of the window, the settings of the Mail Anti-Virus component are displayed”

I did not see the first part but I did seethe second so I clicked on that.

Now I have the mail Anti-Virus settings window open

The next instruction is  “4 In the Mail Anti-Virus window, select the Attachment filter tab.”

I do not see an “Attachment filter tab”

 

I am trying to follow the institutions in: https://support.kaspersky.com/KESWin/10SP2/en-US/128353.htm

 

Thanks, that got me past the first hurdle. The next step I have in eliminating the problem of fie extension names having their left letter changed to an underscore is:

“2 In the left part of the window, in the Anti-Virus protection section, select the Mail Anti-Virus subsection.
In the right part of the window, the settings of the Mail Anti-Virus component are displayed”

I did not see the first part but I did seethe second so I clicked on that.

Now I have the mail Anti-Virus settings window open

The next instruction is  “4 In the Mail Anti-Virus window, select the Attachment filter tab.”

I do not see an “Attachment filter tab”

 

I am trying to follow the institutions in: https://support.kaspersky.com/KESWin/10SP2/en-US/128353.htm

Userlevel 7
Badge +8

@Bookstore Bill Please see more details in this Topic.

 

 

Userlevel 7
Badge +9

Hello @Bookstore Bill

You’re most welcome:relaxed: !
Thank you for posting back:ok_hand_tone3:

If you’re past the first hurdle, that’s progress:clap_tone3:

The documentation you’re referring to: Kaspersky Endpoint Security 10 Service Pack 2 for Windows, Filtering email message attachments, from Kaspersky Business product line, is not appropriate for Kaspersky Security Cloud, for Home users. 

To configure the filter, please follow our images & the guidance from @Katie_A, updated by @Anton Mefodys, in topic Microsoft Outlook 2019 and Attachments, all attachments come with a weird extension_, .xls_ raised by @azucena 

 

 

 

 

 

 

:warning:NOTE, configuring the Mail AV, attachment filter only applies to new emails, any emails impacted by Kaspersky’s poor implementation of the feature, remain uncorrected. At this stage, according to Kaspersky, any documents affected by the “bug” must be changed manually.

Thank you:pray_tone3:

Flood:whale: +:whale2:

The answer by Flood and Flood’s wife solved my problem.  Thanks a lot.

Hello everyone,

My MS Outlook 365 MSO 64 bits, changed the attached files names for all attachment types automatically to my new emails sent, and to my historical emails. Actually, it replaced the last letter of the file type with an underscore (“_”); (i.e. “.docx” to “.doc_” or “.pdf” to “.pd_”). I did check my Kaspersky configuration related to this matter, and this is what I had by default:

 

Settings->Protection->Mail Anti-Virus->Advanced Settings/Protection Scope_incoming and Outgoing messages (checked) / Connectivity_Scan POP3, SMTP,NNTP, and IMAP traffic (checked) _Connect Microsoft Outlook Extension (checked) / Heuristic analysis_Medium scan / Scan of compound files_scan attached files of Microsoft Office formats (checked) / Scan attached archives (checked) / Attachment filter_Rename attachments of selected types

 

I understand Kaspersky found something up and did the change? If so, how can I resolve the problem? I did not get any message about it. Can I reverse the changes in my historical messages?

Thank you in advance for you help on the matter…

 

Userlevel 7
Badge +9

Hello @LYON

Welcome!

Files that have already been changed by this issue, according to Kaspersky, have to be renamed manually. Kaspersky have not offered any solution for renaming files impacted by this “bug”, other than to tell everyone to rename the affected files manually

Please read:

Thank you:pray_tone3:

Flood:whale: +:whale2:

Thank you !

You have cost me +/- 5 hrs of my time today getting to the bottom of why I’m losing documents + images! And you want me to renew my subscription. You should be paying me, for the loss of time. £32 for 1 year and £50 for 2 years, doesn’t cover +/- 30 min’s of my time!!! I wait to hear from you via a private message. It’s all over the internet, your default settings - but did you advise your loyal customers of +/- 10 years, no!  

I have two computers, both running Windows 10, Office 365 and KIS.  I received two emails today from different sources, both with images attached.  In both cases, the images had their file extensions modified from JPG to JP_.  When this happens, the files will not open without manual manipulation of the file extension.

I experimented and forwarded new sample images between my two PCs and found that one was inflicted by this issue and one was not.  The only difference I can see between the two systems is the version of KIS (Windows and Office match exactly).

   - PC #1 (issue with modified extensions) -- KIS 21.2.16.590(b)

   - PC#2 (no issues) -- KIS 21.1.15.500 (  c)

Am I barking up the right tree with KIS or am I missing something obvious.  Haven’t experienced this issue before so am kind of stumped.  Thanks!

Userlevel 7
Badge +9

Hello @Craig

Welcome!

You’re not missing anything, you’re absolutely correct, Kaspersky has acknowledged a bug with KIS 21.2.16.590(b), please read:

Kaspersky changing attached file names like .pdf to .pd_ apparently due to filtering attachments, raised by @Bookstore Bill 

&

Microsoft Outlook 2019 and Attachments, all attachments come with a weird extension_, .xls_  raised by @azucena

Also, the same topic raised in Spanish, German, Russian, French, Italian forums. 

  • If there are any existing files extensions that have been changed to  JP_, or similar, they must be manually changed.
  • The fix from Kaspersky, @Anton Mefodys, was an update of the fix shared by @Katie_A “

quote: 

@Anton Mefodys 
If you face this issue, where Outlook email attachments are showing as blank icons and the file extension changes to underscores in the last character, for example:

".pdf" shows as ".pd_",
".docx” as ".doc_"”
".png" as ".pn_"

Email pictures included in HTML formats are also broken and the right-click properties all greyed out.

To fix this issue: 
1. Close Outlook. 
2. Open Kaspersky Internet Security (or Kaspersky Total Security)
3. Go to Protection (select on the left pane) -> Mail-Anti-Virus -> Advanced Settings -> make sure that only the dangerous extensions are selected: *.bat, *.сmd, *.com, *.exe, *.js, *.jse, *.msi, *.scr, *.vbe, *.vbs.
4. Open Outlook.

This solution fixes all new incoming email. Unfortunately past emails affected by this will not be changed - so to manually solve this: 

1. Right click on the file in the Outlook
2. Choose "Safe as"
3. In the "File name" field change the extension by replacing the "_" with the correct letter, e.g. ".pd_" -> ".pdf"
4. Press "Save" button. 
Now you can open the saved file in its saved location. 

The answer by @Katie_A  has been taken as the base for this answer, we added a few steps to it to make it complete.

unquote

Thank you:pray_tone3:

Flood:whale:+:whale2: