Kaspersky
Solved

how to switch off 'protected browsing'

  • 10 August 2021
  • 5 replies
  • 67 views

  • Community Citizen
  • 2 replies

I’m new to this latest version of Kaspersky (used it 10+ years ago), and thought it was a good idea to enable ‘protected browsing’ when it was offered on Amazon.com … it was a bad idea. Loading the page took forever.

 

How can I switch that option off again? (could not find it after searching for a good 30 minutes).

icon

Best answer by Schulte 11 August 2021, 19:27

View original

This topic has been closed for comments

5 replies

Userlevel 7
Badge +8

Hello @stfhz, Welcome.

Do you mean 'Safe Money'?
'Settings->Protection->Safe Money'.

 

 

No, not safe money. Unless there is a different name for that function … the option I was presented is called ‘protected browser’ … when I go to Amazon.com, a new browser window (not tab) opens up saying “starting protected browser” … and it takes forever.

Userlevel 7
Badge +8

Hi @stfhz,

I think it’s the same:

 

 

Hi @stfhz,

I think it’s the same:

 

 

Seems like it is. Switching off that option did the trick. Thank you!

 

Userlevel 7
Badge +8

Hello @stfhz,

glad it helped at first.

But 'Safe Money' is an important protection feature that you should not disable (if it works for the specific site).
In the settings (see my first screenshot) you can remove non-functional pages from the list after re-enabling and use the function for other pages e.g. online-banking.