Kaspersky

Mount nfs-root over tcp (PXE boot) [MOVED]

  • 6 November 2019
  • 13 replies
  • 197 views

Badge

Hi all!
Please, fix init-script for mounting NFS-root over TCP. NFSv4 by default no listen UDP-ports. If PXE-server have NFSv4, KRD can not mount NFS-root and can not start.

Thanks you for your work!

 

//Mod Note: moved to the correct section.


13 replies

Userlevel 7
Badge +5

Hello   @mekatum,

Welcome!

Your post apper to be describing an problem, however the post has been raised in “Suggestions to the Community”.

Please let us know if the Kaspersky software is Kaspersky Rescue Disk and do you have any other Kaspersky software?

Thank you

Badge

@FLOOD 
I’m sorry. I was in a hurry and accidentally posted this topic in “Suggestions to the Community”.

Yes, I described some problem with Kaspersky Rescue Disk. May be moderators can help me move topic to right chapter.

Userlevel 7
Badge +5

Hello  @mekatum.

Thank you for letting us know and don’t worry, it’s easy to post in a wrong section.

The Moderators have kindly moved the topic to Kaspersky Rescue Disk section. 

Thank you. 

Userlevel 2
Badge

Hi, @mekatum!

KRD can not mount NFS-root and can not start.

Can you provide photo of this error please?

NFSv4 by default no listen UDP-ports.

It seems that KRD init script can’t work with NFS v4 at all. Will you test fix of script  If i provide additional initrd file?

Badge

@Andrey Kirzhemanov 

I disable UDP in nfs.conf. NFS-server listen only TCP:

$ rpcinfo -p
program vers proto port service
100000 4 tcp 111 portmapper
100000 3 tcp 111 portmapper
100000 2 tcp 111 portmapper
100000 4 udp 111 portmapper
100000 3 udp 111 portmapper
100000 2 udp 111 portmapper
100024 1 udp 33363 status
100024 1 tcp 39615 status
100005 1 udp 20048 mountd
100005 1 tcp 20048 mountd
100005 2 udp 20048 mountd
100005 2 tcp 20048 mountd
100005 3 udp 20048 mountd
100005 3 tcp 20048 mountd
100003 3 tcp 2049 nfs
100003 4 tcp 2049 nfs
100227 3 tcp 2049 nfs_acl
100021 1 udp 60018 nlockmgr
100021 3 udp 60018 nlockmgr
100021 4 udp 60018 nlockmgr
100021 1 tcp 43269 nlockmgr
100021 3 tcp 43269 nlockmgr
100021 4 tcp 43269 nlockmgr

NFS-share:  

$ cat /etc/exports

/srv/tftpboot/mnt/live/krd 10.10.10.0/24(ro,wdelay,insecure,no_root_squash,all_squash,no_subtree_check,anonuid=1000,anongid=1000)

pxelinux config:

LABEL Kaspersky Rescue Disk 2018
LINUX ../mnt/live/krd/boot/grub/k-x86_64
INITRD ../mnt/live/krd/boot/grub/initrd.xz
APPEND nfsboot=10.10.10.41:/srv/tftpboot/mnt/live/krd/ net.ifnames=0 lang=en dostartx

Screenshot:

 As you can see, my NFS-server can ping. I try mount NFS-share manually, but I get “connection time out”. Then I add “tcp” option and NFS-share is successfully mounted. 

It seems that KRD init script can’t work with NFS v4 at all.

My mistake. My NFS-server by default provide NFSv3 and NFSv4, but not listen UDP (by default).

As I know, KRD based on SystemRescueCD 5.x.x., it not support NFSv4. You are right.
https://web.archive.org/web/20181016223523/http://www.system-rescue-cd.org/manual/PXE_network_booting/
 

Will you test fix of script  If i provide additional initrd file?

Yes, I can test.

Userlevel 2
Badge

@mekatum 

Please, download additional initrd from here and place it somewhere in nfs share. Change pxelinux config:

LABEL Kaspersky Rescue Disk 2018
LINUX ../mnt/live/krd/boot/grub/k-x86_64
INITRD ../mnt/live/krd/boot/grub/initrd.xz,%some path%/initrd1.xz
APPEND nfsboot=10.10.10.41:/srv/tftpboot/mnt/live/krd/ net.ifnames=0 lang=en dostartx

and try to boot KRD. If something goes wrong then make photo of error.

Badge

@Andrey Kirzhemanov 

I add new initrd to pxelinux config:

LABEL test
LINUX ../mnt/live/krd/boot/grub/k-x86_64
INITRD ../mnt/live/krd/boot/grub/initrd.xz,../mnt/live/initrd1.xz
APPEND nfsboot=10.10.10.41:/srv/tftpboot/mnt/live/krd/ net.ifnames=0 lang=en dostartx vga=791

NFS-share was be updated and work (old initrd work from this NFS-share and new initrd must work too)

$ ls -l mnt/live/

-r-xr-xr-x. 1 support support 15045948 Nov 7 15:16 initrd.xz
-r-xr-xr-x. 1 support support 13176 Nov 7 15:05 initrd1.xz

$ cat /etc/exports

/srv/tftpboot/mnt/live/krd 10.10.10.0/24(ro,wdelay,insecure,no_root_squash,all_squash,no_subtree_check,anonuid=1000,anongid=1000)

/srv/tftpboot/mnt/live/ 10.10.10.0/24(ro,wdelay,insecure,no_root_squash,all_squash,no_subtree_check,anonuid=1000,anongid=1000)


With kernel parameter “dostartx” I got kernelpanic
 

 

Without “dostartx” I got this
 

 

Userlevel 2
Badge

@mekatum , sorry for bug! Please, download initrd and try again.

Badge

Yes, it’s work correctly! It’s can mount NFS-share over TCP and LiveCD successfully boot.

Thank you!

Userlevel 2
Badge

@mekatum, thanks for testing! Now you can use this additional initrd file as workaround. I’ll add this fix into next KRD patch. But i don’t know when this patch will be released to users...

Badge

@Andrey Kirzhemanov 
I'm always happy to help. I will wait new patch.

Thank you and your team for your work!

Badge

@Andrey Kirzhemanov 
Is it way to find out about the new version of krd.iso?

Userlevel 2
Badge

@mekatum, I’ll write message in this topic when new KRD.iso with fix will be released (but i don’t know now when it will be released).

Reply / Ответить