Kaspersky
Solved

Не периодически возникает ошибка на старте

  • 29 August 2019
  • 35 replies
  • 6239 views

Userlevel 1
Здравствуйте!

Проявляется редко и как воспроизвести я пока не понял.



Система Win7 x86 Home.
Версия KPM 9.0.2.972 (b) / 1563191215_6231 / 1.0.363.0-0.8.3.0_1

После нажатия ОК программу можно запустить и далее всё работает нормально.
icon

Best answer by Friend 9 October 2019, 10:03

View original

35 replies

Userlevel 7
Badge +9
@Sandor патч d вышел, ожидайте.
Мне только сегодня пришел пару минут назад.

Userlevel 7
Badge +9
@Sandor @No user name ошибка Лаборатории Касперского известна, но вот сроки решения неизвестны. Мне предложили такое решение пробуйте:
  1. . Выгрузите Kaspersky Password Manager из трея и остановите сервис Kaspersky Password Manager через Диспетчер задач.
  2. . Удалите все файлы eka_lock_* из папки: c:\ProgramData\Kaspersky Lab\Kaspersky Password Manager\Data\ в Безопасном режиме Windows.
  3. Выдайте права всем пользователем на запись/чтение/исполнение на папку c:\ProgramData\Kaspersky Lab\Kaspersky Password Manager\Data\eka_lock_KSN
  4. Перезагрузите компьютер и понаблюдайте за проблемой.
Userlevel 7
Badge +9
если опять грохнуть и поставить предыдущую версию, можно ли как то запретить ему обновляться?
Нет, тогда перестанут обновляться базы и не будут приходить исправления найденных ошибок.

С учетом, что в Лаборатории данная проблема известна, я так понимаю, что всякие логи снимать бесполезно.
Наоборот, стоит, чем больше обращений по проблеме, тем быстрее ее решат. Поэтому создайте запрос через Личный кабинет, подробно опишите проблему, соберите трассировки Kaspersky Password Manager, отчет о системе GetSystemInfo6.
Userlevel 7
Badge +9
@Sandor решение проблемы изменилось, отправил в ЛС.
Поддержка сообщила, что исправление будет в будущем патче Kaspersky Password Manager.
Userlevel 1
Вчера мне тоже пришел патч. Установился успешно.
Userlevel 1

Поправка: всё это время ошибка больше не проявлялась.

9.0.2.1186 (c) / 1566924466_6244
Изменений по железу и обновлений никаких не делалось, так же ничего не устанавливалось.
Копию создал.
Userlevel 7
Badge +7
@Sandor @No user name рекомендую вам обратится в к специалистам поддержки, для диагностики ваших проблем
Ради интереса поставил на виртуалку, она обновилась сама до "С", там ошибка не возникает, сейчас на основной машине грохну и поставлю заново.
Короче, грохнул, ребут, установил, ребут, качал с оф сайта, поставилась версия 9.0.2.972 (b) / 1566924466_6244 т.е. "В", несколько ребутов после этого, ошибки нет, но и нехочет сама обновляться сама на "С", при ручной проверке, пишет, что у вас последняя версия. Если обновится в итоге на "С", то обязательно отпишусь в любом случае.
Userlevel 1
@kmscom , я бы обратился. Просто я не могу эту ошибку воспроизвести, чтоб собрать трассировку. Явно она бы понадобилась.
Userlevel 7
Badge +9
А можно не в ЛС, а всем, вдруг оно более красивое, чем у меня.
Нельзя, нужно обращаться в поддержку.
Ваше решение классное, мне нравится. 🙂Второе отправил в ЛС.
Userlevel 1
Заменил. Несколько дней понаблюдаю и сообщу.
К великому сожалению у меня сегодня с утра тоже опять обновился на "С" и опять при старте ПК вылезла эта ошибка, интересно, если опять грохнуть и поставить предыдущую версию, можно ли как то запретить ему обновляться? С учетом, что в Лаборатории данная проблема известна, я так понимаю, что всякие логи снимать бесполезно.
Userlevel 1
Нет, сегодня опять увидел ошибку. GSI чем-то поможет?
Userlevel 7
Badge +9
@Sandor ошибка точна такая же или уже другая формулировка? Можете сделать новый скриншот?
Приложите, посмотрим.
Userlevel 1
Точно такая. Впрочем, при очередном появлении сделаю скриншот.
Короче, я поступил проще, не забыть бы об этом когда он снова обновиться, а то будут два автозапуска. С учетом того, что он ругается на то, что ещё какой-то сервис не запустился, знать бы ещё какой ему нужен стал, а до этого он как-то перебивался, а он лезет вперед батьки в пекло 🙂 я убрал его из автозагрузки в HKCU, а в Планировщике заданий создал задачу точно такую же как в автозагрузке была, но с отсрочкой запуска при входе на 2 минуты и все стало нормально запускаться.
Из вышесказанного можно сделать вывод, что это проявится только у тех, у кого запускается при старте много всякого хлама, из-за этого я и не смог в начале воспроизвести это на виртуалке, т.к. там в автозагрузке кроме самого kpm ничего и не было.
Userlevel 7
Badge +11
Не периодически возникает ошибка на старте. Проявляется редко
Система Win7 x86 Home.. Версия KPM 9.0.2.972 (b) / 1563191215_6231 / 1.0.363.0-0.8.3.0_1
Hажатия ОК программу можно запустить, алее всё работает нормально
---
Kaspersky Password Manager «Сервис не отвечает». Код ошибки = eOpenSharedMemoryMutex


Привет @Sandor
добропожаловать!
Спасибо за размещение и изображение, очень полезно👏🏽!
KPM был установлен в течение длительного времени, и ошибка только началась, или KPM установлен новый?
Был ли установлен KPM с правами администратора?
Что еще работает, когда происходит ошибка, что-нибудь конкурирующее за ресурсы?
Вы удалили и переустановили KPM?
Userlevel 1
Выдайте права всем пользователем на запись/чтение/исполнение на папку
Вероятно не на папку, а на файл?

После обновления версии стал наблюдать ошибку значительно чаще, почти при каждом старте системы.
Userlevel 1
Установлен давно.
Видел эту ошибку пару раз и вот, наконец, собрался сообщить о ней.
Да, установлен с правами администратора.
Повторю: возникает при старте системы и самой программы.
Не удалял и не переустанавливал.
Userlevel 1
Шесть дней - полёт нормальный, ошибка не появилась ни разу. Спасибо и ждём патч.
Не нашел как редактировать пост.
Немного дополню предыдущий, в ручную править реестр нет смысла, при следующей загрузке kpm восстановит себя в автозагрузке, достаточно у него в настройках снять галку "загрузка при старте системы" и все станет нормально.
У меня ошибка начала появляться при старте каждый раз пару дней назад, установлен давно, win7*64, после первого появления ошибки и повторного запуска в ручную появилось окошко, что то типа спасибо за обновление, а теперь при старте машины каждый раз такая ошибка, далее в ручную запускается нормально.

Reply