Kaspersky Password Manager Add-on Incompatible With Firefox [MOVED] [Solved][Closed]

Userlevel 1
Today i've upgraded Mozilla Firefox Quantum from v67.0.2(64-bit) to v67.0.3(64-bit).
Also, i have installed Kaspersky Password Manager Add-on for Firefox v4.1.15, updated may 14, 2019.
But, i think that the latest version of Firefox and the Add-on are incompatible.
On some websites the "key" icon is GREY, while on other sites the "key" icon is just missing.
This never happened with Firefox v67.0.1 and 67.0.2, i never had any problems on those sites.
I posted 2 photos to see the issue.
Any help?
Thank you.

//Mod Note: moved to proper section.


Best answer by Flood and Flood's wife 21 June 2019, 18:36

View original

This topic has been closed for comments

10 replies

Userlevel 7
Badge +11
Hello Gjoksi,
Thanks for the screen prints, helps hugely to get a good understanding of the issues:

Re "On some websites the "key" icon is GREY"

Check KPM, Settings, Autosave & Autofill, if these are not selected, the key will be grey

If this does not fix Grey key please let us know?

  • 2nd issue, for that specific site, what happens when "Cookies must be enabled in your browser" is corrected?
  • Can you post back the url for this specific site

so we can replicate/check please?

Userlevel 1
Thanks for your answer!!!

Settings -> General -> Autosave and autofill -> Loggins and passwords ALREADY selected / checked
2nd try: Same setting first unselected, then selected, problem still persists, key is still grey

Cookies are already ENABLED for that site
The only difference from the last time is that now the key icons are shown in the fields.

In both cases, nothing happens when i click on the icons, not even showing "Filling out loggins and passwords is disabled in application settings".

No settings were changed in Firefox and KPM, this problem came ONLY with the newest Firefox v67.0.3(64-bit).
Userlevel 7
Badge +11
Hello Gjoksi,
Thanks for posting back and the additional info.
Using 67.0.3, Firefox Release, June 18, 2019,
going to https://moodle2.ugd.edu.mk/login/index.php,

I got: (same as you)

  • In Firefox, I added
& got

Thinking🤔, please standby, doing more tweaking..
Userlevel 7
Badge +11
Hello Gjoksi,
As I don't have & can't create a moodle2.ugd.edu.mk profile/pwd, are you able to add (as I have), then enter your usrname/pwd to test?
moodle2.ugd.edu.mk is going to be difficult (for me) to test further due to not being able to create a dummy account.

Any chance you'd have another example site please that 's not an "esteemed" institution, i.e. one that will allow me to setup a test account?
(16 hours ago) Going back to the first section of your post "On some websites the "key" icon is GREY", as soon as I read, I replicated the identical issue, all of my KPM, Settings -> General -> Autosave and autofill -> Logins and passwords, were unselected, I selected each one, KPM automatically synced, the keys changed from grey to green.
Drilling down on this further:
Are you using Firefox, with "Private Windows" always?
Using a Firefox standard browser, this is my result:

My feeling is, the issue is not a KPM malfunction, can you also check, if you create another Windows account, install Firefox, not synced, would you mind checking the "grey/green" key status please? Also check 3rd party trackers settings.
Perhaps, the (other) best way to check if the issue is coming from Firefox, is to "deselect" all about:preferences#privacy settings, exit Firefox, retest
I think FF 67, https://support.mozilla.org/en-US/kb/content-blocking, may be, if not causing both issues, contributing🤔
We'll be very interested to hear your feedback please?

Userlevel 7
Badge +11
Another reference that may interest you Gjoksi:

Best regards!
Userlevel 1
Dude, i've tried everything, i mean EVERYTHING!
But, the problem still exists.
Strange thing is: i have no problems with the same site: https://moodle2.ugd.edu.mk/login/index.php on Google Chrome v75.0.3770.100 (Official Build) (64-bit). The fields are automatically filled.
Here's a picture:

It seems that the problem is with FIREFOX, but NOT with CHROME.
Anyway, big thanks for your help! 🙂
Userlevel 7
Badge +11
Hi Gjoksi-DUDE😁
I TOTALLY agree, the problem started immediately the latest FIREFOX update was applied-June !8.
I haven't finished trying to nut this out.
I'll post back as soon as I have something, either for you to test, or findings.
If anything changes that you observe please keep us informed?
Userlevel 7
Badge +11
Hi Gjoksi-DUDE😁,
I created a Windows, normal user, no admin privileges account, installed a new Firefox account, normal user, no admin privileges, no master pwd, cleared: Block pop-up windows, Warn you when websites try to install add-ons, exited Firefox & restarted, the GREY Keys appeared, when the GREY key was clicked on a popup msg displayed: "You haven't added an account", I copied URL https://moodle2.ugd.edu.mk/login/index.php to KPM, add website, added "moodle" >>>>> GREEN keys "appeared" on the MOODLE site

I then reversed: Firefox: Block pop-up windows, Warn you when websites try to install add-ons. Exited Firefox, restarted Firefox, went back to Moodle: GREEN keys remained.

Hi 5, DUDE😉!

  • Try, removing the KPM Moodle entry, reset Firefox as per my steps, add Moodle to KPM, check Firefox-Moodle-key colour?
Let us know the outcome please?

Best regards!
Userlevel 1
Thanks for your help, BUDDY! 😃
Anyway, i've uninstalled Firefox and moved to Chrome!
Too much steps to solve the problem for just one site.
Still NO problems with Chrome.
Userlevel 7
Badge +11
Hi Gjoksi,
You're very welcome, as long as at least one browser is working the way you need & you're happy.
Best regards!