Kaspersky

Запрет обновлений kis 20 -> kis21

  • 8 September 2020
  • 53 replies
  • 8780 views

Userlevel 1
  • Bronze Theorist
  • 7 replies

Здравствуйте,

прошу знающих людей подсказать как запретить kis v.20 в автоматическом режиме скачивать и устанавливать версию 21. В данный момент, на мой взгляд, она очень сырая. В частности, не корректно работает веб-антивирус (проблему описывал в соседнем топике).

Ранее была настройка и выбор - скачивать новую версию или нет. Сейчас её убрали. Может быть есть другой способ?

Номер запроса в ТП (INC000011879193).


53 replies

Userlevel 3
Badge

Вот такой способ я получил от тех. поддержки, когда создавал пожелание вернуть опцию отключения автообновления:

Также авто-обновление можно отключить через реестр, изменив (добавив) следующий параметр:
Для x64:
HKEY_LOCAL_MACHINE\SOFTWARE\WOW6432Node\KasperskyLab\AVP20.0\environment
добавить DWORD параметр IsVersionUpdateEnabled со значением 0.
Для x86
HKEY_LOCAL_MACHINE\SOFTWARE\KasperskyLab\AVP20.0\environment
добавить DWORD параметр IsVersionUpdateEnabled со значением 0.

Сам не проверял.

Userlevel 1

Спасибо! 

Буду читать/изучать. Не хотелось бы после 10+ лет активного пользования продуктами LK дома и на работе искать им замену. Это сложно, но выполнимо, если нормального решения так и не будет найдено.

Обидно, что вот так Kaspersky сейчас тратит наше время.

Userlevel 7
Badge +8

Я помню как несколько лет назад многие возмущались, что у них не работает автообновление версий, насмотря на наличие соответствующей галочки в настройках.

На самом деле конечно автообновление нужно было включить по-умолчанию, но оставить возможность его отключать.

Userlevel 1

Да, я тоже это помню. Я больше читатель, чем писатель 🙂 Захожу сюда, читаю иногда новости/проблемы. Но это немного другое - когда функционал есть и не работает и когда путём принятия бестолковых поправок в лицензионном соглашении выпиливают реально нужные опции и лишают выбора, превращая хороший,гибкий, проверенный годами продукт в какое-то однокнопочное существо, которое нельзя настроить “под себя”, под свои запросы, под свою систему и т.д. Я считаю это плохо.

Userlevel 7
Badge +8

@kmscom, да, ТП мне это тоже подтвердила.

Userlevel 7
Badge +8

@pirippiri, нужно предварительно отключить самозащиту антивируса и выгрузить его.

Userlevel 2
Badge

Вообще, что-то странное происходит с запретом обновлений... У меня опция IsVersionUpdateEnabled со значением 0 присутствует и на моём старом компьютере и на новом ноутбуке, который я купил недавно. На обоих установлен KIS 2020.

Вчера для меня стало большим сюрпризом, когда на ноутбуке KIS 2020 сам по себе обновился до 21й версии, причём, установив, при этом, Kaspersky Password Manager, который я всегда исключаю из установки, т.к. не пользуюсь им.

Не знаю, что ещё будет с моим PC... т.к. мне там 21я версия точно не нужна...

Написал опять гневное письмо в службу ТП (INC000012033514)...  жду от них ответ...

Userlevel 7
Badge +8

@dimon_sk, если вы заметили, в этой ветки все параметры типа REG_SZ, так что возможно с DWORD они изначально напутали.

Добрый день,

да, параметр должен быть string (REG_SZ в реестре).

@andrew75 все верно говорит.

Передадим информацию коллегам.

Спасибо!

как отредактировать реестр. не получается добавить ключ. пишет не удаётся создать параметр ошибка при записи в реестр

Userlevel 7
Badge +8

удалил свой старый ключ, который покупал для KIS 2020 и активировал его новым ключом, купленным пару дней назад

Не должно быть никакой связи. Ключ не привязан к номеру версии.

Userlevel 7
Badge +8

@Al_New, известные ошибки 21-й версии были исправлены в новой редакции - 21.2.16.590.

Ее можно загрузить и установить вручную с официальных сайтов.

А проблемы с лицензией обычно быстро решаются через техподдержку.

Userlevel 2
Badge


 

В ...Data\ProductUpdate выставил как у @dimon_sk.

 

@Al_New, в ветке реестра ...Data\ProductUpdate выставлять ничего не нужно. Программа сама корректирует эти данные после добавления строкового параметра:

“IsVersionUpdateEnabled”=”0”

 

Таким образом, этого достаточно для отключения автоматического обновления версии программы.

 

В службе ТП, так же, сообщили, что данный параметр работает и для крайних версий KIS 2021 MR1/MR2, только его нужно вносить в соответствующие ветки AVP21.1 и AVP21.2, так же, нужно соблюдать разрядность ОС:

Windows Registry Editor Version 5.00

; x64
[HKEY_LOCAL_MACHINE\SOFTWARE\WOW6432Node\KasperskyLab\AVP21.1\environment]

; x86
; [HKEY_LOCAL_MACHINE\SOFTWARE\KasperskyLab\AVP21.1\environment]
"IsVersionUpdateEnabled"="0"

 

Windows Registry Editor Version 5.00

; x64
[HKEY_LOCAL_MACHINE\SOFTWARE\WOW6432Node\KasperskyLab\AVP21.2\environment]

; x86
; [HKEY_LOCAL_MACHINE\SOFTWARE\KasperskyLab\AVP21.2\environment]
"IsVersionUpdateEnabled"="0"

 

Userlevel 1

@Al_New , добрый день, да, необходимо создать вручную. 

Игорь, а если это нужно делать для 4 остальных членов семьи, удаленных географически(тк в 21 версии не работает лицензия)? - Вы это там считаете нормальным?

Userlevel 1

@Alx_kz , да нормальным. Если пользователь столкнулся с проблемой при активации лицензии, он должен обратится в ТехПоддержку. 

Только по ее рекомендации вносить изменения в реестр .

Как бы далеко географически не находился пользователь или группа пользователей от специалистов ТехПодержки, они им все подробно опишу, что нужно сделать

 

Я выражаю свое частное мнение.

Я столкнулся с кривостью ПО а не с проблемой лицензии,20 версия у меня работала прекрасно.. Объясняли ченить 80 летнему деду в онлайне, что делать в компьютере?

Userlevel 7
Badge +8

а если это нужно делать для 4 остальных членов семьи, удаленных географически(тк в 21 версии не работает лицензия)? - Вы это там считаете нормальным?

Нужно один раз решить проблему с лицензией и больше никаких действий ни от кого из членов семьи не потребуется.

Запрещать обновление из-за проблемы с лицензией это как мне кажется неверное решение.

Userlevel 1

С чем бы вы не столкнулись, а вы соглашались с тем , что никакое ПО не свободно от ошибок, ошибки активации решаются в ТехПоддержке.

Раз ПО как то было установлено дедом, то значит и выполнить инструкции специалистов в состоянии. Они могут дать инструментарий, снижающий необходимость вносить изменения вручную.

ПО было установлено мной и не должно без моего ведома самопроизвольно обновлятся.

Userlevel 1

Я установил всем грубо говоря, полгода назад 20 версию, 21 еще не было. Все было ок 4 месяца, потом  вдруг слетело, я подумал что баг, не найдя никаких настроек в ПО, пошел ножками всем поставил назад старую версию. Прошел месяц и тут опять… жесть короче…

 

Userlevel 7
Badge +8

@CruiseR, подробная инструкция:

1. Отключаете самозащиту антивируса - https://support.kaspersky.ru/14818

2.Выгружаете антивирус

3.Запускаете Файл kis20.reg и соглашаетесь на внесение изменений в реестр. 

4.Запускаете антивирус и включаете самозащиту.

Файл применим для всей ветки домашних продуктов 20-й версии.

Для 21-й версии нужно изменить AVP20.0 на версию антивируса.

Разрядность системы не играет роли, просто пропишется лишний ключик в реестре.

 

Кого не устраивают такие танцы с бубном - пишем запрос в техподдержку с пожеланием вернуть соответствующую настройку.

Чем больше будет запросов, тем больше вероятность, что ее вернут.

 

Userlevel 7
Badge +8

@Anton Mefodys, @Igor Kurzin, судя по последним сообщениям

https://community.kaspersky.com/kaspersky-internet-security-21/pochemu-segodnya-ya-udalil-kaspersky-internet-security-moved-14190?postid=66516#post66516

ТП по-прежнему пишет пользователям, что параметр должен быть DWORD

Userlevel 2

Жаль что техподдержка так долго давала пользователям некорректную инструкцию, надеюсь теперь это исправлено. :frowning2:
Я тоже считаю что функцию отключения автообновления зря убрали из интерфейса, у пользователя должно быть право выбора, тем более ситуации бывают разные, но хорошо хоть способ через реестр остается.
Обычно я устанавливаю новую версию раньше чем происходит автообновление, как правило сразу после подписания технического релиза, но сейчас у меня проблемы с компьютером, требуется ремонт (в том числе замена HDD), поэтому установка (тем более через автообновление) 21.3 вместо 21.2 сейчас для меня нежелательна, поэтому я сейчас применил твик к реестру для запрета автообновления антивируса на новую версию, вот уж отремонтирую комп, тогда и установлю новую версию антивируса, ведь все-равно потребуется переустановка ОС и всего софта после замены HDD.
Здорово что наконец-то с помощью этой темы разобрались и нашли ошибку в прежней инструкции от техподдержки.

Userlevel 2

@Tm74, штатных методов нет. Насчет не совсем штатных почитайте эту тему

Я тогда эксперименты забросил. Может у вас хватит терпения.

Написал в этой теме на форуме фан-клуба пост с указанием на ошибку в типе параметра в реестре, которая выяснилась в рамках этой темы здесь и с описанием корректного решения.

Userlevel 7
Badge +8

@Tm74, штатных методов нет. Насчет не совсем штатных почитайте эту тему

Я тогда эксперименты забросил. Может у вас хватит терпения.

Есть еще такой вариант.

Userlevel 7
Badge +8

@Gruffi, я сейчас запросил ТП, рабочий ли этот метод на сегодняшний день.

Если ответят, сообщу.

Userlevel 7
Badge +7

@andrew75  есть информация , что метод рабочий для 20 версии с патчем L
Вот пользователь создавал запрос в ТП http://forum.ru-board.com/topic.cgi?forum=5&topic=50407&start=1420#4

Reply