Kaspersky
Question

Windows slider bar disappears on certain websites unless KIS is paused


Since the start of this week, when I try and look at an online newspaper www.telegraph.co.uk then as soon as the home page has been ?built, the slider bar just vanishes and the screen expands to fill the space. This makes it impossible to navigate the page !. For a period of a second or so the slider bar is visible and can be grabbed with the mouse and the page contents moved up and down, but as soon as the slider bar vanishes the page is locked in its current position. Ctrl-F5 does not fix it.

Not every page on this online newspaper suffers from this fault, they have a section called Market Details which gives access to UK and world stockmarkets and all those pages show the slider bar correctly allowing me to view the entire page.

This odd behaviour vanishes if I pause Kaspersky Internet Security (20.0.14.1085(k)). PC is Windows 10 Pro 32 bit. Strange behaviour happens on Firefox (latest Vsn), Edge and Chrome.

No other online newspaper, or indeed any of the sites that I regularly look at have this problem, *only* the one shown above.


14 replies

Userlevel 7
Badge +5

Hello @AndrewD , open the site in question, click on “kaspersky protection” at the top right of the browser and then click on “ allow data collection on this website ...”

Regards

 

Sorry Bobby that isn’t appropriate. I don’t have a Kaspersky icon in that location, all I have is a Shield icon to the left of the Padlock. When I click on it I get a list of options in the new windows 10 format, one of which states, “Enhanced Tracking Protection is ON for this site”, and a horizontal slider to turn it off. When I turn it OFF the page refreshes, briefly showing the vertical page slider bar on the right, and then it vanishes  as before. 

Annoyingly I cannot show you a screen shot because as soon as I start using the Snipping Tool, the drop down box that appears when I click on the Shield icon vanishes :-(

Userlevel 7
Badge +9

Hello @AndrewD,

Thank you for updating us:ok_hand_tone3:

  • For images, open the browser, full screen & press the PrtScr key, then paste output directly to Paint, or 2nd method, press Windows logo key &  PrtScr key together, paste directly to Paint.
  • The Tracking prevention, you’re referring to, is related to Edge Chromium’s Privacy & services tools, not Kaspersky

     

     

     

  1. In all browsers, is the Kaspersky Protection extension installed ?→ check chrome://extensions/ - may we have an image of the extensions page please?

Please post back?

Thank you:pray_tone3:

Flood:whale:

This is how my Telegraph screen appears, notice the lack of slider bar and the same will occur using Edge or Chrome. 

The only Firefox extension for now is AdBlock Plus. I haven’t applied any extensions to the other two browsers.

 

 

Userlevel 7
Badge +9

Hello @AndrewD,

Thank you for the images:ok_hand_tone3:

We do understand the “slider bar missing” issue.

  1. What happens if AdBlock Plus is turned off - is the slider bar still missing on some telegraph.co.uk pages?
  2. What happens if Enhanced tracking protection is turned off - is the slider bar still missing on some telegraph.co.uk pages?
  3. May we have the names or links for telegraph.co.uk pages that do not show the slider bar so we can test please? 
  4. Please show us a full screen image of Edge Chromium Privacy & services tools ?(same as our 2nd image in our previous reply) 

Please post back?

Thank you:pray_tone3:

Flood:whale:

Hello

  1. Turning AdBlock Plus OFF makes no difference
  2.  On my computer the aberrant slider behaviour occurs on all pages except for the section accessible on the BUSINESS page headed “More Information on MARKETS HUB”  

Once I visit the Markets Hub, that screen and all subsidiary screens display correctly, with the slider allowing navigation.

As regards Chrome extensions, do you mean this from the actual Chrome browser (which I tend not to use) ?  :-

 

Userlevel 7
Badge +9

Hello @AndrewD,

You’re welcome!

  • Re (your) Chrome question, no, your advice in the topic has been the issue occurs in Firefox, Edge Chromium & Chrome. 
  1. For our understanding, the “slider bar missing” issue is resolved if/after going to Markets Hub, is that correct? 
  2. If “yes”, does that apply to Firefox & Edge Chromium  - equally? 
  3. If FireFox Private Mode browser is used, does the “slider bar missing” issue persist? 
  4. Because you’re not sharing URLs & or posting full screen browser images, it’s incredibly difficult to try to replicate where on the site the issue is:thinking:
  • May we have some URL links please - ONLY the pages that are not working please? 

Please post back?

Thank you:pray_tone3:

Flood:whale:

Hmm,  I have found out how to ‘fix’ it, but I don’t understand how it changed.

In this screen, I had “Block data collection” selected, but I’m sure that was the Kaspersky default. I have changed it to “only gather statistics” and voila,  the missing slider bars no longer 'disappear’ after 1 second or two. 

I am going to install the Kaspersky extension for Firefox, but I notice there is a warning that I should only install it if I trust it.

Thanks for your help.

 

 

Userlevel 7
Badge +9

Hello @AndrewD,

You’re welcome!

  • It’s better to install Kaspersky Protection extension in all supported browsers: Firefox, Edge Chromium, Chrome & IE & manage Private Browsing - specific to each site, as @bobbycooper showed in his reply above - that way, it’s not necessary to use the Only gather statistics option.

Regarding the This is not monitored for security through Mozilla's Recommended Extensions program. Make sure you trust it before installing, message that shows for the Kaspersky Protection extension in Firefox: 

There’s an element of choice involved, Mozilla, like Google and MS, have available thousands of extensions… 

The “warning” from Mozilla is “generic”, Mozilla Add-ons Product Manager (Jorge Villalobos) explains it best:

quote:

The “This extension isn’t monitored by Mozilla” notification is currently part of a test, so not all users are seeing it. It’s not a permanent part of AMO yet. We want to gauge the reaction users have to it and decide if it should be kept, modified, or dropped.

Having said that, the message is accurate. Most extensions on the site aren’t being regularly code-reviewed, so we can’t guarantee their safety. We believe this is something users should understand. That a developer has been contributing for X years, has positive reviews, or has provided ID to us is not enough to assess safety (though it helps). We’ve had incidents in the past with long-standing add-ons and “reputable” developers. Additionally, having the ability to ban after the fact doesn’t help users who have already been impacted by a bad add-on.

We’re trying to draw a line between add-ons that are being closely monitored and those that aren’t. At the moment that’s limited to a small set of Recommended extensions, but that can change in the future depending on the success of the program.”

unquote

Thank you:pray_tone3:

Flood:whale:

Hello @AndrewD,

You’re welcome!

  • Re (your) Chrome question, no, your advice in the topic has been the issue occurs in Firefox, Edge Chromium & Chrome. 
  1. For our understanding, the “slider bar missing” issue is resolved if/after going to Markets Hub, is that correct? 
  2. If “yes”, does that apply to Firefox & Edge Chromium  - equally? 
  3. If FireFox Private Mode browser is used, does the “slider bar missing” issue persist? 
  4. Because you’re not sharing URLs & or posting full screen browser images, it’s incredibly difficult to try to replicate where on the site the issue is:thinking:
  • May we have some URL links please - ONLY the pages that are not working please? 

Please post back?

Thank you:pray_tone3:

Flood:whale:

Answers:

Q1, Correct . The Markets Hub screen is fine.

Q2, Yes the behaviour was the same in all three browsers

Q3, The problem is still there in Private Browsing Mode

Q4, Sorry, it is/was www.telegraph.co.uk , a UK newspaper website and the problem occurred on the home page and all other pages of that site, except for the Markets Hub selected from the ‘Business’ page.

As I have pointed out in the previous post, I tried changing the Kaspersky screen Privacy Protection, and changed “Block Data Collection” to “Only Gather Statistics” and lo and behold the odd behaviour (slider bar appearing then vanishing) seems to have been cured. I’m sure I haven’t made any changes there, I tend to let Kaspersky apply its default settings.

 

 

Userlevel 7
Badge +9

Hello @AndrewD,

Thank you for the information:ok_hand_tone3:

Please see my previous reply.

Thank you:pray_tone3:

Flood:whale:

Userlevel 3
Badge

been following this and the better solution for me would be to leave block data collection active but add https://www.telegraph.co.uk/ to private browsing exclusions. That site now works correctly.

 

Petsy,

Thanks for that suggestion. I’ll try it.

Andrew

 

 

Hello!

Is the issue still actual? 

I’m unable to reproduce the issue.

 

If the issue is still actual:

  1. clear cache in browser.
  2. restore product settings (settings - general - manage settings)
  3. check the issue
  4. enable Private Browsing blocking tracking option.
  5. restart browser and retest the issue.

If the issue still reproduce:

enable tracing in product - restart browser - reproduce the issue - disable tracing.

Send these traces to Tech support in an archive: Create a request to Tech Support

Reply