Kaspersky
Solved

URL advisor is enabled in my KIS 2020 but there is no extension called url advisor in my firefox.

  • 13 November 2019
  • 33 replies
  • 5492 views

URL advisor is enabled in my KIS 2020 but there is no extension called url advisor in my firefox.

I have selected “check all url’s”

But I don’t see a green icon beside the links on the pages

Is there something wrong?

icon

Best answer by FLOOD 13 November 2019, 19:43

Hello  @display10,

Excellent, thank you:pray_tone3:

Please configure:

  • (1) Url Advisor - refer image
  •  (2) Web Anti-Virus: Check the URL against the database of URLs containing legitimate applications that can be used by criminals to damage your computer or personal data. 
  • (3) Open a Firefox browser, using search engine of your choice, search for Kaspersky Community, please take an image of the results screen, (without selecting a link to open the Kaspersky Community site) please? 

     

Please post back?

Thank you

View original

This topic has been closed for comments / Тема закрыта для комментариев

33 replies

Userlevel 7
Badge +6

Hello @display10,

Welcome!

  1. Has KIS recently updated?
  2. Has the Kaspersky Protection Addon ever worked? 
  3. What Firefox browser name & version is installed please?
  4. In Firefox type:     about:addons  - what shows please?

 

Please let us know?

Thank you

 

Userlevel 7
Badge +5

Also, You may install FF KP add-on manually from:

 

C:\Program Files (x86)\Kaspersky Lab\Kaspersky Internet Security 20.0\FFExt\light_plugin_firefox\addon.xpi

Dear FLOOD,

Recently Kaspersky is updated from patch d to patch e so I have the last version.

The “secure keybord input” works in firefox so I suppose the kaspersky protection addon works.Or is this not a prove?

My mozilla firefox has version 70.0.1

I have attached the about:addons page.

 

harlan4096,

I suppose the FF KP addon is the Kaspersky protection addon.

This was installed at the moment of installation of kaspersky 2 months ago.

I think the manual installation now has no sense.

Userlevel 7
Badge +6

Hello @display10,

Thank you for replying and the image:clap_tone3:

Yes, you have the Kaspersky Protection addon installed:ok_hand_tone3:

“secure keybord input” working is good:white_check_mark:, however,  a heads up, according to Kaspersky Lab Technical Support, Sent: Tuesday, 15 October 2019 15:44

the “secure keybord input” feature requires script injection by Kaspersky, we have received news that Mozilla will be applying a restriction in Firefox, resulting in the loss of the virtual keyboard icon.”

The Lab have not provided an ETA for this change. 

(A) Referring to your image, please select the 3 horizontal dots, that will show you the Kaspersky Protection addon version and will show if Kaspersky Protection addon has “permission” to run in Private browser?

 

(B) Also, please select/open the small (Kaspersky) green shield, in the top of the FireFox browser - highlighted red, please post an image for me?

(C) Please show an image of KIS AntiBanner settings?

(D) Please show an image of KIS Web AntiVirus settings?

(E) May I have an image please, of a “search for Kaspersky Community”, refer my image:

 

Please post back?

Thank you:pray_tone3:

Hi FLOOD,

 

I’ attached the image when I open the K icon in the upper right corner of the FF browser but this icon is greyed out.

 

When i select the 3 dots at about:addons I see the vesion of KP addon 30.0.3.762?27d

But Kaspersky has no permission to run in private browsing.

Userlevel 7
Badge +6

Hello @display10,

Thank you for replying and the image.

  • Kaspersky Protection addon version should be: 30.0.3762.27d-20190319165301
  • What shows when you select the 3 horizontal dots?

 

  •  does the extended detail show: 

 

  • May I have an image of Anti Banner settings please:

 

  • & may I have an image of Advanced settings of Web Anti-Virus:

 

 

Please post back?

Thank you:pray_tone3:

 

Hi FLOOD,

Firefox will have the same problem as chrome has now already namely “no script injection allowed” like you describe.

I have indeed the version of KP like you specify, you can check it in the image I attach.

I’ve attached the image of the anti banner settings.

And I’ve also attached the image of the web antivirus settings

 

Userlevel 7
Badge +6

Hello  @display10,

Excellent, thank you:pray_tone3:

Please configure:

  • (1) Url Advisor - refer image
  •  (2) Web Anti-Virus: Check the URL against the database of URLs containing legitimate applications that can be used by criminals to damage your computer or personal data. 
  • (3) Open a Firefox browser, using search engine of your choice, search for Kaspersky Community, please take an image of the results screen, (without selecting a link to open the Kaspersky Community site) please? 

     

Please post back?

Thank you

Userlevel 7
Badge +4

@display10

Also , i tried the same configuration like yours :

Did  you try to clean reinstall KIS 2020

@Flood,

I’ve done the settings you asked and I’ve attached the search engine page.

Userlevel 7
Badge +6

Hello  @display10,

Thank you for posting again.

Unfortunately, the image hasn’t uploaded, would you be kind and add again please?:pray_tone3:

 

sorry I forgot to upload the image.

Userlevel 7
Badge +6

Hello @display10,

Thank you so much:pray_tone3:

 :cartwheel_tone3:

So, going back to the very beginning:

(a) “URL advisor is enabled in my KIS 2020 but there is no extension called url advisor in my firefox”

(b) “I have selected “check all url’s”, but I don’t see a green icon beside the links on the pages”,

:one:  Are both (a) & (b) now resolved? 

:two:  When Kaspersky Protection addon is now opened (see my image) what is now shown? Please post image? 

 

:three:  Firefox - do you use a Master Password? 

:four:  (in) Firefox, enter  about:preferences#privacy    - please post a full image of Browser Privacy settings please?

:five:  KIS, Network Settings, scroll to the bottom of the window, may I have an image of Mozilla Firefox & Thunderbird please?

Please post back?

Thank you

 

Hi,

I see no addon called “url adviser” but I see green icons near the links so it’s resolved thanks

Userlevel 7
Badge +6

Hello  @display10,

I’m very happy it’s resolved:cartwheel_tone3:

Thank you for confirming:pray_tone3: .

KIS URL Advisor is managed via KIS application, Private Browsing addon & Anti-Banner addon, are facilated by enabling the extension/addon (in browsers) & can be managed both in the browser(s) and the application.

Best regards.

Userlevel 1

Hi dear FLOOD, I recently created a topic about this issue, but now decided to post here. 

I have KIS 2020 last version:

But the Kaspersky extention I downloaded from Chrome store, is not the new version. 

Where to download the last version which as you said is:

“: 30.0.3762.27d-20190319165301”

Thank you.

Userlevel 1

Also when I click on the Kaspersky icon, it shows like this

 

I use the new edge chromium. 

Version 79.0.309.71 (Official build) (64-bit)

Userlevel 7
Badge +4

@AHS0 Please go to this link

Userlevel 1

Thanks for the correct link, I did everything but it didn't work. The icon is gray. 

Userlevel 1

Maybe its something has to do with Edge Chromium?

Userlevel 1

Can you please install Edge Chromium and inform if it doesn't work?

https://mspoweruser.com/need-offline-installer-for-chromium-based-edge-heres-how-you-can-get-it/

 

Thank you so much.

 

Userlevel 1

With Firefox, it works fine and I see the K icon.

Userlevel 7
Badge +4

@AHS0 Please see this Topic

Userlevel 1

Ok, thanks.

ok, thank you. Safe Money must be enabled? 

I have it turned off, but it works on Firefox. 

Also, should I enable this?