Kaspersky
Question

Unable to open port for javascript development

  • 31 December 2020
  • 2 replies
  • 43 views

I’ve been trying  unsuccessfully for hours to open up a port on my machine so that other computers on my local network can access my app, which I am hosting on port 4111 (I’ve also tried hosting on 8080, but still won’t work).   

Observations:

  • localhost:4111 works just fine, so I know the app is up and listening.
  • Other computers can ping my dev machine and they can access the default port 80 web site on my dev machine, so I know it is not a connectivity issue.

My app:

  • Typescript app running with webpack-dev-server

What I’ve tried:

  • Enable port instructions.  (using additional->network settings)
  • Setting packet rules.   My rule is at the top of the list.  Here’s my rule:  

    (I’ve tried setting ports to just 8080 or 4111, still doesn’t work)


2 replies

Userlevel 7
Badge +7

Hello @nebosite, Welcome.

Your screenshot leads to the assumption that you are not using KIS21 MR2 (21.2.16.590).
Which version is it exactly?

Can you please leave the 'Remote Ports' field empty and test the rule with it?

I figured it out.   The webpack-dev-server --host argument was set to localhost, which is fine for local debugging, but to have it work from a remote machine the --host argument must be the machine name, or the ip address of the machine. 

Reply