Kaspersky
Solved

Unable to do development gulp serve, ERR_CONNECTION_RESET. with latest version of KIS 21.1.15.500 [Fixed in 2021MR2]

  • 13 October 2020
  • 37 replies
  • 423 views

Userlevel 2

I am trying to develop applications using react.js. However when I run gulp serve command, the web browser opens and I get an error ERR_CONNECTION_RESET.

After spending several days trying different solutions, uninstalling and reinstalling,etc, I found that if I right click on KIS and choose exit and then if I run gulp serve, my application works without any issues.

I am able to reproduce this again and again. As soon as I enable  KIS and run gulp serve, the application fails. If I exit KIS completely and run gulp serve, my application works.

I am not facing this issue on systems which don’t have KIS and which have older version of KIS. Only after I updated to latest version of  KIS 21.1.15.500, I am facing this issue.

 

Please help asap

 

icon

Best answer by Anton Mefodys 15 October 2020, 08:17

Another workaround is:

- Open Settings - Additional - Threats and exclusions - Specify trusted applications - Add
- In the opened window click on the search icon (magnifier) and type web browser name (Chrome for example)
- Choose browser executable from the list, double click on it and choose Do not scan all traffic, Only for specific IP type "::1"
- Close settings, restart pc and check.

 

The issue should be fixed in MR2 version.

View original

37 replies

Userlevel 7
Badge +9

Hello @San2020

  1. Which patch(x) is KIS up to?  x = letter
  2. As a test only, what happens if Inject script into web traffic to interact with web pages is unchecked? 
  3. Run a  GSI & Windows Logs & post back please? 

Thank you:pray_tone3:

Flood:whale: &:whale2:

Userlevel 2

Thank you very much for the reply.

Yes, KIS and gulp serve has worked in the previous version of KIS without any issues.

I don’t see any patch number . Under application version it shows as 21.1.15.500

I unchecked Inject script into web traffic to interact with web pages, but I am still facing the same issue.

Only if I right click and exit KIS, the application works

I will share the logs shortly

 

Userlevel 2

I’ve attached logs. Please help as this would be an issue faced by many developers updating to latest KIS and doing web development

Userlevel 7
Badge +9

Hello @San2020

You’re most welcome:relaxed: !

Thank you for replying:ok_hand_tone3:

On the Windows Taskbar, rightclick the KIS icon, select About, the popup window will show the patch(x), or hover the mouse:rat: over the KIS icon, the tiny floating popup will show the patch(x) or, open the KIS GUI, select the headset:headphones: , opens Support window, the patch(x) information is on the 4th line from the top. 

Thank you:pray_tone3:

Flood:whale: &:whale2:

Userlevel 2

I have tried all the methods. But I see no patch number. To be frank, I had updated once again today to the latest version of KIS just to see if it would solve my problem. A few hours ago ,before I did the update, it was on patch ‘C” for 21.1.15.500. But now after I once again updated, I don’t see any patch info. Screenshot below. 

 

 

Userlevel 2

I am able to fix the issue but I don't know if this is the right approach.

  1. I went to Settings->Additional->Network
  2. I selected Monitor selected ports only 
  3. The I clicked on "Select" next to it and unchecked "Monitor all network ports for applications that are vulnerable to network attacks"

After this I closed the browser and ran gulp serve and it was working.

However I am not sure if this is the right approach and if this would make KIS vulnerable or if there is a better approach.

 

Please advise

Userlevel 7
Badge +3

@San2020,

Restore KIS settings and then try to disable IPv6.

Reboot and retest the issue.

Please tell about the reusts.

Userlevel 2

But Microsoft advises to not disable IPv6 as it would disable some windows components

Userlevel 7
Badge +9

@San2020

  1. Do you use IPv6 ?
  2. Also, KIS 21 is up to Patch C, which should be what is applied. 

Thank you:pray_tone3:

Flood:whale: &:whale2:

Userlevel 2

Thanks for the reply

 

  1. I restored the settings, disabled IPv6 and restarted and the issue still exists
  2. I updated it to patch C
Userlevel 7
Badge +9

Hello @San2020

You’re most welcome:slight_smile: !

Thank you for updating us:ok_hand_tone4:

  • Unless @Anton Mefodys says otherwise, raise a request with Kaspersky Technical Support, fill in the KIS21, Application malfunction, Other template → see following image, include a new GSI & Windows Logs, images & provide a detailed history with as much detail as possible, so Technical experts understand, also, in the request, include a link/URL to this Community topic; Support will probably request Traces, they will give you the steps required to collect the data

 

  • After submitting the case, you’ll receive an automated email with an INC+12digits reference number, then, normally, within 5 business days, a Kaspersky Technical Support human will communicate with you, also by email, you may continue to engage with the Kaspersky Technical Team via email or by updating the INC in your MyKaspersky account.
  • Please post the incident # here in your topic? 
  • Please share the outcome with the Community when it’s available?

Thank you:pray_tone3:

Flood:whale:+:whale2:

Hi, If service tells you how to solve the problem let us know please.

I have encountered the same problem. Thanks

Userlevel 2

 

Hi Paolo, I will reply back on this thread once I get a resolution. This is an issue which would affect all web developers I believe.

 

I have raised the request. Incident number is INC000011983725

I will inform the outcome of the same in this same thread

Userlevel 7
Badge +4

Hello,

Do you set network settings to the following mode?Let us know the result.

Regards.

Userlevel 2

Hi Zhang,

 

I tried your suggestion now. It still gave the same ERR_CONNECTION_RESET error

Userlevel 7
Badge +4

Hi Zhang,

 

I tried your suggestion now. It still gave the same ERR_CONNECTION_RESET error


Hello,

Which browser do you use?Chrome or Firefox?Please turn off web-antivirus model to check this behavior has gone or not and tell the test result.

Regards.

Userlevel 2

I use chrome. I tested in all browsers, same issue. I disabled the web antivirus but same error.

Only the resolution which I mentioned earlier in this post works

Userlevel 7
Badge +4

I use chrome. I tested in all browsers, same issue. I disabled the web antivirus but same error.

Only the resolution which I mentioned earlier in this post works


Hello,

I try to install node.js and gulp with “npm install gulp -g”, but installation process encounter several  dependency issues.

npm WARN deprecated chokidar@2.1.8: Chokidar 2 will break on node v14+. Upgrade to chokidar 3 with 15x less dependencies.
npm WARN deprecated urix@0.1.0: Please see https://github.com/lydell/urix#deprecated
npm WARN deprecated resolve-url@0.2.1: https://github.com/lydell/resolve-url#deprecated
npm WARN optional Skipping failed optional dependency /chokidar/fsevents:
npm WARN notsup Not compatible with your operating system or architecture: fsevents@1.2.13

It means I need upgrade chokidar from 2 to 3 version. I use this command to install chokidar 3: npm install chokidar. But the same depandency issue existed when I reinstall gulp… Do you know how to solve this issue? I want to test your problem by myself. Thanks.

Regards.

Userlevel 2

Hi Zhang,

Thanks for trying it out. I am following instructions from here for my development:

https://docs.microsoft.com/en-us/sharepoint/dev/spfx/set-up-your-development-environment

 

When you follow all the instructions in that and at the end run gulp serve, you can check.

This is my environment setup which you get when you run npm list -g --depth 0

+-- @microsoft/generator-sharepoint@1.11.0
+-- gulp@3.9.1
`-- yo@3.1.1

 

Is use node v10.17.0

My npm is 6.11.3

 

 

Userlevel 7
Badge +4

Hi Zhang,

Thanks for trying it out. I am following instructions from here for my development:

https://docs.microsoft.com/en-us/sharepoint/dev/spfx/set-up-your-development-environment

 

When you follow all the instructions in that and at the end run gulp serve, you can check.

This is my environment setup which you get when you run npm list -g --depth 0

+-- @microsoft/generator-sharepoint@1.11.0
+-- gulp@3.9.1
`-- yo@3.1.1

 

Is use node v10.17.0

My npm is 6.11.3

 

 


Hi, San2020

I will follow this instructions. I install node 12.19.0 LTS. Any issue will reply back here.

Maybe I should install v10 instead.

Regards.

Userlevel 7
Badge +4

Hello,

Here is the installation process of gulp from me. Node10 is the best way to install it. I set C:\my-project as my project folder. 

PS C:\Windows\system32> node --version
v10.9.0
PS C:\Windows\system32> npm --version
6.2.0
PS C:\Windows\system32> npx --version
6.2.0
PS C:\Windows\system32> npm install --global gulp-cli
npm WARN deprecated urix@0.1.0: Please see https://github.com/lydell/urix#deprecated
npm WARN deprecated resolve-url@0.2.1: https://github.com/lydell/resolve-url#deprecated
C:\Users\Wesly.Zhang\AppData\Roaming\npm\gulp -> C:\Users\Wesly.Zhang\AppData\Roaming\npm\node_modules\gulp-cli\bin\gulp.js
+ gulp-cli@2.3.0
added 255 packages from 166 contributors in 16.981s
PS C:\Windows\system32> cd c:\
PS C:\> npx mkdirp my-project
npx: installed 1 in 2.131s
PS C:\> cd .\my-project\
PS C:\my-project> npm init
This utility will walk you through creating a package.json file.
It only covers the most common items, and tries to guess sensible defaults.

See `npm help json` for definitive documentation on these fields
and exactly what they do.

Use `npm install <pkg>` afterwards to install a package and
save it as a dependency in the package.json file.

Press ^C at any time to quit.
package name: (my-project) test avp
Sorry, name can only contain URL-friendly characters.
package name: (my-project) testavp
version: (1.0.0)
description:
entry point: (index.js)
test command:
git repository:
keywords:
author:
license: (ISC)
About to write to C:\my-project\package.json:

{
"name": "testavp",
"version": "1.0.0",
"description": "",
"main": "index.js",
"scripts": {
"test": "echo \"Error: no test specified\" && exit 1"
},
"author": "",
"license": "ISC"
}


Is this OK? (yes)
PS C:\my-project> npm install --save-dev gulp
npm WARN deprecated chokidar@2.1.8: Chokidar 2 will break on node v14+. Upgrade to chokidar 3 with 15x less dependencies.
npm WARN deprecated resolve-url@0.2.1: https://github.com/lydell/resolve-url#deprecated
npm WARN deprecated urix@0.1.0: Please see https://github.com/lydell/urix#deprecated
npm WARN deprecated fsevents@1.2.13: fsevents 1 will break on node v14+ and could be using insecure binaries. Upgrade to fsevents 2.
npm notice created a lockfile as package-lock.json. You should commit this file.
npm WARN testavp@1.0.0 No description
npm WARN testavp@1.0.0 No repository field.
npm WARN optional SKIPPING OPTIONAL DEPENDENCY: fsevents@1.2.13 (node_modules\fsevents):
npm WARN notsup SKIPPING OPTIONAL DEPENDENCY: Unsupported platform for fsevents@1.2.13: wanted {"os":"darwin","arch":"any"} (current: {"os":"win32","arch":"x64"})

+ gulp@4.0.2
added 331 packages from 221 contributors in 14.324s
PS C:\my-project> gulp --version
CLI version: 2.3.0
Local version: 4.0.2
PS C:\my-project> gulp
[10:30:09] Using gulpfile C:\my-project\gulpfile.js
[10:30:09] Starting 'default'...
[10:30:09] Finished 'default' after 3.52 ms
PS C:\my-project> npm i gulp --save
npm WARN deprecated chokidar@2.1.8: Chokidar 2 will break on node v14+. Upgrade to chokidar 3 with 15x less dependencies.
npm WARN deprecated resolve-url@0.2.1: https://github.com/lydell/resolve-url#deprecated
npm WARN deprecated urix@0.1.0: Please see https://github.com/lydell/urix#deprecated
npm WARN deprecated fsevents@1.2.13: fsevents 1 will break on node v14+ and could be using insecure binaries. Upgrade to fsevents 2.
npm WARN testavp@1.0.0 No description
npm WARN testavp@1.0.0 No repository field.
npm WARN optional SKIPPING OPTIONAL DEPENDENCY: fsevents@1.2.13 (node_modules\fsevents):
npm WARN notsup SKIPPING OPTIONAL DEPENDENCY: Unsupported platform for fsevents@1.2.13: wanted {"os":"darwin","arch":"any"} (current: {"os":"win32","arch":"x64"})

+ gulp@4.0.2
updated 1 package in 11.753s
PS C:\my-project> npm i gulp-connect --save
npm WARN testavp@1.0.0 No description
npm WARN testavp@1.0.0 No repository field.
npm WARN optional SKIPPING OPTIONAL DEPENDENCY: fsevents@1.2.13 (node_modules\fsevents):
npm WARN notsup SKIPPING OPTIONAL DEPENDENCY: Unsupported platform for fsevents@1.2.13: wanted {"os":"darwin","arch":"any"} (current: {"os":"win32","arch":"x64"})

+ gulp-connect@5.7.0
added 56 packages from 46 contributors in 7.441s
PS C:\my-project> gulp -v
CLI version: 2.3.0
Local version: 4.0.2
PS C:\my-project> gulp
[10:43:57] Using gulpfile C:\my-project\gulpfile.js
[10:43:57] Starting 'default'...
[10:43:57] Starting 'server'...
[10:43:57] Starting server...
[10:43:57] Server started http://localhost:8090
[10:43:57] LiveReload started on port 35729
[10:43:57] Running server

And create file gulpfile.js and index.html to this folder. The content of gulpfile.js is the following code.

'use strict'

const gulp = require('gulp')
const connect = require('gulp-connect')

// OPEN_LOCAL_WEB_SERVER
gulp.task('server',function(){
connect.server({
// SET_ROOT_FOLDER
root:'./',
port:8090,
// ENABLE_LIVEER_LOAD
livereload:true
})
});

// ADD_DEFAULT_TASK
gulp.task('default',gulp.series('server'));

AND index.html content is like this.

<h1>Hello, the world! </h1>

Please tell me do I miss somethings to reproduce your issue? Thanks!

Regards.

Userlevel 2

Hi Zhang,

I am following all the instructions from the url which I mentioned earlier for my development: https://docs.microsoft.com/en-us/sharepoint/dev/spfx/set-up-your-development-environment

Go to command prompt and create a new folder. Go to that folder and run "npm install gulp yo @microsoft/generator-sharepoint --global"
After that run "yo @microsoft/sharepoint" and answer the command prompts are below

? What is your solution name? foo
? Which baseline packages do you want to target for your component(s)? SharePoint Online only (latest)
? Where do you want to place the files? Use the current folder
Found npm version 6.11.3
? Do you want to allow the tenant admin the choice of being able to deploy the solution to all sites immediately without
 running any feature deployment or adding apps in sites?
No
? Will the components in the solution require permissions to access web APIs that are unique and not shared with other c
omponents in the tenant?
No
? Which type of client-side component to create? WebPart
Add new Web part to solution foo.
? What is your Web part name? HelloWorld
? What is your Web part description? HelloWorld description
? Which framework would you like to use? React

This will take sometime to finish downloading all the components depending on the speed of your network.
Once that is finished, pls run "gulp serve"

 

 

Userlevel 7
Badge +4

Hi Zhang,

I am following all the instructions from the url which I mentioned earlier for my development: https://docs.microsoft.com/en-us/sharepoint/dev/spfx/set-up-your-development-environment

Go to command prompt and create a new folder. Go to that folder and run "npm install gulp yo @microsoft/generator-sharepoint --global"
After that run "yo @microsoft/sharepoint" and answer the command prompts are below

? What is your solution name? foo
? Which baseline packages do you want to target for your component(s)? SharePoint Online only (latest)
? Where do you want to place the files? Use the current folder
Found npm version 6.11.3
? Do you want to allow the tenant admin the choice of being able to deploy the solution to all sites immediately without
 running any feature deployment or adding apps in sites?
No
? Will the components in the solution require permissions to access web APIs that are unique and not shared with other c
omponents in the tenant?
No
? Which type of client-side component to create? WebPart
Add new Web part to solution foo.
? What is your Web part name? HelloWorld
? What is your Web part description? HelloWorld description
? Which framework would you like to use? React

This will take sometime to finish downloading all the components depending on the speed of your network.
Once that is finished, pls run "gulp serve"

 

 


Hello,

OK, I know this issue now, you access your website using https. Do you have a kaspersky certificates installed in OS?Run “certmgr.msc” to access it.

Regards.

Userlevel 7
Badge +9

Hello @San2020

Also, If “Scan secure traffic in Mozilla applications” is unchecked, does the certificate issue persist? 

Please let us know?

Thank you:pray_tone3:

Flood:whale: &:whale2:

Userlevel 7
Badge +3

Another workaround is:

- Open Settings - Additional - Threats and exclusions - Specify trusted applications - Add
- In the opened window click on the search icon (magnifier) and type web browser name (Chrome for example)
- Choose browser executable from the list, double click on it and choose Do not scan all traffic, Only for specific IP type "::1"
- Close settings, restart pc and check.

 

The issue should be fixed in MR2 version.

Reply / Ответить