Kaspersky

Steam Workshop downloads no longer working [Closed]

  • 13 May 2019
  • 5 replies
  • 969 views

KIS 2019 patch e windows 10 64 bit. KIS is working fine. Steam is working fine except for the workshop no longer downloading mods from the workshop. This worked in the past. Steam support claims no problem on their end. Has anyone ever had a setting in KIS stop Steam Workshop downloads? Again the non workshop part of steam works fine and KIS is working fine.

17blue17 2 years ago

Update: Did more searching on the web. If anyone else has problems with steam workshop then tell them to do the following:

1) Right click on the game in steam library > click on properties > updates tab > enable steam cloud sync

2) I also enabled background downloads to always, i m not sure if this is a must.

You would think Steam support would know their own settings but instead they automatically tried to blame things on my network or firewall settings which is why I opened this tread.

Thank you

This tread can be marked closed.😀
View original

This topic has been closed for comments

5 replies

Userlevel 7
Badge +10
Hello 17blue17,
Welcome!
This may help:
https://www.kaspersky.com/blog/kis-settings-for-steam/13970/
If not please post back?
Thanks!
Thanks for the reply. I already saw that and everything is set to trusted and not to monitor network activity. Steam itself works fine. It is just the workshop downloads that do not work. Game downloads work fine. So again anyone have any ideas what might block workshop downloads? I have tried multiple steam servers with no difference. My router has the same settings and firmware as in the past when workshop downloads worked. Did KIS 2019 patch e break anything? Thanks
Update: Did more searching on the web. If anyone else has problems with steam workshop then tell them to do the following:

1) Right click on the game in steam library > click on properties > updates tab > enable steam cloud sync

2) I also enabled background downloads to always, i m not sure if this is a must.

You would think Steam support would know their own settings but instead they automatically tried to blame things on my network or firewall settings which is why I opened this tread.

Thank you

This tread can be marked closed.😀
Hmmm, 😐 it so strange that you have such problem. I work in this sphere for 3 years and heat about such error for the first time, really(
I also had similar problems and somehow it magically fixed itself. Maybe Update or some settings changed. Not sure but Fingers Crossed for you.