Kaspersky
Solved

Rocketmail Microsoft 365 and KIS, Blocked, Reason: Invalid name of certificate.

  • 23 February 2021
  • 17 replies
  • 176 views

Userlevel 3
Badge

For the last 25 years I've used Rocketmail (now part of Yahoo) via webmail and Windows 10 Mail without a problem.
Today, I've installed Microsoft 365 as a member of a family group.
While looking at Excel (NOT Outlook) a window appeared and KIS 21.2.16.590(b) Web Anti-Virus reports:-

Event :    SSL connection with invalid certificate detected
User type :    Not defined
Application name :    EXCEL.EXE
Application path :    C:\Program Files\Microsoft Office\root\Office16
Component :    Web Anti-Virus
Result description :    Blocked
Object name :    autodiscover.rocketmail.com
Reason :    Invalid name of certificate. Either the name is not on the allowed list, or was explicitly excluded.


Advice welcome!

 

icon

Best answer by Wesly.Zhang 23 February 2021, 14:17

Hello,

I think autodiscover.rocketmail.com is on repairing their website now……

Regards.

View original

17 replies

Userlevel 7
Badge +9

Hello @wgcuser

Welcome back!

  1. Post a full screen image of the error & select Details & post images of any following screens? 
  2. Did the certificate error show in KIS Reports but not when  you were accessing  Rocketmail ? 

Thank you:pray_tone3:

Flood:whale: +:whale2:

Userlevel 3
Badge

Sorry no screen image.

The Kaspersky error message appeared while I was looking at the opening screen to MS 365 Excel.

I have not made MS 365 Outlook the client for any email service.

At present Rocketmail is accessed either by Windows 10 Mail (that’s the client that come fee with Win 10 or Webmail.

BR

Userlevel 7
Badge +9

Hello @wgcuser

Thank you for posting back. 

  1. What does “Sorry no screen image” mean? 
  2. Is the certificate issue replicable?

Thank you:pray_tone3:

Flood:whale: +:whale2:

Userlevel 7
Badge +4

Hello,

I think autodiscover.rocketmail.com is on repairing their website now……

Regards.

Userlevel 3
Badge

@Flood and Flood's wife 

@Wesly.Zhang 

Thanks for your posts. On reflection, perhaps what I encountered was MS 365 trying to be helpful having assumed that my Microsoft Account Login was a regular email address frequently used and tried to setup MS 365 Outlook to access it? Only to encounter a problem. - see Wesly’s post.

Who knows ??? :smile:

 

Userlevel 3
Badge

Further to this, I have used:-

Settings > Network Settings> scroll down to Manage Exclusions> Add autodiscover.rocketmail.com > Make Active > Save > Confirm Change

Re-Boot

So far so good.

Userlevel 7
Badge +4

Further to this, I have used:-

Settings > Network Settings> scroll down to Manage Exclusions> Add autodiscover.rocketmail.com > Make Active > Save > Confirm Change

Re-Boot

So far so good.


Hello,

That’s a temporary solution. Not a permanent plan. Not be safe. All the website list in this exclusion list will not be scaned by web-antivirus. If the website has been infected some malicious JS file or shellcode. Web-antivirus will not block them.

You can do a test. Set “secure.eicar.org” in that exclusion liet and acess https://www.eicar.org/?page_id=3950 to download EICAR TEST File. This file will download successfully if the browsers itself url safely filter doesn’t work.

Regards.

Userlevel 7
Badge +4

Hello @wgcuser 

I have received your PM. Now I want to know the what the website digital certification it is. If this alarm display again. Please press view certification link and take a screenshot and upload to here.

Regards.

Userlevel 3
Badge

@Wesly.Zhang 

I think the web site certification relates to Rocketmail.com which is the domain of one of my email mail boxes for example myname@rocketmail.com . This address was used was used as login name when I created my Microsoft Account, also used by a family member who has invited me to join Microsoft 365 - which as I'm sure you know, allows me to download and use Microsoft Office 365.

I have seen the Cert Error when I run Excel and Word.  I've not tried the other apps and  Outlook is not configured.

4 Images attached - hope they help

Userlevel 7
Badge +4

@Wesly.Zhang

I think the web site certification relates to Rocketmail.com which is the domain of one of my email mail boxes for example myname@rocketmail.com . This address was used was used as login name when I created my Microsoft Account, also used by a family member who has invited me to join Microsoft 365 - which as I'm sure you know, allows me to download and use Microsoft Office 365.

I have seen the Cert Error when I run Excel and Word.  I've not tried the other apps and  Outlook is not configured.

4 Images attached - hope they help


Hello,

I hate DigiCert digital certification. Their certification’s friendly name are the same. I can’t know which certification it is… I am confused...

If you use office client, Please add word.exe and execl.exe as trusted application exclude “Do not scan encrypted traffic”.

If specified ports doesn’t work, Please disable it.

Regards.

Userlevel 3
Badge

@Wesly.Zhang 
Sorry for the delay in getting back to you.

Are you suggesting that I undo the  following KIS configuration:
Settings > Network Settings > Manage Exclusions > Add Domain: autodiscover.rocketmail.com

and substitute the following :

Tools > Manage Applications > Application Control > Manage Applications > (choose) Microsoft > (choose) Excel > right Click choose Details and Rules > (tab) Exclusions > (tick) Do Not Scan Encrypted Traffic > (edit) Only for Specified Ports enter 80, 443

??
I see that both Word.exe and Excel.exe are already present in the Tools Trusted List of Apps!

Regards.

Userlevel 7
Badge +4

@Wesly.Zhang 
Sorry for the delay in getting back to you.

Are you suggesting that I undo the  following KIS configuration:
Settings > Network Settings > Manage Exclusions > Add Domain: autodiscover.rocketmail.com

and substitute the following :

Tools > Manage Applications > Application Control > Manage Applications > (choose) Microsoft > (choose) Excel > right Click choose Details and Rules > (tab) Exclusions > (tick) Do Not Scan Encrypted Traffic > (edit) Only for Specified Ports enter 80, 443

??
I see that both Word.exe and Excel.exe are already present in the Tools Trusted List of Apps!

Regards.


Hello,

Are you suggesting that I undo the  following KIS configuration:
Settings > Network Settings > Manage Exclusions > Add Domain: autodiscover.rocketmail.com

Yes, I wanna you try to set a exclusion for office application.

Tools > Manage Applications > Application Control > Manage Applications > (choose) Microsoft > (choose) Excel > right Click choose Details and Rules > (tab) Exclusions > (tick) Do Not Scan Encrypted Traffic > (edit) Only for Specified Ports enter 80, 443

If you set word.exe and execl.exe as trusted application and created rule in application control, you also can see the related rule in Settings → Threats and Exclusions → Specified trusted application. They are the same.

Note: If Specified Ports 80, 443 doesn’t work. Please disable this setting. Any better?

Regards.

Userlevel 3
Badge

@Wesly.Zhang 

Hello, Fortunately made a record of the KIS Config effective before my Cert Error messages.
I rolled back KIS settings to that time and set Excel.exe as trusted application and created rule in application control. Leaving Word.exe unchanged and rebooted PC.
Result - Excel=NO Cert Error! Word=Cert Error.
Also noted, as you said, the change to the rule in Settings > Threats and Exclusions > Specify trusted Applications. - Excel listed.
I have now also applied your suggestions to Word.

Thanks for your help

Userlevel 7
Badge +4

@Wesly.Zhang

Hello, Fortunately made a record of the KIS Config effective before my Cert Error messages.
I rolled back KIS settings to that time and set Excel.exe as trusted application and created rule in application control. Leaving Word.exe unchanged and rebooted PC.
Result - Excel=NO Cert Error! Word=Cert Error.
Also noted, as you said, the change to the rule in Settings > Threats and Exclusions > Specify trusted Applications. - Excel listed.
I have now also applied your suggestions to Word.

Thanks for your help


Hello,

what the e-mail service do you use involved in this issue? I want to confirm something related to the mail services? mail. yahoo.com? Could you please logoff the microsoft office account and re-login the office accout in Microsoft Office to check?

Regards.

Userlevel 7
Badge +4

Hello,

2021 mr3 build has been released. Could you dowload and install it to check this issue again ?

Regards.

Userlevel 3
Badge

@Wesly.Zhang 

I guess 2021 mr3 is KIS 21.2.16.590 (C) that has recently appeared on this PC? - it has made no change to the Certificate problem. You other suggestions have and did work!

@Wesly.Zhang 

@Flood and Flood's wife 

@rufford155 

Using the SSL checking website mentioned by rfford155 in his posts about Certificates, it would appear that autodiscover.rocketmail.com does not check out.

The only use of Rocketmail with MS 365 Apps is either from the login to MS Account, or the invitation to download and install MS 365. I decided to change the Primary Login to MS Account to “another email” address.

The next use of MS 365 indicated there was a login error changing it to the “another email” solved that error AND the autodiscover.rocketmail.com error. :blush:

Subsequent running another MS 365 App; so far, causes no errors!

Thanks to all for your help.

 

Userlevel 7
Badge +9

Hello @wgcuser,

KIS 21.2.16.590 (C)  is not v21.3.10.391 → KIS MR3, what’s new?

Thank you:pray_tone3:

Flood:whale: +:whale2:

Reply