Kaspersky
Question

Opera Browser unable to access the internet


Userlevel 1

Is it possible to use the Opera Browser with Kaspersky running, and if so what setting do I need to enable/disable to make it work?

 

I do not have Protection for Kids downloaded(and never have), and I tried added it to exclusions and trusted applications(no idea what either do but was just trying to get it to work lol).

 

I understand from reading a couple of the other topics that the Opera Browser is not officially supported, and that the extension does not work. My question is that it seems the browser itself does for most people since the topics I have been reading are getting the extension running and not the browser itself? I have tried to follow the workaround that was mentioned but when I tried it the plugin did not work.  Referenced workaround being

quote

Rename the browser’s main program file name to chrome.exe

Check whether Kaspersky plugin works

Kaspersky injects relevant dlls based on the browser process name to establish communication with the browser.

unquote


I do not actually care about whether the plugin works or not, but I am unable to use Opera Browser with Kaspersky enabled, it blocks its access to the internet. Is the workaround to make the internet work or just for the plugin?

 

 


16 replies

Userlevel 7
Badge +9

Hello @Skalya

Welcome!

Kaspersky does not support the Kaspersky protection extension/plugin if it’s installed in Opera browsers. 

There is an unofficial hack to make it work, but, that’s not authorised.  

We have the Opera browser installed & working without making any changes to our Kaspersky software at all. 

  1. Which KIS version & patch(x) is installed → in Windows hidden icons, rightclick the Kaspersky icon, select About
  2. Open KIS Reports, look thru the reports for any Opera events → save the report as a .txt file & attach:paperclip: to your reply please? 

Please post back? 

Thank you:pray_tone3:

Flood:whale: +:whale2:

Resource:

Read before you create a new topic! tutorial by @Danila T. 

Userlevel 1

21.3.10.391 (d)

sorry not sure how I am supposed to get to the KIS Reports?  Kaspersky just places a credits on the screen that opens with the KIS version

Userlevel 7
Badge +9

21.3.10.391 (d)

  1. how I am supposed to get to the KIS Reports? 
  2. Kaspersky just places a credits on the screen that opens with the KIS version

Hello @Skalya

Thank you for posting back! 

Open KIS application, select More tools, select Reports, look thru all reports for any Opera events, save the report & attach to your reply? 

 

 

 

 

Please post back? 

Thank you:pray_tone3:

Flood:whale: +:whale2:

Userlevel 1

I attached every event I could find with the search function that popped up with opera.

Userlevel 1

Edit: sorry missed some opera reports in Application Control

Userlevel 7
Badge +9

I attached every event I could find with the search function that popped up with opera.

Hello @Skalya

Thank you:clap_tone3:

  1. In the Opera browser, apart from the Kaspersky extension, are there any other extensions/plugins? 
  1. Has the “unable to use Opera Browser with Kaspersky enabled” always existed or is the problem new? 

Please do the following steps: 

  1. Close all apps.
  2. Create a System restore point
  3. Export KIS Settings →  images below
  4. Restore KIS Settings →  images below

     

     

     

     

     

     

     

  5. Shutdown the computer using Shutdown, not Restart, power on, login to computer.
  6. Do not start Opera atm
  7. Run a manual KIS Database update → allow it to complete.
  8. Shutdown the computer using Shutdown, not Restart, power on, login to computer, make sure KIS is active.
  9. Open Opera & recheck “unable to use Opera Browser with Kaspersky enabled”, fixed - “yes”, let us know please? 
  10. Not fixed, let us know please & include full screen screen-prints of any errors? 

Thank you:pray_tone3:

Flood:whale: +:whale2:

Userlevel 1

Ok I had a few things I had to all retry. When I was waiting for an original response I downloaded Opera GX to see if it worked, and it did. 

I had to install a couple windows updates that I let install before following your instructions. after restarting for the updates I followed your instructions and then attempted opening Opera - It still did not work. I then tried opening Opera GX and now it no longer worked as well.

So i tried reloading the restore for KIS that you had me make, and Opera GX still did not work. I then tried going back to the restore point before I downloaded the windows updates (putting me back to before I did anything) and Opera GX is still broken.

So the fix did not fix Opera, and it seems that Kaspersky broke Opera GX off of a first time install after a single restart because undoing both things did not refix it (both Opera and Opera GX work fine with Kaspersky disabled though)


Edit to clarify: since I ended up back to neither opera working after all that I went ahead and reinstalled the windows updates, and after a shutdown restored KIS settings again.
 

Userlevel 1

To answer point #1

I have the extensions 1Password, Dark reader, Mate Translate, Open in VLC, and uBlock installed.

I have tried multiple times to uninstall and/or disable them all while testing Opera, and they have all been disabled during this entire testing process.

Edit for grammer

Userlevel 1

I just noticed that @Flood and Flood's wife  that you have been using to ping.

To answer #2 it has been a problem since a couple days after I installed Opera. I do not regularly restart my computer, so it may have been after the first restart that it broke like what just happened to Opera GX, but I could not say for sure since it has been a month or so since it started happening.

Userlevel 7
Badge +9

Hello @Skalya

Thank you for the updates:ok_hand_tone3:

  • :arrow_right: Post the UPDATED KIS reports , i.e. since GX was installed? 
  • Is the Opera VPN enabled? 

Do the following steps:

  1. Make sure you have the KIS activation code written down & or a screen print of it. 
  2. Create a System restore point.
  3. Uninstall KIS, save License information ONLY, do not tick any other checkboxes. 
  4. Reset Opera Settings Restore settings to their original defaults →  opera://settings/resetProfileSettings
  5. Reset Opera RX Settings Restore settings to their original defaults →  opera://settings/resetProfileSettings
  6. Shutdown the computer using Shutdown, not Restart, power on, login to computer.
  7. Do not start Opera atm
  8. Check whether any applications installed on the computer are incompatible with KIS?  
  9. Download new KIS installer.
  10. Install KIS
  11. Shutdown the computer using Shutdown, not Restart, power on, login to computer.
  12. Run a manual Database update - allow it to complete. 
  13. Shutdown the computer using Shutdown, not Restart, power on, login to computer.
  14. Make sure KIS is running. 
  15. Start Opera/Opera RX, does the original issue repeat? 

Please let us know?

Thank you:pray_tone3:

Flood:whale: +:whale2:

Userlevel 1

Thank you for all of the help so far. I need to go to sleep for work tomorrow, I will try these steps after work and tell you how it goes.

Userlevel 7
Badge +9

Thank you for all of the help so far. I need to go to sleep for work tomorrow, I will try these steps after work and tell you how it goes.

You’re most welcome @Skalya,

Take your time, we’ll be available whenever you’re ready. Sleep well!

Thank you:pray_tone3:

Flood:whale: +:whale2:

Userlevel 1

Not sure what it was but my computer must have had something else wrong with it @Flood and Flood's wife 

 

I was starting on the steps above and was uninstalling Kaspersky and Opera at the same time, and the the uninstall for both errored for me. I do not remember the exact error but it was something .bin. Afterwards, no matter what I tried to do (including trying to use the system restore point) was giving me .bin errors, and telling the computer to shut down did nothing. I restarted by holding the physical button and logged back on to the same thing happening.  I could not figure out how to do anything so I ended up reinstalling windows from a usb that I keep. On the plus side all browers work fine now.

Userlevel 7
Badge +9

Not sure what it was but my computer must have had something else wrong with it @Flood and Flood's wife

I was starting on the steps above and was uninstalling Kaspersky and Opera at the same time, and the the uninstall for both errored for me. I do not remember the exact error but it was something .bin. Afterwards, no matter what I tried to do (including trying to use the system restore point) was giving me .bin errors, and telling the computer to shut down did nothing. I restarted by holding the physical button and logged back on to the same thing happening.  I could not figure out how to do anything so I ended up reinstalling windows from a usb that I keep. On the plus side all browsers work fine now.

Hello @Skalya

Thank you for taking the time to update us:pray_tone3:

We did not plan for Opera/Opera RX to be uninstalled, however, we’re delighted the issue is fully resolved:cartwheel_tone3:

IF, in the future, you need to uninstall KIS & any other software, please only uninstall KIS as a single procedure, do not combine with uninstalling any other software at the same time.  

Thanks again. 

Flood:whale: +:whale2:

Userlevel 1

Oh had to reread, reset in my mind was reinstall so I was uninstalling all at once so I could readd it first. Oops. Either way thanks for all the time you spent helping me with it, glad its fixed even if its not how I figuring how.

Assuming I had some other underlying problem with what happened.

Userlevel 7
Badge +9

Oh had to reread, reset in my mind was reinstall so I was uninstalling all at once so I could read it first. Oops. Either way thanks for all the time you spent helping me with it, glad its fixed even if its not how I figuring how.  Assuming I had some other underlying problem with what happened.

Hello @Skalya

You’re most welcome:relaxed:!

We agree there appears to have been “something else” going on, but, the important thing is you’ve got everything working as it should, so well done:clap_tone3:

Thanks again:pray_tone3:

Flood:whale: +:whale2:

Reply