Kaspersky
Solved

Network connection between computers does not work any more [Closed]

  • 16 December 2019
  • 15 replies
  • 11299 views

Userlevel 2
Badge

System : windows 10 Home edition : 1909.18363.535

The initial purpose was to share the printer HP Officejet 6600 (usb connected)that is set as shared on the computer and working, on the laptop I get the error : Windows cannot connect to the printer. Check the printer name. If it is a network printer make sure it is turned on and that the printer address is correct.

I checked all that.

Since this failed I tried to make a network connection from the laptop to the computer with the result hereafter.

On the laptop : file and print resource (DESKTOP-L....) is online but isn’t responding to connection attempts : error code 0x80070035.The remote computer isn’t responding to connections on port 445, possibly due to firewall or security settings, or because it might be temporarily unavailable.Windows couldn’t find any problem with the firewall on your computer.

netbios over TCP/IP is enabled,

Network discovery is on, file and printer sharing as well and the printer is marked as shared.

I changed the settings accordingly on both desktop and laptop.

SMB1 = enabled, Sharing wizard is checked in folder options, Function discovery resource publication and funtion discovery provider host is set to automatic.

The public folder is set to shared.

I was able to connect the laptop through the desktop but after restarting, they are visible but refuse to connect.

I even did a network reset and clicked yes to : allow the computer to be discoverable.

Since this going on for a while now, I hope someone can help me out, I cannot think of anything any more and followed all the recommendations I could find.

After all that changing etc. I got the internet to be very slow. After disabling : allow downloads from other PC’s in windows settings it got better for a while, it’s on and off really.

Thanks.

icon

Best answer by arleetel 20 December 2019, 14:23

View original

This topic has been closed for comments

15 replies

Userlevel 7
Badge +9

Welcome. Can you please try this :

Kaspersky > Settings > Protection > Firewall > Configure packet rules
=> Local services (TCP) > Rightclick > Edit > Action : "Allow" > Save
=> Local services (UDP) > Rightclick > Edit > Action : "Allow" > Save

=> Reboot

@richbuff Also Ooops , we miss the preview option

Userlevel 7
Badge +4

Kaspersky products are: ? 

Kaspersky network settings are: ?

 

Ooops, please see Berny above this post! :)

Userlevel 2
Badge

Thanks fo your replies.

@Berny : changed the settings on both the computer and the laptop.

Same thing, nothing changed. laptop is not visible on the computer.

Things change continuously, I’m trying since Thursday and I bought this computer to replace windows 7…… argh …..

I suppose I better reset it to the original and block it again.

Userlevel 7
Badge +9

Can you please provide some details that @richbuff is asking for above your Post.

Also, there is a lot of content available on the WEB concerning [ error code 0x80070035 ]

Userlevel 2
Badge

KIS 20.014.1085(f)

Network was changed like mentioned above but blocked it again. All computers are configured that way.  I really don’t want to mess up security settings for 1. a printer that does not want to show up and 2.files/computers that cannot be seen. Already got a huge file Live Kernel reports, that CCleaner detected, moved it to another drive, don’t know why that happened ! Not really reassuring with a new computer.

And yes, 5 days of changing, adapting, tutorials etc. error 0x80070035 etc. : there is a very good tutorial on the windows 10 forum, very clear and I followed every step, controlled a few times to be sure and no, it did not work. Seeing all this I also understand that this a serious bug in windows10  and so far many people are facing this problem. It’s a pity Windows 7 is stopping updates and support next year.

My workaround for now is to copy whatever I want to print from another computer is copy it to an external USB stick and print from there, until windows (maybe) comes up with a real solution.

Userlevel 7
Badge +4

Have you diagnosed this issue as caused by or not caused by Kaspersky application? 

Userlevel 2
Badge

Since it involved some blocking by a firewall and port 445, it could have been Kaspersky. I never disabled TCP and UDP before on any computer, it did not help anyway. 

 

Userlevel 7
Badge +2

Hi All with the  above posts.

This issue with Hp printers happened few years ago also.

Have you tried Installing and Using the Windows Built-in Print Driver (Hp Printers) as a test?

If “NO” look below URL.

Tutorial<>Installing and Using the Windows Built-in Print Driver (Hp Printers)

https://www.hpdrivers.net/installing-and-using-the-windows-built-in-print-driver-hp-printers/

Hp print and scan doctor for Windows PC.

https://support.hp.com/us-en/topic/diagnostics?category=printing&issue=scan-issues

Hp Software and Driver downloads.

https://support.hp.com/us-en/drivers

Thank you

Userlevel 2
Badge

@KarDip : I don’t know what you mean but I did install the drivers from HP on the computer where the printer is connected to. Scanning, printing etc. is possible on that computer only. It’s in fact the network communication between the computers that is not working. All the computers have the same OS and KIS version on it.

Userlevel 7
Badge +2

Hi @arleetel, okay maybe let the Kaspersky experts take a look, as you have Kaspersky<>KIS 20.014.1085(f) installed i suggest you contact Kaspersky support. https://my.kaspersky.com/

Also send a GSI Log.

https://support.kaspersky.com/common/diagnostics/3632#block7

In your computer network connection settings do you have all the network profiles set the same.

Like in public or private, to share printers, you need to be in “private”

Thank you.

 

 

Userlevel 2
Badge

@KarDip : my network connection is Private and I sent the GSI and asked support for help.

Thanks.

Userlevel 7
Badge +2

Hi @arleetel, okay seems you covered everything to try and fix, so yes you need to get this issue sorted to see if if it is Kaspersky causing the disconnect of devices, can you let us know here in Kaspersky Community what support say.

Thank you.

Userlevel 2
Badge

@KarDip : I certainly will.

Userlevel 2
Badge

@KarDip 

The reply from Kaspersky support :

“set all networks 'Trusted' status in Kaspersky Firewall:

1. If the main window of Kaspersky application is not on your desktop, bring it up by double-clicking the Kaspersky desktop shortcut (icon) or by double clicking on the smaller Kaspersky icon in the bottom right corner of the screen;
2. Click on the Gear icon in the bottom left corner of the Kaspersky window;
3. On the left side menu select 'Protection';
4. On the right side menu select 'Firewall' and then select 'Networks'.
5. Right click on each network in the list, except Internet, and select Edit.
6. From the tab that will appear in the right hand side, set the Network type as 'Trusted network'.
7. Repeat the same procedure for each and every network listed there apart from "Internet" (as mentioned above)

Please note that the packet rules for TCP and UDP should remain on "Allow" as well.”

I did all that and I could share the printer on the other computers.

As to the TCP and UDP rules : I have a question : is this safe. When allowing it Kaspersky asks if I’m sure and that it’s not a malicious process causing the change and I had to confirm.

 

Userlevel 7
Badge +2

Hi @arleetel, that is great news.

Also TCP and UDP allowed is okay so don't worry about it.

And it all works connecting your printers.

Thank you.