Kaspersky
Question

My Kaspersky: Email Address Invalid? [moved]


I wanted to link My Kaspersky Account with my Kaspersky program on my pc and it says Invalid Email Address Format. Why is it like this? I basically typed j**********@gmail.com and it says invalid. My account exists.


21 replies

Userlevel 7
Badge +4
Welcome. This topic was moved from Russian section of this forum, to the English section of this forum.

However, the primary purpose of this post is to bump this topic to the top of this forum section that it was moved to, lest it be missed, being moved and arriving lower down on this English page.
Hello.
I am having exactly the same problem as detailed by Discomann when trying to log in to My Kaspersky on the Anti-Virus software I have installed on my laptop.
I did not have the same problem with my desktop.
I hope that some advice will be offered.
Thank you.
Userlevel 7
Badge +9
Hello PhilBr,
Welcome!
Using any browser, can you please go to: https://my.kaspersky.com/ , your MyKaspersky account and login in from there, if login is successful, please check the status of the laptop - https://my.kaspersky.com/MyDevices#/ , if the application software has synchronised correctly the status should show "Last connection" & or "Connected"
Please post back as there's more we can do to assist depending on your findings?
Many thanks!
Hello.

I followed your advice and successfully logged in using my laptop but under devices it only shows my desktop not the laptop.
Have you another possible solution?
Many Thanks

PhilBr
Userlevel 7
Badge +9
Hello PhilBr,
Thanks for posting back!
So one issue solved: (login) and 1 remaining: (Laptop not synced with MyKaspersky account)?
May I ask,
  1. Is the desktop device still in use?
  2. If yes, still has Kaspersky software installed/active?
Please let us know, solutions depend on your information please?
And, useful reference doco: https://support.kaspersky.com/common/start/13886, even tho it says PC, it's generic🙂
Many thanks!
Hello.
Thank you for your latest reply.
Yes the desktop has exactly the same free antivirus installed and yes it is active.
When I sign into My Kaspersky as advised by you the information about my last login on my desktop is shown and is correct.
I have attached a photo of what happens when I try and login on the laptop through the App.
It doesn't matter what email address I type in, it always says Invalid Email Address Format.

Mod's note:
Image was deleted according to the author's message.
Userlevel 7
Badge +9
Hello PhilBr,
Sent you a pm...
Userlevel 7
Badge +9
Hello PhilBr,
Syncing your account fixed the issue.
Best regards.
Many thanks.
PhilBr
I am having exactly the same problem, would you guys let me know how to solve this issue.

I have to reinstall my Windows due to the few reasons.
Userlevel 7
Badge +9
I am having exactly the same problem, I have to reinstall my Windows due to the few reasons. Would you guys let me know how to solve this issue.
Hello@Ckpk,
Welcome!
(1) The MyKaspersky.com web portal uses the same email address and password used to sign into this community.kaspersky.com web portal.
(2) Are you able to sign into your MyKaspersky.com account using any browser?
(3) What happens when you select MyKaspersky.com from KIS application? (see my image)
image 1


(4) Check Hosts file
(5) Check Kaspersky Password Reset Tool - note if using this procedure, the Tool must be used with Windows in SafeMode.
Please let us know:
(6) Operating system information?
(7) Kaspersky software information?

---
Regarding reinstalling Windows, before you do so, go to KIS Support window, select 🎧, next to ⚙, the Support window shows: License Key, Operating System information and Kaspersky software information. image 2


  • Make a note or take a screen image so you have your License Key information available AFTER you've reinstalled Windows, please don't post your License Key information.
Thank you🙏🏽
How to connect your device to My Kaspersky
I am able to Login via website with any browser without any problem.

Clicking on the My Kaspersky from the KIS GUI bring me to login page, however when i type the email address, it always prompt Invalid Email Address Format and the Sign In button will grey out.

I have SS those information.
Userlevel 7
Badge +8
@Ckpk Please contact K-Lab Tech Support https://support.kaspersky.com/b2c/

Go to : Purchasing and licensing > Contact Support > Kaspersky Lab > Chat
Userlevel 7
Badge +9
I am able to Login via website with any browser without any problem.
Clicking on the My Kaspersky from the KIS GUI bring me to login page, however when i type the email address, it always prompt Invalid Email Address Format and the Sign In button will grey out.

Hello @Ckpk,
Thank you for posting back and clarifying the issue.
If you have licensed Kaspersky software, you may wish to contact Kaspersky Technical Support, already referenced in my first reply, however, let's see, is this what you see?


  1. Is the email address the same email address used to log in the MyKaspersky account in a browser?
  2. Can you explain why you need to log in via the Kaspersky application?
Please let me know?
Thank you.

I am able to Login via website with any browser without any problem.
Clicking on the My Kaspersky from the KIS GUI bring me to login page, however when i type the email address, it always prompt Invalid Email Address Format and the Sign In button will grey out.
Hello @Ckpk,
Thank you for posting back and clarifying the issue.
If you have licensed Kaspersky software, you may wish to contact Kaspersky Technical Support, already referenced in my first reply, however, let's see, is this what you see?


  1. Is the email address the same email address used to log in the MyKaspersky account in a browser?
  2. Can you explain why you need to log in via the Kaspersky application?
Please let me know?
Thank you.

Nope, not this error, the error exactly the same as the first post, invalid email format once leave the email fields.

Using the same email address via web and KIS gui.

I want to reinstall my Windows for few reason, thats why i am going to bind current license to my kaspersky so i can use it again later.
Userlevel 7
Badge +9
Nope, not this error, the error exactly the same as the first post, invalid email format once leave the email fields. Using the same email address via web and KIS gui.
i am going to bind current license to my kaspersky so i can use it again later.



Hello @Ckpk,
Thanks for posting back.
  1. When you say "bind" do you mean you wish to synchronise Kaspersky application with your online MyKaspersky account?
  2. When you log into the MyKaspersky account (using a browser) https://my.kaspersky.com/MyDevices#/ is your device shown?
  3. In your MyKaspersky account - LICENSES: https://my.kaspersky.com/MyLicenses#/, are the Activation Code & License Key recorded?
Please let me know?
Thank you.

Ten months later, I’m having exactly the same problem as the OP: paid-for KIS on a laptop running Windows 7 asks me to connect to My Kaspersky, then rejects my valid email address.  KIS accepts the same email address on a tower running Windows 10 with the same licensed copy of KIS.  When is this fault going to be fixed?

Userlevel 7
Badge +9

Hello @paolo-56,

Welcome!

  1. Using a browser, not KIS application, have you logged in the MyKaspersky account, disconnected the  Windows 7 device & resynchronised the device & the KIS application?
  2. Have you raised the issue with Kaspersky Technical Support

Please let us know?

Thank you?

Flood:whale:

KIS20 Library

Hi Flood, thank you for your prompt reply.

  1. Yes. I can’t disconnect the Windows 7 device because it’s not registered.  I can’t register it because KIS rejects my valid email address.
  2. Not yet, but surely they know about this fault already?  The OP registered this 10 months ago - KIS is rejecting valid email addresses.  That’s why I asked, when is it going to be fixed?
Userlevel 7
Badge +9

Hello @paolo-56,

You’re very welcome!

Thank you for the additional information:ok_hand_tone3:

  • May I ask, how long has KIS been installed on the W7 device please?
  • Have you uninstalled & reinstalled KIS? 

Reading thru the previous posts, there’s no indictation that any of the previous Community members who’ve posted did contact Kaspersky Technical Support and for this issue it is necessary for each person impacted to contact Kaspersky Technical Support, essentially bc each person’s hardware, software, network, environmental factors may be different. What may appear to be an identical issue is not necessarily so.

The support team will need a GSI & Windows Logs and they may request Traces, run as the issue is replicated; if Traces are required they will step you thru the necessary steps. 

After submitting the case, you’ll receive an automated email with an INC+12digits reference number, then, nomally, within 5 business days, a Kaspersky Technical Support human:spy_tone3: will communicate with you, also by email, you may continue to engage with the Kaspersky Technical Team via email or by updating the INC in your MyKaspersky account.

Please let us know the outcome when it’s available? 

Thank you:pray_tone3:

Flood:whale:

 

Hi Flood, thank you for your comprehensive reply.

The answers to your questions are as follows:

  1.  6 years.
  2.  I have just done this and it cleared the problem - I have now been able to register the installation with My Kaspersky.

Of course, this is a workaround, not a fix - there must be some underlying problem that caused this fault to arise.  Nevertheless, thank you for your help.

Reply