Kaspersky

Message: "Connection to network is not secure. Wi Fi Network ..........is Public Run kaspersky Secure Connection".

  • 6 December 2019
  • 7 replies
  • 5049 views

I believe this is a message to encourage users to by the Kaspersky VPN. This is not good to mislead users and make them think they are not secure. 

Also mentioning that user is using a “Public Network”, makes it worse.

 

I live in USA and I’ve been using Kaspersky since long time ago despite all issues between US and Russia and still stick to Kaspersky. This misleading message is so annoying.

 

I hope a technician from Kaspersky clarify this situation.

 

Thank you.


7 replies

Userlevel 7
Badge +4

Welcome. Is it a unsecured, unencrypted public connection, which is not secure? 

I have strong password on my router so it means I'm secure at some level. I agree that still it may be hacked but the statement which says I'm connecting to a “Public Network” is kind of exaggerating or misleading. That's my point.

Userlevel 7
Badge +9

Hi, @jaysan ,
For your network to be secure, it must meet the requirements of this article: https://support.kaspersky.com/common/windows/12779
I  think you have a very popular Wi-Fi network name (SSID), try changing it, for example, to Kugy@oTEQ}!uwj2yOeJp

Hi, @jaysan ,
For your network to be secure, it must meet the requirements of this article: https://support.kaspersky.com/common/windows/12779
I  think you have a very popular Wi-Fi network name (SSID), try changing it, for example, to Kugy@oTEQ}!uwj2yOeJp

 

Hi @Friend ,

 

Thanks for replying to my discussion. The referred article was very informative and helpful. I learned a lot form it.

 

Regards,

Mohammad.

I'm getting this message too (Wi-fi network is public Install Kaspersky Secure Connection). I did have it installed, but have now uninstalled as Kaspersky is causing massive browsing problems. I am ready to uninstall and go for a free antivirus (and ask for money back). I don't have the time or patience to deal with this.

My network is as secure as any home network and several other devices with Kaspersky run on the network without issue, yet this machine is disabled from browsing because the network is insecure. Please advise.

 

Userlevel 7
Badge +9

Hello @toddjconklin

Welcome!

In (Windows) Control Panel\All Control Panel Items\Network and Sharing Centre, how is the Wifi n/w set?

& check Network properties, is Wifi defined as Public?

Thank you:pray_tone3:

Flood:whale:

Userlevel 7
Badge +4

I'm getting this message too (Wi-fi network is public Install Kaspersky Secure Connection). I did have it installed, but have now uninstalled as Kaspersky is causing massive browsing problems. I am ready to uninstall and go for a free antivirus (and ask for money back). I don't have the time or patience to deal with this.

My network is as secure as any home network and several other devices with Kaspersky run on the network without issue, yet this machine is disabled from browsing because the network is insecure. Please advise.

 

Hello @toddjconklin 

I  think you have a very popular Wi-Fi network name (SSID), try changing it.

Reply