Kaspersky
Solved

[Mac] How do I disable the pop-up, on-screen Kaspersky keyboard? [Closed]

  • 10 September 2019
  • 14 replies
  • 6283 views

The Kaspersky virtual/on-screen "keyboard" pops up and I don't need it. How do I disable the pop-up, on-screen Kaspersky keyboard?
icon

Best answer by Flood and Flood's wife 11 September 2019, 04:58

Kaspersky virtual/on-screen "keyboard" pops up and I don't need it. How do I disable the pop-up, on-screen Kaspersky keyboard?



Hello @dmarrduncan,

MAC-KIS, there's no "settings", Turn off/on automatic display of the onscreen keyboard



1) KIS application icon, open Protection Centre, choose Preferences

> application preferences window opens.

2) On Browsers tab, in Onscreen Keyboard section, deselect/untick Show onscreen keyboard



Also check:


  • Safe Money as OnScreen Keyboard is a Safe$ feature.
  • Privacy (there won't be OSKB, preferences in Privacy, but, there may be other Preferences you'd like to check/confirm)

& would you please kindly let me know the 4 recommendations please?



Please port back?

Thank you🙏🏽



KIS2020 Library
View original

This topic has been closed for comments

14 replies

Added info: this for Mac running Mojave OS for Kaspersky Internet Security 20.
Userlevel 1



2, Then click additional




3.Click on Secure Data Input
4. Uncheck “show quick launch icon in data entry fields” and uncheck “Enable secure keyboard input”




That's it the keyboard will no longer pop up. But just remember it was put there for the reason of security especially when banking on line for instance. It makes no sound and therefore cannot be heard by anyone listening in from outside etc, unlike your real keyboard which can be heard by hackers with the right equipment. Yes people can do that, through the glass in your windows.

Hope it helps anyway
Thank you. I have seen this solution before, but I don't have the "settings" (gear icon) in the bottom left hand corner and I can't seem to find a path to the settings area. See attached: this is what I see when I open the application. So... what am I missing? How do I get to settings?

Userlevel 1
Do you know what version of KIS your running?
Userlevel 1
So if it's within a browser your talking about then take a look at the Video link in green in the last line of the text below, right click it and open the link in a new tab. You can switch it off and on in the browser your using. If that doesn't help then let us know.

Kaspersky Protection is added to your browser automatically after the installation of the Kaspersky lab application. When you open the browser for the first time after the installation of the Kaspersky Lab application, the browser will show you the notification prompting to enable the Kaspersky Protection extension. If you skipped this notification, you can enable the extension in the browser settings. See the guide for your browser below.
Browsers that support the Kaspersky Protection extension:
  • Microsoft Internet Explorer 8.0, 9.0, 10.0, 11.0
  • Microsoft Internet Explorer versions 8.0 – 11.0 in the new Windows interface style are not supported.
  • Mozilla Firefox 52.x-65.x
  • Mozilla Firefox ESR 52.x60.x
  • Google Chrome 48.x-72.x
Scroll down to watch the video about management options in the Kaspersky Protection extension.
Userlevel 7
Badge +9
Kaspersky virtual/on-screen "keyboard" pops up and I don't need it. How do I disable the pop-up, on-screen Kaspersky keyboard?

Hello @dmarrduncan,
MAC-KIS, there's no "settings", Turn off/on automatic display of the onscreen keyboard

1) KIS application icon, open Protection Centre, choose Preferences
> application preferences window opens.
2) On Browsers tab, in Onscreen Keyboard section, deselect/untick Show onscreen keyboard


Also check:
  • Safe Money as OnScreen Keyboard is a Safe$ feature.
  • Privacy (there won't be OSKB, preferences in Privacy, but, there may be other Preferences you'd like to check/confirm)
& would you please kindly let me know the 4 recommendations please?


Please port back?
Thank you🙏🏽

KIS2020 Library
Yes, going to Preferences --> Browser --> uncheck the OS keyboard box. Worked. Thanks.
Userlevel 7
Badge +9
Hello @dmarrduncan,
That's wonderful news, I'm glad it worked!
Thank you for letting us know🙏🏽

Hey guys,

 

My patience is over. Nothing works. all checks are off but Kaspersky keyboard pops up on my Mac regardless whether Kaspersky Internet Security is on or off. 

 

please help.

Userlevel 7
Badge +9

Hello @Meesha,

Welcome!

Please tell us:

  1. MAC version & build?
  2. KIS version & patch(x)? x = letter
  3. Browser name & version
  4. May I have an full screen image of the problem? 

Please post back?

Thank you:pray_tone3:

Flood:whale:

Last version of OS and last version of Safari.

Kaspersky internet security os down. checks are off. web security is disabled. 

 

I lost patience already. I can’t turn off this keyboard. it pops up regardless of anything,. 

Userlevel 7
Badge +9

Hello @Meesha,

Thank you for replying. 

Please contact Kaspersky Technical Support. They will need a System Report and the system.log file in macOS, an image & they may request Traces, run as the issue is replicated, if needed they will assist you with Traces collection.

Thank you:pray_tone3:

Flood:whale:

I did. then I waited for 30 minutes in a technical chat and nobody joined the chat. 

Userlevel 7
Badge +9

Hello @Meesha

That’s unusual, in my experience, the Online Chat Team respond very quickly:thinking:

As we don’t know your location it’s not possible to check that chat portal, however, I’ve initiated a chat session in my location, the operator responded immediately. 

Unfortunately, here in the Community, we cannot fix the issue, you really do need to engage Kaspersky Technical Support, please do so by submitting a case via (your) MyKaspersky account. 

Thank you:pray_tone3:

Flood:whale: