Kaspersky
Solved

? KIS 21.2.16.590(b) blocking Javascripted webserver stats graphs ?

  • 27 January 2021
  • 5 replies
  • 94 views

Earlier this month my W10 PC upgraded itself to KIS 21.2.16.590(b), largely without a problem, but I can no longer view some web server statistics. These are in the form of Javascripted-visual graphs of web traffic that are embedded in a webpage.  All I ever see is Loading..... but they never load. Sometimes this locks up my browser.

I use Firefox by default so I tried three different web browsers on my PC, all with the same result, so it isn't the browser blocking the graphs. Then I used my mobile phone browser over 4G not Wi-Fi, and the graphs are displaying correctly. The web host in the USA confirms there is no problem with their servers or scripts.

We think it has to be something to do with KIS. Best I can think of is Anti-banner setting, but this is off anyway. Are there any deep settings that would cause Javascripted graphics to be disabled in my web browsers?  Blocked / Allow URLs or anything like that?

TIA!

icon

Best answer by Igor Kurzin 28 January 2021, 07:45

Hi @ARW , 

Does it help to set it to “Do not scan encrypted connections” in Settings → Network settings? Restart browser and check. 

If not, does it help to disable “Inject script into web traffic to interact with web pages”? Restart browser to check. 

View original

5 replies

Userlevel 7
Badge +8

@ARW Welcome.

Did you try to trust the URL :

> Settings > Protection> Web Anti-Virus > Advanced Settings > Configure Trusted URL's > Add

Thanks, but sadly that didn’t make a difference -- I added every combination of URL and absolute URL but it still doesn’t work. In fact Firefox locked up altogether again, and Edge isn’t much better.

The web page is loading but the JS stats. do not. Is there any setting for eg scanning malicious scripts or anything else?

Userlevel 7
Badge +8

@ARW Please contact Kaspersky Lab Technical Support https://center.Kaspersky.com 

Userlevel 7
Badge +4

Hi @ARW , 

Does it help to set it to “Do not scan encrypted connections” in Settings → Network settings? Restart browser and check. 

If not, does it help to disable “Inject script into web traffic to interact with web pages”? Restart browser to check. 

Hi @ARW , 

Does it help to set it to “Do not scan encrypted connections” in Settings → Network settings? Restart browser and check. 

If not, does it help to disable “Inject script into web traffic to interact with web pages”? Restart browser to check. 


Hi Igor,

BINGO! :grinning:

Do not scan encrypted connections made no difference,  but Disable “Inject script… etc” has solved this problem. I can now see the graphical statistics once again.

I guessed there was a deep setting to adjust somewhere, thank you very much for the suggestion!

Alan

Reply / Ответить