Kaspersky
Question

Kaspersky Protection extension greyed out in new Edge Chromium


I installed the Kaspersky Protection extension on the new Edge browser (Version 83.0.478.58 (Official build) (64-bit)) under Windows 10, and enabled it in the extensions page, but it remains stubbornly greyed out. 

If I click on it, it displays this unhelpful image:

I don’t see any settings in Kaspersky Internet Security for the extension, so any ideas what the problem is?


12 replies

Userlevel 7
Badge +9

Hello @Dave Lorde,

Welcome!

  1. Was the Kaspersky protection extension installed from the Chrome web store
  2. In the Edge Chromium browser - is this the KPE Chrome url?

Please let us know?

Thank you:pray_tone3:

Flood:whale:

Resources:

How to install the extension in Edge based on Chromium

How to enable the extension in Edge based on Chromium

  1. Was the Kaspersky protection extension installed from the Chrome web store
  2. In the Edge Chromium browser - is this the KPE Chrome url?

Hi @FLOOD,

Thanks for the speedy response -

 

  1.  Yes, the extension was installed from the Google Chrome web store
  2.  Yes, that was the URL from which it was installed.
Userlevel 7
Badge +9

Hello @Dave Lorde,

You’re most welcome!

  • To troubleshoot we’ve uninstalled & reinstalled KPE, a number of times, very soon after selecting Add to Chrome, the Kaspersky green icon appears, there’s possibly an issue with the Edge install or KIS:thinking:

:a:

Please check:

  1. What setting is edge://settings/privacy - Tracking prevention 
  2. Edge Chromium version, should be: 83.0.478.61 (Official build) (64-bit) ?
  3. Kaspersky Protection extension version, should be: 30.390.42.0 Updated June 29, 2020 ?
  4. KIS version & patch, should be 20.0.14.1085(k) ?
  5. Windows is updated with all updates showing a Successfully applied status?

:b:

  1. Create a System restore point. 
  2. Copy C:\Users\**YOURNAME**\AppData\Local\MicrosoftEdge\User to the desktop.
  3. Edge Chromium → select Reset settings - Restore settings to their default values →  edge://settings/reset
  4. Open KIS, select :gear:Settings, select Manage settings, select Export settings - save the configuration file, select Restore settings.
  5. Shutdown computer using full Shutdown, not Restart, power on, login.
  6. Start KIS
  7. Run a KIS manual Database update - allow it to complete
  8. Start Edge Chromium
  9. Add KPE  - see video as a guide

Please let us know the outcome?

Thank you:pray_tone3:

Flood:whale:

Hi Flood,

 

That procedure seems to have fixed it - I re-enabled all the Edge extensions and restored all the tabs and Kaspersky Protection still works OK.

 

But I found that if I re-imported the old KIS configuration, the Kaspersky Protection extension stopped working again, so it seems to be a KIS setting that was stopping it working.

 

Thanks for your help.

Dave

Userlevel 7
Badge +4

Hello,

You should allow kis inject its js file to the network traffic first. Do you disable “Inject script into the network traffic to Interact with the product”? If Yes, this behavior is normal.

Regards.

 

You should allow kis inject its js file to the network traffic first. Do you disable “Inject script into the network traffic to Interact with the product”?

I don’t recall disabling that setting. But if that was the problem, it would helpful for the extension to display a message to that effect instead of a cryptic image with no explanation.

Userlevel 7
Badge +9

Hello @Dave Lorde,
You're most welcome:relaxed: !

  • Thank you for taking the time to let us know the issue is resolved:pray_tone3: , we're delighted with the outcome:cartwheel_tone3:
  1. Regarding disabling Inject script into web traffic to interact with web pages option, is enabled by default, and not one of the options commonly disabled, unless there’s been other issues → when you identified/reported "Kaspersky Protection extension greyed out in Edge Chromium", was the Kaspersky Protection extension working in:
  • Google Chrome browser?
  • Firefox browser?
  • IE browser? 

Please let us know?

Thank you:pray_tone3:

Flood:whale:

...was the Kaspersky Protection extension working in:

  • Google Chrome browser?
  • Firefox browser?
  • IE browser? 

I don’t know, I wasn’t using those browsers, I was using the Edge Chromium browser.

KIS updated to 2021 for me today.  Update removed the extension from Edge 87.0.664.41 (Official build) (64-bit) and when I re-added it from Chrome Web Store - it looks the same as in the original post. Reset did not help in any way. 

Userlevel 7
Badge +3

@Simbiat hello!

What is the version of the extension?

Try this one: https://chrome.google.com/webstore/detail/kaspersky-protection/ahkjpbeeocnddjkakilopmfdlnjdpcdm 

Please tell about the results.

@Anton Mefodys it is 30.390.42.0 which is linked in FAQ. The one that you’ve linked seems to be working normally, thank you. I think it would be best to have some kind of button (Install/Reinstall) in KIS itself. If there are multiple possible versions, it should determine which one should be used in my particular case.

Userlevel 7
Badge +9

@Simbiat hello!

What is the version of the extension?

Try this one: https://chrome.google.com/webstore/detail/kaspersky-protection/ahkjpbeeocnddjkakilopmfdlnjdpcdm 

Please tell about the results.

Hello @Anton Mefodys

Thank you for the correct link:ok_hand_tone3:

How to install the extension in Edge based on Chromium extension link redirects to https://chrome.google.com/webstore/detail/kaspersky-protection/elhpdacimkjpccooodognopfhbdgnpbk, Version 30.390.42.0, Updated June 29, 2020

 

 

Thank you:pray_tone3:

Flood:whale:+:whale2:

Reply / Ответить