Kaspersky
Solved

Kaspersky not starting properly, Mac Catalina.

  • 28 August 2021
  • 2 replies
  • 61 views

Hi there,

Whenever I start up my Macbook for the past few months, I keep getting this attached message from Kaspersky Internet Security saying it failed to start up correctly. Why is that? it said to seek technical support if it keeps happening, so here I am

Also, as a separate issue which may be related, I’ve been noticing that the Kaspersky (I think) process called “kavd” is wrecking havoc on my computer’s processor. Lately my Mac’s fan has been constantly running at full blast more than usual, even when nothing processor intensive is running. This also results in slowdown at some points. Every time I check the Activity Monitor, it’s the same culprit kavd, running like 200% - 300% on the CPU for no apparent reason and taking up a lot of memory. I believe that something is happening, perhaps a memory leak, that is causing Kaspersky to over tax the computer’s resources for no apparent reason. I believe this may be responsible for my performance issues.

Since these issues started both seemed to start happening around the same time, I’d like some help diagnosing this. Any ideas? I seem to be running the most recent version. I’ve put my Mac’s specs below.

Mac OS Catalina 10.15.7
2.4 GHZ Intel Core i9
32 GB RAM
Intel UHD Graphics 630 1536 MB

icon

Best answer by Danila T. 1 September 2021, 15:55

View original

This topic has been closed for comments

2 replies

Userlevel 7
Badge +9

it said to seek technical support if it keeps happening, so here I am

Welcome.

Kaspersky Technical Support is available here :

https://my.kaspersky.com/techsupport#/requests/new 

 

Userlevel 7
Badge +7

Hello,


1) Uninstall the KIS 21 for Mac: https://support.kaspersky.com/15587#block2
2) Restart macOS.
3) Try to install KIS 21 again and update base. Restart macOS again.

Check problem.