Kaspersky

Kaspersky handling of soundmixer.exe virus [Closed]


Yesterday Kaspersky Internet Security detected a trojan mining virus soundmixer.exe and removed the threat. But next time I started the PC and logged in, there was only a terminal window opened, and no file explorer. After a lot of search, I found that most of the steps to eliminate the virus threat were taken, except one:
In the registry HKEY_CURRENT_USER\Software\Microsoft\Windows NT\CurrentVersion\Winlogon , the value of Shell was not fixed - it was still %comspec% instead of explorer.exe . That solved the problem.
Hopefully that will be fixed soon.

BestTiger 1 year ago

Hello, i had the same problem as makifazder5. This did the trick for me:

https://answers.microsoft.com/en-us/windows/forum/windows_10-performance/soundmixerexe-error-on-startup/85e30193-a5d3-4ceb-86c3-7d35acdb4d7e
View original

This topic has been closed for comments

13 replies

Userlevel 7
Badge +4
Welcome. Please inform Tech Support of your findings.

Please contact Tech Support: https://my.kaspersky.com/support/

Please attach the following items to your Tech Support request:

a. Description of the issue.
b. Screenshot, as needed.
same problem here. value of Shell is explorer.exe but explorer.exe still doen't work at startup. I run it manually everytime. I deleted kaspersky free and reinstalled it but it still didn't fix the issue
Userlevel 7
Badge +9
same problem here. value of Shell is explorer.exe but explorer.exe still doesn't work at startup. I run it manually every time. I deleted kaspersky free & reinstalled, it still didn't fix the issue
Hello @makifazder
Welcome!
Your issue (& solution) is somewhat different, for several reasons:
  1. Kaspersky free software = no Technical Support.
  2. @AlexSSB's fix has not resolved explorer.exe starting @ system startup.
  3. Deleting KAV free and reinstalling will not fix explorer.exe not starting @ system startup.
---
Please do this (assuming you're using Windows):
  • Start Windows in SafeMode with Networking
Q. Does explorer.exe start?
"Yes"
"No"
Also, please check system event logs, look for any explorer.exe events
&, please read Windows Explorer has stopped working

If the operating system is not Windows, please post back with Opsys info so we can provide an alternative system info collection tool.

Thank you.
No. Explorer.exe doesn't start in SafeMode (with networking) eather. I uploaded the system info. Event log has tons of explorer.exe events.

The OS is windows 10.
Userlevel 7
Badge +9
No. Explorer.exe doesn't start in SafeMode (with networking) eather. I uploaded the system info. Event log has tons of explorer.exe events. The OS is windows 10.
Hello @makifazder,
Thanks for posting back.
  • When SafeMode was activated, what was running/active?
&
  • Collect GSI & Windows Logs - upload .zip folder, post back or pm the link.
Thank you
nothing just a black screen. I use ctrl+shift+esc to open task meneger and run explorer.exe

I dont know how to save windows logs.
Userlevel 7
Badge +9
nothing just a black screen. I use ctrl+shift+esc to open task meneger and run explorer.exe

Hello @makifazder,
Thank you for posting back.
  1. When you started Windows in SafeMode, what was active?
  2. In NormalMode, is the first thing, or all you see, is a black screen?
  3. In SafeMode, is the first thing, or all you see, is a black screen?
  4. Run GSI again, selectWindows logs, when the GSI is complete, upload the .zip folder to cloud, post back or pm the link please?
Thank you🙏🏽
  1. I started SafeMode with networking as you asked, if that what you mean by active networking was active
  2. In normal mode all I see is a black screen yes.
  3. In SafeMode also all I see is a black screen.
  4. I'll upload it here
Userlevel 7
Badge +9
  1. I started SafeMode with networking as you asked, if that what you mean by active networking was active
  2. In normal mode all I see is a black screen yes.
  3. In SafeMode also all I see is a black screen.


Hello @makifazder.
  1. What happened just before or when Explorer stopped working?
  2. What date was that?
  3. Is there a reason why Windows is still v 1803?
  4. Up until the problem have the Windows updates been happening on a regular basis, automatically?
  5. When did you start using Kaspersky software?
Please let me know?
Thanks.
  1. Kaspersky detected a virus and said it needed to restart and after restart neather kaspersky nor explorer.exe started. After vaiting a while I run explorer.exe manuelly from task meneger. It doesnt start ever since.
  2. it was around agust 10 (not %100 sure though)
  3. I dont know
  4. Yes. I didnt even notice updates has stopped.
  5. Its been almost a year now
Userlevel 7
Badge +9
  1. Kaspersky detected a virus and said it needed to restart and after restart neather kaspersky nor explorer.exe started. After vaiting a while I run explorer.exe manuelly from task meneger. It doesnt start ever since.
  2. it was around agust 10 (not %100 sure though)
  3. I dont know
  4. Yes. I didnt even notice updates has stopped.
  5. Its been almost a year now

Hello @makifazder,
Thanks for posting back.
You need to prepare your system:
(1) Have you worked thru the (Windows/Explorer) procedures I posted before?
&
(2) Check all the Windows updates
&
(3) Uninstall Kaspersky leave it uninstalled
(3a) Reboot-power off/on
(4) Uninstall Bitdefender.
(4a) Reboot-power off/on
----
5 When the system is up to date, stable and Explorer working:
(6) Download and install Kaspersky
(6a) Reboot-power off/on
(7) On system restart, make sure KAV is active,
(7a) Run manual database update
(7b) Run manual Full scan
(7c) Synchronize KAV application with MyKaspersky account.
Please keep us updated?
Thank you.
Hello, i had the same problem as makifazder5. This did the trick for me:

https://answers.microsoft.com/en-us/windows/forum/windows_10-performance/soundmixerexe-error-on-startup/85e30193-a5d3-4ceb-86c3-7d35acdb4d7e
Hello, i had the same problem as makifazder5. This did the trick for me:

https://answers.microsoft.com/en-us/windows/forum/windows_10-performance/soundmixerexe-error-on-startup/85e30193-a5d3-4ceb-86c3-7d35acdb4d7e


It worked! Thank you so much.
But this doesnt make anysense. I've tried this before and in [HKEY_CURRENT_USER\Software\Microsoft\Windows NT\CurrentVersion\Winlogon] folder, the shell value was explorer.exe and it still didn't work. Now I tried it with the instructions on your link and it worked. I deleted [HKEY_CURRENT_USER\Software\Microsoft\Command Processor] foder than I went to [HKEY_CURRENT_USER\Software\Microsoft\WindowsNT\CurrentVersion] as instracted but Winlogon sub-folder didn't appear under currentversion folder(it was empty). So I restarted the windows I opened regedit againg it was there and the Shell value was %comspec% so I changed it to explorer.exe and it worked.