Kaspersky
Solved

I cannot access any of the Kaspersky settings with Input Director software on Networked PCs [MOVED]

  • 10 May 2019
  • 8 replies
  • 179 views

Hi I've just downloaded Internet security as a trial to my two netwoked PCs, I use Input Director to control both with one single keyboard and mouse. However although it works well I cannot access any of the Kaspersky settings as the mouse and keyboard are disabled around the borders of Karspersky interface. Read a post where the only solution offered was to disable Self Defense which indeed solves the issues but can cause security issues makes using the software pointless.

I am thinking of purchasing license for 3 devices but unless there is a genuine solution without jeopardising security then I'm afraid I won't do so. Surprised this an issue when all previous other vendors packages never has a problem. Look forward to a possible resolution.

regards

//Mod Note: moved to proper section.
icon

Best answer by Schulte 12 May 2019, 15:10

Hello skywreck,

please note FLOOD's questions in the previous post.

I have come up with another possible solution:
Open KIS and go to 'Settings->Protection->Application Control'.
Click on 'Manage Applications' below.
In the next window search for the program file of 'Input Director' and double click on it.
Go to the Exclusions tab.
Enable 'Do not monitor application activity' and (if available) 'Allow Interaction with the Kaspersky Interface'.
Click on 'Save', close all windows and check if there is a change.
View original

8 replies

Userlevel 7
Badge +5
Hello Skywreck,
Welcome!
May we have the following information please:
KIS version?
Devices Operating system/s / versions?
Input Director version?
Screen print/s showing "mouse and keyboard disabled around the borders of Kaspersky interface"?
GSI - https://support.kaspersky.com/common/diagnostics/3632
Thanks.
Well it seems I was too hasty in posting for after Karspersky was installed in both PCs and granting various permissions and a couple of reboots, all well. Great smooth security so far.

thanks and regards
Userlevel 7
Badge +5
Hello Skywreck,
Great to hear, it never hurts to post a query!
Thanks!
Unfortunately this issue is not resolved. Attached System report and a video showing how when enabling Self Defence on the client PC the input director mouse is disabled on any Kaspersky window and how a locally attached mouse does indeed has full access. This happens even when a local mouse in client is not active. The master PC does not have any issues and is a windows 10 Pro 64 and the client is a Windows 7 64. The Input director version is the current one v1.4.1. - I have now bought and activated a licence for 3 devices. Never have had this issue with any other previous antivirus/Internet security packages, other than this issue I'm very happy with your product.

Report

Video

Regards
Userlevel 7
Badge +5
Hello Skywreck,
Thanks for posting back.
May I ask, is the original problem: "cannot access any of the Kaspersky settings as the mouse and keyboard are disabled around the borders of Kaspersky interface", slightly different to current issue: "input director mouse is disabled on any Kaspersky window"?

And, it's very hard (for me) to see, on the left hand side it looks like there are 2 shortcuts being accessed, 1 (input director?), the other (?S_Cll?) is it possible to move these to a more central/visible position & reproduce please?

For my understanding, when [ ]Self Defence is unselected that's using the locally attached mouse? Is that correct?

Also, referring to the following image, your .mp4 does not show a PopUp when [ ]Self Defence is changed, is that correct?


& please let us know:
  1. KIS [Security Level] setting?
  2. Secure Data Input Settings?
  3. Is KISDT version 3.1.10.217 software still installed?
Thanks!

https://help.kaspersky.com/KIS/2019/en-US/87342.htm
Hello Skywreck,
Thanks for posting back.
May I ask, is the original problem: "cannot access any of the Kaspersky settings as the mouse and keyboard are disabled around the borders of Kaspersky interface", slightly different to current issue: "input director mouse is disabled on any Kaspersky window"?


No, basically as soon as Self Defence is activated on the client using the mouse via Input Director, it becomes impossible to access any Kaspersky windows, but the Input Director mouse still works outside Kasperky's windows at this point no pop-up appears.


And, it's very hard (for me) to see, on the left hand side it looks like there are 2 shortcuts being accessed, 1 (input director?), the other (?S_Cll?) is it possible to move these to a more central/visible position & reproduce please?

For my understanding, when [ ]Self Defence is unselected that's using the locally attached mouse? Is that correct?


No. When Self Defence is deactivated on the client the Input Director mouse works perfectly on all windows including Kaspersky's

Also, referring to the following image, your .mp4 does not show a PopUp when [ ]Self Defence is changed, is that correct?


Please see new video capture linked below.


& please let us know:
KIS [Security Level] setting?Security Level setting MinimumSecure Data Input SettingsNot sure where to find itKISDT version 3.1.10.217 software still installed?

Where can I find it?

Link to updated video below.



Link to updated videoOn this video you can clearly see what happens when I enable Self Defence on the client. Only Input Director mouse active.

If I then connect an additional wireless/cable mouse to client while Input Director still active the local mouse works fine with everything but Input Director one still cannot access Kaspersky's windows

Trust this clarifies the issue.

regards
Userlevel 7
Badge +4
Hello skywreck,

please note FLOOD's questions in the previous post.

I have come up with another possible solution:
Open KIS and go to 'Settings->Protection->Application Control'.
Click on 'Manage Applications' below.
In the next window search for the program file of 'Input Director' and double click on it.
Go to the Exclusions tab.
Enable 'Do not monitor application activity' and (if available) 'Allow Interaction with the Kaspersky Interface'.
Click on 'Save', close all windows and check if there is a change.
Thank you very much Schulte, your instruction worked fine but had to apply it to all three executables in the Input Director folder.

Consider this issue solve.

Thanks to all.

Reply / Ответить