Kaspersky
Solved

HW virtualization and virtual machine [Closed]

  • 11 February 2020
  • 30 replies
  • 671 views

Userlevel 7
Badge +3
  • Platinum Senior Helper
  • 591 replies

Hi,

I want to ask you if still can not use VM because kaspersky use HW virtualization…

In past i ran VM and in kaspersky was disabled this. I want to know if now it is fixed - use for kaspersky hw virtualization and for VM also in same time without problem..

Or still there is a problem?

icon

Best answer by nexon 12 April 2020, 23:22

View original

This topic has been closed for comments

30 replies

Userlevel 7
Badge +11

Hello @nexon,

Welcome back!

As per Kaspersky experts: Feb 14 2020, 3:45:28 PM

quote:

Kaspersky hyperv and and other applications' hyperv cannot run at the time. 

When hyperv is also running in another application, Kaspersky's hyperv protection becomes unavailable.

end quote

This is as per design. 

Thank you:pray_tone3:

Flood:whale:

Userlevel 7
Badge +8

@nexon: I use KTS2020 inside W10 Pro x64 running in VMWare without issues…

 

The issues come when used Microsoft HyperV, it seems only 1 hypervisor running on system is allowed...

Userlevel 7
Badge +3

Hello @FLOOD and @harlan4096

 

Hmmm in KIS is problem with hw VM and in KTS without problem? 

Userlevel 7
Badge +11

Hello @nexon,
Have you ever asked Kaspersky Technical Support experts?

(imo) there’s no harm in having 3 “answers”:thinking:

Thank you:pray_tone3:

Flood:whale:

 

Userlevel 7
Badge +8

It shouldn’t have any issue, as KTS and KIS are “the same” products, KTS some additional features…

 

Added: https://support.kaspersky.com/us/common/safemoney/13713?cid=KTS_21.0#block1

Userlevel 7
Badge +3

@FLOOD i will contact tech support today but teply from support will be in monday probably.

 

@harlan4096 then why i can not use in my system? I know that KTS is same product with aditional features..

So if you uninstall KTS an instal KIS and try my scenario? Can you do this? 

Maybe KIS have Bug and KTS no? Hmm

Userlevel 7
Badge +8

So if you uninstall KTS an instal KIS and try my scenario? Can you do this? 

Hum I don’t think so, probably They share the same code at this point, so there should not be any difference…

 

What is the error You get when trying KIS inside VM? VMWare, VirtualBox?

 

 

Userlevel 7
Badge +3

Error is in kaspersky - KIS detected that hw is Turner off (vnwwre use hw) and KIS detecting that is off... I cant enable must uninstall VM then reset PC into bios disable vt restart PC alto desktop again restart PC boot into bios enable vt and checkbox in KIS enable vt .. 

 

Because When i only uninstall VM KIS still detecting that VM is not available so mušt boot into bios turn of after restart turn on .. 

Userlevel 7
Badge +8

I have 2 vms now with Kaspersky Home products: 1 with KTS2020h and the other with KSCloud Free 2020h, both running in host W10 Pro x64 inside a virtualized W10 Pro x64 in VMWare WorkStation.

 

These are the settings I have there:

 

 

I have an AMD Athlon II X3 450 @ 3,2 ghz + 8 GB RAM, and virtualization support enabled in BIOS…

 

What is Your CPU/Mother Board?

Userlevel 7
Badge +3

Wmvare workstation latest version? 

 

I have win 10 Pro latest... Runing on core i7 8700K with 16 GB RAM and ssd etc... Enable vt in bios.

Without VM all Works in KIS When instal vm KIS hw not working. 

Userlevel 7
Badge +8

Your system is by far more powerful than mine...

Userlevel 7
Badge +3

I think so... 

Hm i am now on mobile device... But i will try install vm again and i post here result.. 

I will update you here. 

 

IF problem will presist then i contact tech supp. 

Userlevel 7
Badge +3

Hmm in Kaspersky is not feature enable or disable HW??? Because was in Safe money settings and nothing here …

And also in Setting > additional> Additional protection and managment … there is only KSN cloud and marketing purposes…

It was removed from kaspersky?

Userlevel 7
Badge +8

Hum I don’t think so :thinking: I’m testing KTS2021beta and I have still those settings… patch H installed in K2020?

Userlevel 7
Badge +3

Yes patch h installed and i dont see this option on earlier version i saw this

 

 

 

Userlevel 7
Badge +8

Is that KIS2020 inside a virtual machine?

Userlevel 7
Badge +3

I use KIS 2020 on REAL machine and VM machine is whatever i use (i mean that problem is in REAL machine with KIS 2020)

Userlevel 7
Badge +8

I would completely uninstall KIS2020 with its standard uninstalled → Windows Control Panel, assure hw vt is enabled in BIOS, and then clean install again, update to get all the patches and reboot… if still no hw vt setting then → KL Support...

Userlevel 7
Badge +3

I dont see any restrictions but only cant see option enable / disable hv in KIS.

Userlevel 7
Badge +3

So i uninstalled KIS restarted pc then installed kis (i saw there is a installer with patch g) i check if there is option to turn on or of VT was there :) but i updated (patch h) and restarted pc again does not exists… Hmmm maybe KL removed it?

Userlevel 7
Badge +3

Quick update : I contacted tech supp…

@harlan4096 You have 2021 beta version i installed also on VM newest build 21.0.41.1458 and i dont see there also nothing about VT.

Userlevel 7
Badge +8

So, maybe some issue with Your hardware specs, maybe with BIOS vt hw support or CPU...

Userlevel 7
Badge +3

I dont think so it is my hw Because patch g Works great and patch h not working.. You have patch h and you see this option? 

Userlevel 7
Badge +8

I just got the patch H in a Vm running KTS2020, and also I don’t have the hw vt setting in my KTS2020, but I have it with my real system + KTS2021 last beta…

 

Probably it is a patch H issue...

Userlevel 7
Badge +3

Yes tis is what i talkig about…