How to maintain firewall rules on a network device [Closed]

  • 22 January 2020
  • 2 replies

Hi, I am using KIS 20 on Windows 10 pro and docker. I have an annoying problem, since I don’t have docker running all times, every time I start it, it starts the hyper-v machine that creates a network device to expose the services. However, even if it has always the same ip and name, KIS firewall identify it as a public network instead of a local one. In this way I can’t use external volumes on docker because it can’t see the smb share. I already tried to set to the network adapter to put the new connections to the local network group but it doesn’t maintain it. A reboot and the settings are vanished. Is there a way to fixate the ip to always identify it as a local network instead of public? Thanks


Best answer by Igor Kurzin 23 January 2020, 06:54

View original

This topic has been closed for comments

2 replies

Userlevel 7
Badge +5

Welcome. Your environment appears to be complex, so please contact Tech Support. 



Please attach the following items to your Tech Support request: 

a. Description of the issue.
b. Screenshot, as needed.
c. GSI

Userlevel 7
Badge +6

Hi @Ripper346 

Please also include traces in your request to technical support:


  • enable traces
  • restart PC
  • reproduce the issue (status of the network is public)
  • make a screenshot
  • stop traces
  • send all the data to support via cloud drive (dropbox, onedrive, etc.)