Kaspersky
Solved

Firefox 72 tells me I am trying to use an older version of itself. Kasperski Safe Money. [Closed]


After updating Firefox to v 72: Every time I try to access web from  Kasperski Money Safe. with Firefox as default browser. Firefox tells me I am trying to use an older version of itself and to create a new profile. Which means all my bookmarks and history etc. are missing in the new profile. I have used about:profiles and found the old browser but it does not open into Money safe. Even when I set a new profile the same thing happens next time I attempt to access the web. I have reset browser default to other browsers but still Firefox persists in Kasperski Internet Security. Any help gratefully appreciated. Thanks

icon

Best answer by Schulte 27 January 2020, 21:12

Hello @jph,


please try this:
close all browser windows.
Go to the directory 'C:\ProgramData\Kaspersky Lab\' and rename the folder 'SafeBrowser', e.g. to 'SafeBrowser.old'. You may need to disable the self-protection.

How to enable or disable Self-Defense in Kaspersky Internet Security

Then start the secure browser.

note: 'ProgramData' is a hidden directory.

How to enable access to hidden folders

View original

This topic has been closed for comments

13 replies

Userlevel 7
Badge +9

Hello @jph,

Welcome!

  1. Which browser is configured as Windows default browser
  2. With your original Firefox - is a Master password used?
  3. Is Malwarebytes Premium installed? 

Please let me know?

Thank you:pray_tone3:

Flood:whale:

Userlevel 7
Badge +8

it does not open into Money safe. 

Also, can you please verify your Kaspersky Protection Add-on version.
Concerning your FF profile issue did you visit “support_mozilla _org”
Please let us know.

Thank you, Flood and Bernie, for your interst. First: as I mentioned in my message, I have tried setting browser to Firefox, then to internet explorer, then to Chrome. However as I said the problem persists. It seems to make no difference which browser I set to default. I have Kaspersky Internet Security 2019, I am not sure what you mean by ‘Protection-add-on version’.. I havn’t got a FF profile. I never have had. I have also posted a question about this problem on the FF support forum, the only advise was to check profiles, as mentioned in my original message. Up until the recent update to version 72 everything worked fine. No master password is used or set. Windows 10 Pro 64 bit.

Same here, upgraded to 72.0.2 (64bit) and suddenly a new tab that invokes Safe Money makes Firefox give that error message. See picture.

 

Opening a new private tab or normal tab does not bring this message so something has gotten corrupt in Firefox in relation to Kaspersky Safe Money.

 

I do not want to create a new profile just for the Safe Money mode to function, not sure what will happen with my normal tabs if I do…

 

Regards

Userlevel 7
Badge +7

Hello @jph,


please try this:
close all browser windows.
Go to the directory 'C:\ProgramData\Kaspersky Lab\' and rename the folder 'SafeBrowser', e.g. to 'SafeBrowser.old'. You may need to disable the self-protection.

How to enable or disable Self-Defense in Kaspersky Internet Security

Then start the secure browser.

note: 'ProgramData' is a hidden directory.

How to enable access to hidden folders

Thank you very much Schulte. Your fix worked perfectly. I would like to also post this fix on the Firefox support site, with your permission of course. Thanks again.

Userlevel 7
Badge +7

I'm very happy to hear that.

You are welcome to share the fix wherever you want.

PS: you can delete the .old directory when you get the time to do so.

Thanks, works for me as well.

This message is for Schulte : I have created an account today just to be able to say THANK YOU for sharing this solution! I cannot believe that FF and Kaspersky are so slow in reaction when users are keep flagging issues on various sites about their specific product. ...and Kaspersky is a well paid one!

Anyway, thanks again Schulte ! You put an end to a three day unexpected and unnecessary misery. Cheers !

I have the same problem running win7 64 bit.

I do not have a “program data” folder on the C drive and cannot locate the “safe browser” folder.

Userlevel 7
Badge +8

I do not have a “program data” folder 

Welcome.
Please see above “ Best answer by @Schulte “ :
“How to enable access to hidden folders”

Ok thanks, that works. Missed it in my hurry.

Now to reload my old bookmarks, getting increasingly frustrated with firefox. This problem seems to recur from time to time.