Kaspersky
Solved

error updating components SW2 and KLAVA. Database update failed! [Closed]

  • 3 May 2019
  • 9 replies
  • 2370 views

I was able to update the database on daily basis but since this morning it's been failing with error updating components SW2 and KLAVA. Please help me resolve this error! Thank you!
icon

Best answer by Igor Kurzin 30 May 2019, 12:30

View original

This topic has been closed for comments

9 replies

Userlevel 7
Badge +8
Hello sunshines, welcome to the new forum.

The easiest way is:
  • uninstall your KLprodukt (keep only the activation data)
  • reboot
  • reinstall the product
Had the same problem with the same errors showing, only just noticed that the databases had not updated for two days, I can confirm that after a reinstall updates are now back to normal.
Hello sunshines, welcome to the new forum.

The easiest way is:
  • uninstall your KLprodukt (keep only the activation data)
  • reboot
  • reinstall the product

Thank you but it works only for 2 days. Then the error appears on the 3rd day. It's pain in the neck to uninstall and reinstall every 2 days! The tech people told me the same thing but it doesn't seem like a permanent solution.
Had the same problem with the same errors showing, only just noticed that the databases had not updated for two days, I can confirm that after a reinstall updates are now back to normal.
Did you run into the same issue after 3 days?
Userlevel 7
Badge +5
Welcome. Your best bet is to continue with Tech Support, if the error recurs after a few days.

There are two courses of action. One is to post your GetSystemInfo report here, so forum users can help, and the other is to Contact Tech Support.

1. Please post your GetSystemInfo report link, instructions: https://support.kaspersky.com/common/diagnostics/3632
Please upload the GetSystemInfo zip folder that is inside the larger GSI zip to the GSI parser site http://www.getsysteminfo.com/ and post the url to the parsed report here, in your next post.

2. Please contact Tech Support: https://my.kaspersky.com/support/

Please attach the following items to your Tech Support request:

a. Description of the issue.
b. Screenshot, as needed.
c. GSI
Did you run into the same issue after 3 days?

No, I am running W10 and have had no problems since the re-install twenty days ago, it would appear to have fixed the problem for me as databases are all updating without further issues.

When you remove Kaspersky do you do a reboot before installing again?
Userlevel 7
Badge +11
Hello Sunshines & Cajef,

Re: "When you remove Kaspersky do you do a reboot before installing again?"

Standard "best practice" method for any software/hardware change:
Reboot between each step.
Example:
  • Remove application
  • Reboot
  • Install/reinstall application
  • Reboot
Also, just to keep in mind, with Kaspersky Lab, if ever you reach out to the Technicians for assistance, as a general rule, they will always want traces, and they want traces that have been "caught" following these steps:
  • Problem happens
  • Turn on traces
  • Reboot
  • Replicate problem
  • Turn off traces - save
  • Create GSI, save
  • Submit: definition of problem, steps taken to recover, images, traces & GSI.
The only time they vary this is if "fastboot" is used, in which case the requirements are the same EXCEPT instead of the REBOOT step they request:
  • Problem happens
  • Turn on traces
  • EXIT Kaspersky application.
  • RESTART Kaspersky application
  • Replicate problem
  • Turn off traces - save
  • Create GSI, save
  • Submit: definition of problem, steps taken to recover, images, Traces, GSI.
And, as you'll probably surmise, the replicate "problem/issue" can be "tricky" if "it" happened "out of the blue."

Anyway, let's hope you never have to go thru the process, if you do, you'll have some guidance.
Best regards!
Userlevel 7
Badge +6
I was able to update the database on daily basis but since this morning it's been failing with error updating components SW2 and KLAVA. Please help me resolve this error! Thank you!

Hi, sorry to hear about this trouble, please tell me the number of the incident to technical support. The workaround is to restart Kaspersky product (exit via system tray icon and then start again) and update bases.
Userlevel 7
Badge +7
Update error: “Not all components were updated”