Kaspersky
Question

Connection not protected, "...certificate chain is not up to date"

  • 24 April 2019
  • 3 replies
  • 962 views

Userlevel 1
Today when i tried to visit this site with Google Chrome v74.0.3729.108 (64-bit):
https://forum.kajgana.com/
i got these notifications:




So, my question is:
Am i safe to visit this site or i'm not safe and should not visit that site until the problem with the certificate is not solved?
Thanks for your answers! 🙂

3 replies

Userlevel 1
Today i contacted the admin of the site, and he told me that they already know that the certificate has expired and the problem will be solved today or tomorrow.
Anyway, thanks for your answers, guys. I appreciate it! 🙂
Now, you can can mark this Topic as SOLVED or LOCK it for further comments.
Userlevel 5
Badge
Hi, yes, richbuff, you are right, the certificate is expired and that's why there is this warning from Kasperky product. If you trust the site, and wish to escape these notifications, please add the site https://forum.kajgana.com/ to exclusions via Kaspersky product Settings -> Additional -> Network -> Manage Exclusions -> Add.
More information about the nature of certificate errors here: https://support.kaspersky.com/12489
Userlevel 7
Badge +1
Well, I am not a certificate expert, but it looks like the security of your connection is reduced, because one or more certs on the chain is not up to date.

Maybe, if you understand the risk, you may wish to buck advisement and continue.

Reply / Ответить