Kaspersky
Solved

Cannot browse some website


Hi, i am using Mac kaspersky. I cannot browse Netflix today since ‘Your connection is not a private connection’, but i still browse yesterday. I can browse Netflix if i  close the kaspersky application. Is there any problem? 

 

icon

Best answer by Ania 2 July 2020, 12:02

Hi guys, 

I’ve heard from Kasperky Technical Support again and they informed me that the issue should be solved now. I switched back on the "check secure connection (https).."  option in the preferences and checked all the websites - and they’re working now! :relaxed:  Seems that the issue is solved! Hooray! 

Would advise you checking if it works for you too. 

View original

22 replies

Userlevel 7
Badge +9

Hello @Evan,

Welcome!

  1. To help us, please tell us everything that’s written on the image? 
  2. Which application is Net::ERR_CERT_VALIDITY_TOO_LONG error showing in? 
  3. What’s changed since yesterday? 
  4. What is the MAC operating system version?
  5. KIS version & patch(x)? x = letter
  6. Which browser is used to access Netflix? 
  7. In KIS Reports, are there any certificate errors, if “yes” may we have a copy of the report, attached:paperclip: as a .txt file please?
  8. Is Kaspersky Secure Connection or any VPN, installed and active? 

Please post back?

Thank you:pray_tone3:

Flood:whale:

@Wesly.Zhang, please join @Evan’s topic. 

  1. Your connection is not private

    Attackers might be trying to steal your information from vkontakte.ru (for example, passwords, messages or credit cards). Learn more

    NET::ERR_CERT_VALIDITY_TOO_LONG

  2. Chrome, Safari (Firefox is not displaying this message and site is loaded into browser)
  3. not sure what exactly changed, but 2 days ago sites vkontakte.ru and vk.com were accessible
  4. 10.15.5
  5. 20.0.0.829b
  6. error shown regardless of vpn status (on or off)

If I switch off option “Check secure connections (HTTPS) for safe money and private browsing” - I can access the site.

 

You need to check how HTTPS or your technology for encrypted sessions works and what your timeout is.  

Userlevel 7
Badge +9

Hello @Evan & @Slava_Z,

  • After submitting the case, you’ll receive an automated email with an INC+12digits reference number, then, normally, within 5 business days, a Kaspersky Technical Support human will communicate with you, also by email, you may continue to engage with the Kaspersky Technical Team via email or by updating the INC in your MyKaspersky account.
  • Please post the INC# here in this topic? 
  • Please let us know the outcome when it’s available? 

Thank you:pray_tone3:

Flood:whale:

Userlevel 7
Badge +9

Hello @Evan & @Slava_Z,

@Palasv Since this morning, access to Microsoft 365 Admin is impossible. “Safari can’t establish a secure connection”, has posted a response from Kaspersky Technical Support, as follows:

  • Correction in progress!

Answer from the support :

*****

Greetings and thank you for contacting Kaspersky Technical Support. My name is Konstantin and I will be assisting you with this query. The issue you encountered is caused by a bug which has been identified and is under investigation by our developer team. No diagnostics are required at the moment and the workaround to be able to work with your browser is the following: Open Kaspersky Preferences (click on its icon on the Menu bar) - Protection: uncheck the option next to "Check secure connections (HTTPS) for Safe Money and Private Browsing" We will keep this ticket open until the bug is resolved and we will send you an email to inform you when this happens. Please ignore the note below that the ticket will be considered resolved if you do not reply in 7 days as it does not apply to you. Apologies for any inconvenience this causes but it should be sorted soon.

Thank you!

*****

Flood:whale:

Here also facing the same issue for the following website.

it was accessed until yesterday.

https://www.etisalat.ae/b2c/rd-login.html

Userlevel 1

I also have the same problem. Receiving the following message when trying to access a number of websites: 

Your connection is not private

Attackers might be trying to steal your information from ‘name of the website’ (for example, passwords, messages or credit cards). Learn more

NET::ERR_CERT_VALIDITY_TOO_LONG

 

The websites open fine once I uncheck the option next to "Check secure connections (HTTPS) for Safe Money and Private Browsing".  Would be great to be updated on the situation and the progress of resolving this current bug. I also made a request with the Technical Support as advised by FLOOD. 

 

Userlevel 7
Badge +9

Hello @Ania

Welcome! 

And thank you for logging a case and updating us:ok_hand_tone3:

  • From the Kaspersky Technical Support response to @Palasv’s case, it seems the Kaspersky Technical Team are working on the bug, even tho there’s no eta, that’s a positive response. 
  • There’s a few people tracking this, so we expect updates here and or in @Palasv’s topic, also, when Kaspersky Technical Support respond, ask them to keep you updated please? 
  • And, if you get any feedback, please share it here in the Community?

Thank you:pray_tone3:

Flood:whale:

Started having same problem since yesterday, so annoying.

Issue is only in CHROME: ERR_CERT_VALIDITY_TOO_LONG for most of the websites and also site not secure error and also some of the contents (Pic, videos etc) do not appear.

Removed Chrome completely from my Mac, restarted and re-installed multiple times.

Everything works if I Stop Protection. Please fix it

 

Same issue here guys:

 

Your connection is not private

Attackers might be trying to steal your information from github.com (for example, passwords, messages or credit cards). Learn more

NET::ERR_CERT_VALIDITY_TOO_LONG

Userlevel 1

This is the reply I just received from the Kaspersky Technical Support. Same advice as mentioned already in this thread: 

“Recently an issue arose on Kaspersky Internet Security/Kaspersky Security Cloud on Mac, and you are unable to visit certain secure websites. We are aware of the issue, and our developers are working for a fix. At the moment, there is a workaround you can use to visit such websites.

Please click on the Kaspersky icon on the top right corner and choose preferences. On the protection tab, disable the option "check secure connection (https).." and try to visit the website again. I suggest using this workaround to visit the secure websites but not the banking websites since Safe Money won't work after this workaround. If it's urgent to use your banking websites, please use another computer, preferably a Windows one.

I will keep the incident open in our database and I will keep you posted by sending you a new email when we fix this issue permanently.” 

 

I will post an update here, once they let me know they have sorted out this issue. For now it just looks we have to keep operating without the Safe Money option. Hopefully it will happen sooner rather than later. 

Userlevel 7
Badge +4

Hello,

Please let us know the site certificate type. Is it a SSL 3 certificate?

And does kaspersky lab fake certificate be invalid ?

Regards.

Userlevel 1

Hi guys, 

I’ve heard from Kasperky Technical Support again and they informed me that the issue should be solved now. I switched back on the "check secure connection (https).."  option in the preferences and checked all the websites - and they’re working now! :relaxed:  Seems that the issue is solved! Hooray! 

Would advise you checking if it works for you too. 

Userlevel 7
Badge +9

Hello @Ania,

Excellent work:clap_tone3:

Thank you so much for taking the time to update us:ok_hand_tone3:

Flood:whale:

I know it is easy to throw fruit and software is extremely annoying, but how is office.com not part of a basic smoke test?  This seems like a really easy way to save your customers hassle.

Unfortunately, the issue still hasn’t been resolved for me three days after this has started. I followed the short term solution of unselecting “Check secure connections (HTTPS)...” on Preferences. However, when I select it back, I can’t access the website again. I have the same problem with the OP, I can’t access Netflix. I hope there will be a solution soon as I, too, use banks often and need Safe Money enabled.

Userlevel 7
Badge +9

Hello @Jakone,

Thank you for updating us:ok_hand_tone3:

Please log the request, follow the template and the request requirements provided above and please add the INC # to your reply? 

Thank you:pray_tone3:

Flood:whale:

I also got the same problem that when accessing to certain websites, however, my Kasperky account has been expired…Could anyone teach me how to solve the same problem without purchasing Kasperky service again…

Userlevel 7
Badge +9

Hello @ctw13,

Welcome!

  • When you say “my Kasperky account has been expired”, does that mean the Kaspersky license subscription has expired? 
  • It’s important to note: when the license expires, there may be given a grace period to renew the license. The application remains functional during the grace period. When the license expires and the grace period is over, the application continues to operate with limited functionality (for example, updates and Kaspersky Security Network become unavailable). You can still use some application components and run virus scans, but only with the anti-virus databases that were installed before the grace period ended. To continue using the full functionality of Kaspersky Internet Security, you have to renew the license.
  1. May we have images and more detail of what is not working, if the issue is due to an expired license with an expired grace period, there’s no solution, other than to renew the license. 

Please post back?

Thank you:pray_tone3:

Flood:whale:

Hello @FLOOD 

What I mean for the expiry of the account is shown as the attached photo (1) as follows, “Your key is invalid. Protection is disabled. Please contact Technical Support.”

But, when I clicked the button “Contact Technical Support”, it shows the following information with reference to the attached photo (2). 

I’m sorry that I don’t ensure whether my licence is still during the grace period or not, but the only thing I know is that I can no longer use the limited functions as you mentioned above (e.g. some application components and run virus scans).

Thank you so much for your time and warm help.

Please let me know if you need any information and details. 

photo (1)

 

photo (2)

 

 

@ctw13 Hello,

Do you know your new Activation Code?

You can try to reinstall KIS and try to activate it with your new Activation Code.

This problem is happening on my Mac today.

 

Mac OSX version 10.15.7

Chrome is up to date, so is Safari -- “Not private connection” happens in both browsers

 

The problem goes away ONLY after I uninstalled AND disconnected Kaspersky (from web portal). In fact, after I disabled the client, this problem goes away too.

 

So I am pretty sure this is caused by Kaspersky software. 

Userlevel 7
Badge +9

This problem is happening on my Mac today. Mac OSX version 10.15.7, Chrome is up to date, so is Safari -- “Not private connection” happens in both browsers, The problem goes away ONLY after I uninstalled AND disconnected Kaspersky (from web portal). In fact, after I disabled the client, this problem goes away too. So I am pretty sure this is caused by Kaspersky software. 

Hello @kasper_in_house

  1. Uninstall KIS, follow the documentation carefully. 
  2. Shutdown MAC completely, power on, login. 
  3. Confirm Prepare for installation
  4. Install KIS 
  5. Recheck “Not private connection” issue? if it persists: 

 

 

  • After submitting the case, you’ll receive an automated email with an INC+12digits reference number, then, normally, within 5 business days, a Kaspersky Technical Support human will communicate with you, also by email, you may continue to engage with the Kaspersky Technical Team via email or by updating the INC in your MyKaspersky account.
  • Please let us know the outcome when it’s available? 

Thank you:pray_tone3:

Flood:whale:+:whale2:

Reply