Kaspersky
Question

After incomplete drag and drop icon uninstall of KIS, my iMac won't boot

  • 9 November 2021
  • 0 replies
  • 27 views

Hello everybody,

Event though I perfectly knew that it wasn’t the right method to uninstall Kaspersky Internet Security for Mac (I bought Total Security, but only KIS was available for Mac), I dragged and dropped the app icon on the trash bin. Later, I switched it off.

The day after, the iMac couldn’t complete the boot: it was stuck at the apple logo with progress bar (half).

I tried to boot in safe mode, I reinstalled Big Sur: nothing.

I’m quite sure (as you can see from the screenshot) that during the boot some Kaspersky (kernel?) extension are required, and since macOs cannot find them it goes in loop.

So, the question is: how can I complete uninstall KIS from my Mac, considering that I cannot boot?

I tried to use the Terminal available in Recovery Mode, but it’s in read only mode, and I don’t know what to do…

Can anybody help me?

 

iMac late 2015 with Big Sur

Kaspersky Internet Security for Mac (from a Total Security bundle)


0 replies

Be the first to reply!

Reply